Добро пожаловать!


Общая техническая информация

ONI

Общая техническая информация

Назначение и область применения

Сенсорные графические панели оператора предназначены для организации человеко-машинного интерфейса для контроля и управления различными автоматизированными процессами и системами.

Области применения панелей оператора: автоматизация различного технологического и инженерного оборудования, построение систем автоматизированного сбора и обработки информации, построение систем учета и распределения энергоресурсов, систем дистанционного управления и т. д.

Общие технические характеристики и условия эксплуатации

Параметр |  | Значение
Номинальное напряжение питания, В |  | 24 DC
Допустимый диапазон напряжений питания, В | А | от 9 до 28 DC
 | Б | от 18 до 28 DC
Диапазон температур при эксплуатации, C° | А | от 0 до плюс 50
 | Б | от минус 20 до плюс 70
Относительная влажность воздуха, % |  | 10..90, без конденсации
Степень загрязнения микросреды по ГОСТ Р МЭК 60664.1 |  | 2, без содержания агрессивных паров и газов в концентрациях, вызывающих коррозию металлов и разрушение изоляции
Способ охлаждения |  | естественное охлаждение окружающим воздухом
Степень защиты по ГОСТ 14254 |  | IP65 со стороны экрана, IP20 со стороны разъемов

ЭМС (предельные воздействующие факторы)

Параметр | Значение
Статический разряд в воздухе, кВ | 8
Статический разряд контактный, кВ | 4
Наносекундная импульсная помеха на линии питания, кВ | ±2
Наносекундная импульсная помеха на линии связи, кВ | ±1

Хранение и транспортировка панелей оператора осуществляются в заводской упаковке при температурах от минус 25 до плюс 70 C°, при относительной влажности до 90 % без конденсации. Не допускается воздействие атмосферных осадков и длительное воздействие прямых солнечных лучей.

Транспортировка допускается всеми видами транспорта, в том числе и воздушным, при соблюдении условий хранения и транспортировки, в соответствии с правилами перевозки грузов, действующими на каждом виде транспорта.

ONI


Варианты исполнения

ONI

Варианты исполнения

Параметр \ Артикул |  | ETG 4.3” | ETG 4.3” | ETG 7” | ETG 7” | ETG 7”
Диагональ экрана |  | 4.3’’ | 4.3’’ | 7’’ | 7’’ | 7’’
Разрешение экрана |  | 480x272 | 480x272 | 800x480 | 800x480 | 1024x600
Цветность |  | 24 бит | 24 бит | 24 бит | 24 бит | 24 бит
Яркость, кд/м2 |  | 360 | 300 | 360 | 360 | 450
Тип подсветки |  | LED | LED | LED | LED | LED
Тип сенсора |  | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный
CPU |  | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц
Объем ROM Объем RAM |  | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб
Опции | USB-A | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0
 | USB-B | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0 (micro)
 | COM1 | RS232/422/485 | RS232/422/485 | RS232/422/485 | RS232/422/485 | RS232/422/485
 | COM3 | RS232 | RS232 | RS232 | RS232 | RS232
 | COM2 | - | - | - | RS232/422/485 | RS485
 | COM4 | - | - | - | RS232 | RS485
 | Ethernet | - | 1x10M/100M | - | 1x10M/100M | 1x10M/100M
 | SD Card | - | - | - | 1 | 1
Диапазон напряжений питания* |  | А | А | А | А | А
Потребляемая мощность не более, Вт |  | 5 | 5 | 10 | 10 | 6
Материал корпуса |  | пластик | металл | пластик | пластик | пластик
Диапазон рабочих температур* |  | А | Б | А | А | А
Масса, кг |  | 0,3 | 0,465 | 0,575 | 0,6 | 0,65
Артикул |  | ETG-A8TS- HSSN-S-043 | ETG-CP-043 | ETG-A8TS- HSSN-S-070 | ETG-CP-070 | ETG-A8TH- HSSE-S-070

* Расшифровка обозначения представлена в разделе "общая информация".

Параметр \ Артикул |  | ETG 7” | ETG 7” | ETG 9.7” | ETG 9.7” | ETG 9.7”
Диагональ экрана |  | 7’’ | 7’’ | 9.7’’ | 9.7’’ | 9.7’’
Разрешение экрана |  | 800x480 | 800x480 | 1024x768 | 1024x768 | 1024x768
Цветность |  | 24 бит | 24 бит | 16 бит | 16 бит | 16 бит
Яркость, кд/м2 |  | 360 | 360 | 350 | 350 | 350
Тип подсветки |  | LED | LED | LED | LED | LED
Тип сенсора |  | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный
CPU |  | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц
Объем ROM Объем RAM |  | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб
Опции | USB-A | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0
 | USB-B | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0
 | COM1 | RS232/422/485 | RS232/422/485 | RS232/422/485 | RS232/422/485 | RS232/422/485
 | COM3 | RS232 | RS232 | RS232 | RS232 | RS232
 | COM2 | - | RS232/422/485 | - | RS232/422/485 | RS485
 | COM4 | - | RS232 | - | RS232 | RS485
 | Ethernet | - | 1x10M/100M | - | 1x10M/100M | 1x10M/100M
 | SD Card | 1 | 1 | - | 1 | 1
Диапазон напряжений питания* |  | А | Б | А | Б | Б
Потребляемая мощность не более, Вт |  | 10 | 10 | 10 | 10 | 10
Материал корпуса |  | металл | металл | пластик | пластик | металл
Диапазон рабочих температур* |  | Б | Б | А | А | Б
Масса, кг |  | 0,975 | 1,08 | 1,1 | 1,12 | 1,2
Артикул |  | ETG-A8TS- HSSN-P-070 | ETG-A8TS- HSSE-P-070 | ETG-A8TS- HSSN-S-097 | ETG-CP-097 | ETG-A8TS- HSSE-P-097

* Расшифровка обозначения представлена в разделе "общая информация".

Параметр \ Артикул |  | ETG 10.4” | ETG 12.1” | ETG 15”
Диагональ экрана |  | 10.4’’ | 12.1’’ | 15’’
Разрешение экрана |  | 800x600 | 1024x768 | 1024x768
Цветность |  | 24 бит | 24 бит | 24 бит
Яркость, кд/м2 |  | 500 | 370 | 400
Тип подсветки |  | LED | LED | LED
Тип сенсора |  | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный
CPU |  | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц
Объем ROM Объем RAM |  | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб
Опции | USB-A | 1x2.0 | 1x2.0 | 1x2.0
 | USB-B | 1x2.0 | 1x2.0 | 1x2.0
 | COM1 | RS232/422/485 | RS232/422/485 | RS232/422/485
 | COM3 | RS232 | RS232 | RS232
 | COM2 | RS232/422/485 | RS232/422/485 | RS232/422/485
 | COM4 | RS232 | RS232 | RS232
 | Ethernet | 1x10M/100M | 1x10M/100M | 1x10M/100M
 | SD Card | 1 | 1 | 1
Диапазон напряжений питания* |  | Б | Б | Б
Потребляемая мощность не более, Вт |  | 15 | 15 | 15
Материал корпуса |  | металл | металл | металл
Диапазон рабочих температур* |  | Б | Б | Б
Масса, кг |  | 2,02 | 2,71 | 4,3
Артикул |  | ETG-A8TS- HSSE-P-104 | ETG-CP-121 | ETG-CP-150

* Расшифровка обозначения представлена в разделе "общая информация".


ETG 4.3 ETG-A8TS-HSSN-S-043

ONI

ETG 4.3 ETG-A8TS-HSSN-S-043

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 4.3 ETG-CP-043

ONI

ETG 4.3 ETG-CP-043

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 7 ETG-A8TS-HSSN-S-070

ONI

ETG 7 ETG-A8TS-HSSN-S-070

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 7 ETG-CP-070

ONI

ETG 7 ETG-CP-070

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 7 ETG-A8TH-HSSE-S-070

ONI

ETG 7 ETG-A8TH-HSSE-S-070

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 7 ETG-A8TS-HSSN-P-070

ONI

ETG 7 ETG-A8TS-HSSN-P-070

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 7 ETG-A8TS-HSSE-P-070

ONI

ETG 7 ETG-A8TS-HSSE-P-070

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 9.7 ETG-A8TS-HSSN-S-097

ONI

ETG 9.7 ETG-A8TS-HSSN-S-097

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 9.7 ETG-CP-097

ONI

ETG 9.7 ETG-CP-097

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 9.7 ETG-A8TS-HSSE-P-097

ONI

ETG 9.7 ETG-A8TS-HSSE-P-097

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади


ETG 10.4 ETG-A8TS-HSSE-P-104

ONI

ETG 10.4 ETG-A8TS-HSSE-P-104

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 12.1 ETG-CP-121

ONI

ETG 12.1 ETG-CP-121

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETG 15 ETG-CP-150

ONI

ETG 15 ETG-CP-150

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


Варианты исполнения

ONI

Варианты исполнения

Параметр \ Артикул |  | ETC 7” | ETC 7” | ETC 9.7” | ETC 9.7” | ETC 17”
Диагональ экрана |  | 7’’ | 7’’ | 9.7’’ | 9.7’’ | 17’’
Разрешение экрана |  | 1024x600 | 1024x600 | 1024x768 | 1024x768 | 1280x1024
Цветность |  | 24 бит | 24 бит | 16 бит | 16 бит | 16 бит
Яркость, кд/м2 |  | 450 | 450 | 350 | 350 | 350
Тип подсветки |  | LED | LED | LED | LED | LED
Тип сенсора |  | емкостной | емкостной | емкостной | емкостной | емкостной
CPU |  | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц
Объем ROM Объем RAM |  | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб | 256 Мб 256 Мб
Опции | USB-A | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0 | 1x2.0
 | USB-B | 1x2.0 (micro) | 1x2.0 | 1x2.0 (micro) | 1x2.0 | 1x2.0
 | COM1 | RS232/422/485 | RS232/422/485 | RS232/422/485 | RS232/422/485 | RS232/422/485
 | COM3 | RS232 | RS232 | RS232 | RS232 | RS232
 | COM2 | RS485 | RS232/422/485 | RS485 | RS232/422/485 | RS485
 | COM4 | RS485 | RS232 | RS485 | RS232 | RS485
 | Ethernet | 1x10M/100M | 1x10M/100M | 1x10M/100M | 1x10M/100M | 1x10M/100M
 | SD Card | 1 | 1 | 1 | 1 | 1
Диапазон напряжений питания* |  | А | Б | А | Б | Б
Потребляемая мощность не более, Вт |  | 6 | 10 | 6 | 8 | 18
Материал корпуса |  | пластик-металл | металл | пластик-металл | пластик | металл
Диапазон рабочих температур* |  | А | Б | А | Б | Б
Масса, кг |  | 0,68 | 0,8 | 1,1 | 1,24 | 5,8
Артикул |  | ETC-A8TS- HSSE-S-070 | ETC-A8TS- HSSE-P-070 | ETC-A8TS- HSSE-S-097 | ETC-A8TS- HSSE-P-097 | ETC-A8TS- HSSE-P-170

* Расшифровка обозначения представлена в разделе "общая информация".

Параметр \ Артикул |  | ETC 22”
Диагональ экрана |  | 22’’
Разрешение экрана |  | 1920x1080
Цветность |  | 16 бит
Яркость, кд/м2 |  | 250
Тип подсветки |  | LED
Тип сенсора |  | емкостной
CPU |  | Cortex A8 600 МГц
Объем ROM Объем RAM |  | 256 Мб 256 Мб
Опции | USB-A | 1x2.0
 | USB-B | 1x2.0
 | COM1 | RS232/422/485
 | COM3 | RS232
 | COM2 | RS232/422/485
 | COM4 | RS232
 | Ethernet | 1x10M/100M
 | SD Card | 1
Диапазон напряжений питания* |  | Б
Потребляемая мощность не более, Вт |  | 20
Материал корпуса |  | металл
Диапазон рабочих температур* |  | Б
Масса, кг |  | 6,68
Артикул |  | ETC-A8TS- HSSE-P-220

* Расшифровка обозначения представлена в разделе "общая информация".


ETC 7 ETC-A8TS-HSSE-S-070

ONI

ETG 7 ETC-A8TS-HSSE-S-070

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETC 7 ETC-A8TS-HSSE-P-070

ONI

ETG 7 ETC-A8TS-HSSE-P-070

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETC 9.7 ETC-A8TS-HSSE-S-097

ONI

ETG 9.7 ETC-A8TS-HSSE-S-097

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETC 9.7 ETC-A8TS-HSSE-P-097

ONI

ETC 9.7 ETC-A8TS-HSSE-P-097

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETC 17 ETC-A8TS-HSSE-P-170

ONI

ETC 17 ETC-A8TS-HSSE-P-170

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


ETC 22 ETC-A8TS-HSSE-P-220

ONI

ETC 22 ETC-A8TS-HSSE-P-220

Габаритные размеры

Чертеж

Размер монтажного отверстия и вид сзади

Чертеж


Варианты исполнения

ONI

Варианты исполнения

Параметр \ Артикул |  | OEM 4.3” | OEM 5” | OEM 7”
Диагональ экрана |  | 4.3’’ | 5’’ | 7’’
Разрешение экрана |  | 480x272 | 800x480 | 800x480
Цветность |  | 16 бит | 16 бит | 16 бит
Яркость, кд/м2 |  | 300 | 300 | 300
Тип подсветки |  | LED | LED | LED
Тип сенсора |  | 4-проводный резистивный | 4-проводный резистивный | 4-проводный резистивный
CPU |  | Cortex A8 600 МГц | Cortex A8 600 МГц | Cortex A8 600 МГц
Объем ROM Объем RAM |  | 128 Мб 128 Мб | 128 Мб 128 Мб | 128 Мб 128 Мб
Опции | USB-A | 1x2.0 | 1x2.0 | 1x2.0
 | USB-B | 1x2.0 (micro) | 1x2.0 (micro) | 1x2.0 (micro)
 | COM1 | - | - | -
 | COM3 | - | - | -
 | COM2 | RS232/485 | RS232/485 | RS232/485
 | COM4 | RS232 | RS232 | RS232
 | Ethernet | - | - | -
 | SD Card | micro | micro | micro
Диапазон напряжений питания* |  | А | А | А
Потребляемая мощность не более, Вт |  | 5 | 5 | 5
Материал корпуса |  | без корпуса | без корпуса | без корпуса
Диапазон рабочих температур* |  | Б | Б | Б
Масса, кг |  | 0,25 | 0,3 | 0,3
Артикул |  | OEM-A8HS- HSSN-S-043 | OEM-A8HS- HSSN-S-050 | OEM-A8HS- HSSN-S-070

* Расшифровка обозначения представлена в разделе "общая информация".


OEM-A8HS-HSSN-S-043

ONI

OEM 4.3 OEM-A8HS-HSSN-S-043

Габаритные размеры

Чертеж


OEM-A8HS-HSSN-S-050

ONI

OEM 5 OEM-A8HS-HSSN-S-050

Габаритные размеры

Чертеж


OEM-A8HS-HSSN-S-070

ONI

OEM 7 OEM-A8HS-HSSN-S-070

Габаритные размеры

Чертеж


Монтаж оборудования

ONI

Монтаж оборудования

Выполните необходимое для установки отверстие в соответствии с монтажными размерами монтируемого устройства. | Установите устройство в монтажное отверстие, при этом необходимо проконтролировать правильность установки уплотнителя.
Монтаж | Монтаж

Вставьте металлические струбцины-фиксаторы из монтажного комплекта в отверстия на корпусе устройства и затяжкой винтов зафиксируйте фиксаторы и монтируемое устройство.

Монтаж


Схемы подключения

ONI

Схемы подключения

Вариант 1

Питание

Назначение контактов в разъеме подключения питания.

Разъем питания

Контакт | Обозначение | Описание
1 | DC24V | Источник питания [+]
2 | GND | Источник питания [-]
3 | FG | Заземление

COM1/COM3

Порты COM1 и COM3 объединены в один разъем DB9M, назначение контактов которого представлено в таблице.

Разъем

Контакт | Обозначение | COM1 RS232 | COM1 RS422 | COM1 RS485 | COM3 RS232
1 | RX- (B) |  | RX- | B- |
2 | RxD | RxD |  |  |
3 | TxD | TxD |  |  |
4 | TX- |  | TX- |  |
5 | SG | Общий
6 | RX+ (A) |  | RX+ | A+ |
7 | RxD |  |  |  | RxD
8 | TxD |  |  |  | TxD
9 | TX+ |  | TX+ |  |

COM2/COM4

Порты COM2 и COM4 объединены в один разъем DB9M, назначение контактов которого представлено в таблице.

Разъем

Контакт | Обозначение | COM2 RS232 | COM2 RS422 | COM2 RS485 | COM4 RS232
1 | RX- (B) |  | RX- | B- |
2 | RxD | RxD |  |  |
3 | TxD | TxD |  |  |
4 | TX- |  | TX- |  |
5 | SG | Общий
6 | RX+ (A) |  | RX+ | A+ |
7 | RxD |  |  |  | RxD
8 | TxD |  |  |  | TxD
9 | TX+ |  | TX+ |  |

Вариант 2

Питание

Назначение контактов в разъеме подключения питания.

Разъем питания

Контакт | Описание | Функция
1 | FG | Заземление
2 | DC- | Источник питания [-]
3 | DC+ | Источник питания [+]

COM1/COM3

Порты COM1 и COM3 объединены в один разъем DB9M, назначение контактов которого представлено в таблице.

Разъем

Контакт | Обозначение | COM1 RS232 | COM1 RS422 | COM1 RS485 | COM3 RS232
1 | RX- (B) |  | RX- | B- |
2 | RxD | RxD |  |  |
3 | TxD | TxD |  |  |
4 | TX- |  | TX- |  |
5 | SG | Общий
6 | RX+ (A) |  | RX+ | A+ |
7 | RxD |  |  |  | RxD
8 | TxD |  |  |  | TxD
9 | TX+ |  | TX+ |  |

COM2/COM4

Порты COM2 и COM4 объединены в один разъем, назначение контактов которого представлено в таблице.

Разъем

Контакт | Функция | COM2 RS485 | COM4 RS232
1 | A+ | A+ |
2 | B- | B- |
3 | GND | Общий |
4 | A+ |  | A+
5 | B- |  | B-
6 | GND |  | Общий

Ethernet

Назначение контактов в разъеме Ethernet.

Ethernet

Контакт | Описание | Функция
1 | TX+ | Data Send+
2 | TX- | Data Send-
3 | RX+ | Data Receive+
4 | NC | --
5 | NC | --
6 | RX- | Data Receive-
7 | NC | --
8 | NC | --

В зависимости от устройства к которому выполняется подключение необходимо выбрать соответствующий кабель. Кабель можно приобрести готовый или изготовить самостоятельно по приведенным ниже схемам.

Прямой кабель для подключения к ПЛК через коммутатор (Ethernet Switch)

Ethernet

Ethernet

Кросс-кабель для непосредственного подключения к ПЛК*

Ethernet

Ethernet

* В случае если ПЛК поддерживает функцию автоопределения типа подключения, можно использовать прямой кабель.


Новый раздел

ONI

Структура внутренней памяти

Внутренняя память устройства представлена несколькими разделами битовых и 16-разрядных регистров имеющих различное функциональное значение. Адрес каждого регистра определяется буквенным префиксом указывающим его тип и цифровым индексом. Описание и доступные диапазоны разделов приведены в таблице ниже.

Структура внутренней памяти

Адрес внутренней памяти |  | Формат | Сохранение данных при отключении питания | Примечание
Префикс | Диапазон
LB | 0-799999 | BIT | нет | Регистры данных
SRB | 0-11023 | BIT | -- | Системные регистры
LW | 0-799999 | WORD | нет | Регистры данных
RW | 0-524288 | WORD | да | Регистры данных
SRW | 0-11023 | WORD | -- | Системные регистры

Часть регистров внутренней памяти доступно для внешней коммуникации по протоколу Modbus при работе в роли ведомого (Slave). Соответствие адресов внутренней памяти устройства, адресам Modbus приведено в таблице.

Соответствие регистров внутренней памяти адресам Modbus в режиме ведомого

Адрес внутренней памяти |  | Формат | Адрес Modbus | Пример
Bit | Word (16 Bit)
LB 0-65535 | —— | DDDDD | 0X(n+1) n: 0-65535 | LB0 = 0X00001
LB 0-65535 | —— | DDDDD | 1X(n+1) n: 0-65535 | LB0 = 1X00001
—— | LW 0-9998 | DDDDD | 3X(n+1) n: 0-9998 | LW0 = 3X00001
—— | RW 0-55535 | DDDDD | 3X(n+10000) n: 0-55535 | RW0 = 3X10000
—— | LW 0-9998 | DDDDD | 4X(n+1) n: 0-9998 | LW0 = 4X00001
—— | RW 0-55535 | DDDDD | 4X(n+10000) n: 0-55535 | RW0 = 4X10000


Внешний вид

ONI

Обзор интерфейса программы

Интерфейс программы классический для программ платформы MS Windows и состоит из различных функциональных элементов, скомпонованных внутри основного окна программы.

Представленное на рисунке расположение является стандартной настройкой по-умолчанию, которая может быть изменена пользователем по своему усмотрению в процессе работы с программой.

Обзор интерфейса программы

Изменение положения и размеров окон можно выполнить с помощью указателя, захватив изменяемое окно левой клавишей мыши за заголовок, расположенный в верхней части, и переместив его в нужное положение. При этом, при перемещении на экране отображаются указатели парковки, которые позволяют упростить организацию окон внутри основного окна программы.

Для закрепления перемещаемого окна в желаемом месте просто наведите курсор на соответствующий указатель и отпустите клавишу мыши, окно будет закреплено в подсвеченной области.

Обзор интерфейса программы

В правом верхнем углу закрепленного окна расположены дополнительные элементы управления его внешним видом и поведением, назначение которых представлено на рисунке.

Обзор интерфейса программы

При необходимости, всегда можно изменить состав отображаемых окон через меню "Вид" или вернуться к настройкам внешнего вида заданным по умолчанию. Чтобы выполнить сброс настроек и возврат, необходимо перейти к пункту главного меню "Вид > Восстановить вид по умолчанию".


Обзор главного меню

ONI

Обзор главного меню

Главное меню расположено в верхней части рабочего окна программы и служит для доступа ко всем функциям и настройкам, предусмотренным в программе.

Для удобства навигации пункты главного меню сгруппированы по функциональному признаку.

Обзор главного меню


Меню "Файл"

ONI

Меню "Файл"

Меню "Файл" содержит основные команды для управления файлами проектов.

Обзор пунктов меню

Пункт меню | Описание функции
"Создать новый проект" | Открыть диалог создания нового проекта
"Открыть проект" | Открыть диалог открытия существующего проекта
"Закрыть проект" | Закрыть редактируемый проект
"Сохранить проект" | Сохранить редактируемый проект
"Сохранить проект как ..." | Сохранить редактируемый проект изменив имя или место расположения
"Защита проекта паролем" | Задать пароль для защиты проекта от изменений
"Недавние проекты" | Список последних редактированных проектов
"Выход" | Выйти из программы и закрыть окно


Меню "Вид"

ONI

Меню "Вид"

Меню "Вид" содержит элементы для настройки внешнего вида программы, настройки оформления рабочей области и набора отображаемых элементов основного окна программы.

Обзор пунктов меню

Пункт меню | Описание функции
"Проект" | Отображать / скрыть окно проекта
"Окна" | Отображать / скрыть окно менеджера окон
"Ошибки" | Отобразить / скрыть вкладку "Ошибки" в окне информации
"Результаты" | Отобразить / скрыть вкладку "Результаты" в окне информации
"Элементы" | Отобразить / скрыть окно менеджера элементов
"Восстановить вид по умолчанию" | Сбросить настройки внешнего вида и вернуться к стандартным настройкам
"Текущий язык" | Выбрать язык интерфейса программы
"Текущее состояние" | Изменить текущий статус для отладки статус зависимых элементов


Меню "Правка"

ONI

Меню "Правка"

В меню "Правка" сгруппированы команды для редактирования проекта в процессе разработки и отладки.

Обзор пунктов меню

Пункт меню | Описание функции
"Отменить" | Отменить последнее действие
"Повторить" | Повторить отмененное действие заново
"Найти" | Найти бит или регистр данных по адресу
"Заменить" | Найти и заменить адрес бита или регистра данных
"Вырезать" | Вырезать выделенные элементы в буфер обмена
"Копировать" | Копировать выделенные элементы в буфер обмена
"Мульти-копия" | Размножить выделенные элементы с изменением параметров
"Вставить" | Вставить элементы или данные из буфера обмена
"Удалить" | Удалить выделенные элементы
"Позиционирование" | Прецизионное позиционирование выделенного элемента
"Выравнивание" | Взаимное выравнивание выделенных элементов
"Размер" | Согласование размеров выделенных элементов
"Слой" | Настроить порядок отображения элементов при наложении
"Тот же цвет" | Скопировать одинаковый цвет для выделенных элементов
"Группировать" | Сгруппировать выделенные элементы
"Разгруппировать" | Разгруппировать группу элементов
"Центр по горизонтали" | Выровнять элемент по центру вертикальной оси
"Центр по вертикали" | Выровнять элемент по центру горизонтальной оси
"Заблокировать" | Заблокировать возможность редактирования выделенного элемента
"Разблокировать" | Разблокировать возможность редактирования выделенного элемента


Меню "Окна"

ONI

Меню "Окна"

В меню "Окна" сгруппированы команды для управления окнами в редактируемом проекте, а также настройки представления редактируемого окна в рабочей области программы.

Обзор пунктов меню

Пункт меню | Описание функции
"Создать новое окно" | Добавить новое окно в проект
"Удалить окно" | Удалить текущее окно из проекта
"Свойства текущего окна" | Открыть окно свойств текущего окна проекта
"Изменить стартовый логотип" | Изменить стартовое окно-заставку
"Показывать фоновое окно" | Отобразить / скрыть фоновое окно-шаблон в текущем окне
"Показывать окно нижнего слоя" | Отобразить / скрыть окна нижних уровней в текущем окне
"Перейти к окну" | Перейти к окну выбрав его имя / номер из списка
"Показать сетку" | Отображать фоновую сетку в рабочей области
"Выравнивание по сетке" | Привязывать элементы к сетке в рабочей области
"Использовать линии привязки" | Отображать линии взаимной привязки элементов в рабочей области
"Настройка сетки" | Настройка параметров сетки в рабочей области
"Масштаб" | Выбрать масштаб отображения элементов в рабочей области


Меню "Рисование"

ONI

Меню "Рисование"

В меню "Рисование" содержатся инструменты для добавления в проект и редактирования векторной графики, а также статических текстовых и графических элементов.

Обзор пунктов меню

Пункт меню | Описание функции
"Выбрать" | Инструмент "указатель" - для выбора и перемещение объектов
"Прямая линия" | Инструмент "прямая линия"
"Ломаная линия" | Инструмент "ломаная линия"
"Прямоугольник" | Инструмент "прямоугольник"
"Многоугольник" | Инструмент "многоугольник"
"Эллипс" | Инструмент "эллипс"
"Дуга" | Инструмент "дуга"
"Сектор окружности" | Инструмент "сектор окружности"
"Сектор кольца" | Инструмент "сектор кольца"
"Изображение" | Добавить статичное изображение в текущем окне.
"Текст" | Добавить статичный текст или надпись в текущем окне.


Меню "Компоненты"

ONI

Меню "Компоненты"

В меню "Компоненты" содержатся все доступные пользователю активные элементы, с использованием которых реализуется проект человеко-машинного интерфейса: отображение информации и функции управления. Все элементы объединены по функциональному признаку в группы, краткое описание которых представлено в таблице.

Обзор пунктов меню

Пункт меню | Описание функции
"Клавиши" | Группа содержит элементы для организации управления. Предусмотрены функции изменения данных в регистрах, переключения окон проекта, вызов системных функций настройки, работа с рецептами и передача данных.
"Индикаторы" | Индикаторы позволяют визуально отобразить состояние регистров данных или значение сохраненные в них. Также с использованием индикатора можно выполнить текстовую расшифровку, например, цифровых значений состояний или результатов работы автоматики.
"Дисплеи" | Дисплеи используются для отображения цифровых и текстовых данных, также при активации соответствующего функционала в настройках могут выступать в качестве полей ввода информации.
"Тумблеры и списки" | Группа содержит элементы для изменения и(или) ввода данных. В данную группу входят "тумблеры", по условию нажатия которых можно, например, изменить данные в регистре памяти или состояние определенного бита, также "списки", которые позволяют организовать ввод данный путем выбора значения из ранее определенного списка.
"Таймеры и передача данных" | Доступ к настройкам таймеров и синхронной передачи данных активного окна проекта. Позволяет организовать цикличное выполнения каких либо действий и обмен информацией.
"Указатели" | Группа элементов для графического отображения значений данных в виде шкал, графический индикаторов, стрелочных указателей и т.п.
"Графики и диаграммы" | Группа элементов для реализации отображения данных в виде различных графиков и диаграмм для удобства анализа зависимостей.
"Шкалы" | Графические элементы шкал различной конфигурации, которые могут быть использованы для индикации значений совместно с элементами из группы указатели.
"Таблицы" | Элементы таблиц для структуризации отображаемых данных. Можно также использовать в качестве сегментного индикатора, управляя позицией выделения стока, столбец или ячейка.
"Ползунок" | Графический задатчик значения выполненный в виде ползунка, путем перемещения которого в целевой регистр записывается значение пропорциональное положению.
"Перемещаемый элемент" | Перемещаемые элемент может использоваться для дополнительного привлечения внимания оператора при выводе информации. Положением элемента на экране можно динамически управлять.
"Окна" | Группа элементов-окон для реализации многооконного интерфейса пользователя. Позволяет реализовать вывод дополнительных, всплывающий окон поверх основного рабочего. Условием для вывода может быть, как состояние бита памяти так и значение данных в регистре.
"Журналы и события" | Элементы для отображения архивных и текущих событий и аварий в виде списков. Также присутствует возможность отображения системных журналов работы и действий оператора.
"Инструменты" | Группа вспомогательных элементов для создания интерфейса пользователя. В нее входит элемент холста, с возможностью управления состоянием каждого пиксела индивидуально, генератор QR кодов на основании введенной информации, элемент "дата и время", а также средство просмотра документов в формате PDF или графических файлов.
"Трубопровод" | Группа анимированных элементов для построения мнемосхем трубопроводов, сетей коммуникаций с возможностью визуального отображения их состояния.


Меню "Библиотеки"

ONI

Меню "Библиотеки"

Для удобства построения сложных проектов все используемые ресурсы могут быть сгруппированы в библиотеки, доступ к которым осуществляется через раздел "<Библиотеки" главного меню.

Обзор пунктов меню

Пункт меню | Описание функции
"Библиотека адресных меток" | Каждому внутреннему адресу или внешнему регистру подключаемых устройств может быть назначена текстовая адресная метка, что может быть удобно при работе над крупными проектами с большим количеством элементов использующих одинаковые адреса.
"Библиотека текстов" | Библиотека текстов позволяет сгруппировать все текстовые данные проекта в одном месте. Это может быть удобно при разработке многоязычных проектов, в таком случае достаточно перевести текстовые данные из библиотеки которые сгруппированы в виде таблиц, вместо перевода текстов для каждого элемента.
"Библиотека звуковых файлов" | Библиотека может содержать звуковые файлы воспроизведение которых привязывается к определенным событиям и служит для дополнительного привлечения внимания оператора.
"Библиотека контрольных адресов" | В панелях оператора серии ETG предусмотрена возможность включить информацию о процессе в текстовые сообщения системы для большей информативности. В этом случае в библиотеке контрольных адресов создается запись об адресе содержащем необходимую информацию, а при создании сообщения в его текст помещается ссылка на эту запись. В случае наступления события в тестовое сообщение будет автоматически подставлено значение по адресу на который ссылается выбранная запись из библиотеки.
"Библиотека меток устройств" | Библиотека позволяет назначить текстовые метки подключенным устройствам для удобства навигации и идентификации.
"Добавить новую графику" | Пункт активирует диалог добавления нового графического файла в библиотеку графики.
"Библиотека графики" | Библиотека содержит все графические элементы проекта. Это могут быть как встроенные по умолчанию элементы, так и добавленные пользователем в процессе разработки.


Меню "Макросы"

ONI

Меню "Макросы"

Меню "Макросы" служит для управления макросами, для добавления и редактирования макросов в проекте.

Обзор пунктов меню

Пункт меню | Описание функции
"Создать макрос" | Пункт активирует диалог и редактор создания нового макроса и добавления его в проект.
"Изменить макрос" | При выборе данного пункта, перед запуском редактора будет предложено выбрать существующий макрос, который будет открыт в редакторе для внесения правок.
"Разрешить проверку паролей" | Макрос может быть защищен паролем от изменения, который задается в данном пункте. Для подтверждения пароль необходимо ввести дважды.
"Обновить пароль макроса" | Данный пункт позволяет изменить пароли защищающий макросы проекта от изменений.


Меню "Рецепты"

ONI

Меню "Рецепты"

Меню "Рецепты" используется для управления рецептами при их использовании в редактируемом проекте.

Обзор пунктов меню

Пункт меню | Описание функции
"Создать рецепт" | Создать новый рецепт и добавить его в проект


Меню "Настройки"

ONI

Меню "Настройки"

Меню "Настройки" позволяет получить доступ к настройкам аппаратной части панели, настройкам непосредственных и удаленный подключений, а также основным настройкам разрабатываемого проекта. Отдельным пунктом меню "Настройки" выделены настройки непосредственно среды разработки ONI Visual Studio.

Обзор пунктов меню

Пункт меню | Описание функции
"Настройки HMI" | В данном разделе осуществляется выбор модели HMI и ориентации экрана, настройки Ethernet подключения.
"Настройки связи" | Настройки внешних подключений, протоколов и используемых сервисов для коммуникации с периферийными устройствами.
"Настройки системы" | Настройки редактируемого проекта доступные пользователю подробно рассмотрены в разделе работа с проектом.
"Опции" | Настройки среды разработки ONI Visual Studio, выбор языка интерфейса.


Меню "Инструменты"

ONI

Меню "Инструменты"

Меню "Инструменты" содержит разделы предназначенные для отладки редактируемого проекта, а также инструменты для загрузки или выгрузки проекта в панель оператора.

Обзор пунктов меню

Пункт меню | Описание функции
"Компилировать" | Запустить процесс компиляции проекта
"Компилировать все" | Запустить процесс полной компиляции проекта
"Очистить результат компиляции" | Удалить результаты предыдущих компиляций
"Загрузить" | Загрузить редактируемый проект в панель
"Архивировать на диск" | Сформировать архив проекта для последующей загрузки в панель
"Выгрузить" | Выгрузить проект из панели
"Декомпилировать" | Декомпилировать выгруженный или ранее сохраненный архив проекта
"Моделирование в симуляторе" | Запустить симулятор для моделирования и отладки проекта


Меню "Справка"

ONI

Меню "Справка"

Меню "Справка" служит для доступа к интегрированной справочной системе, а также позволяет проверить наличие обновлений программы и получить информацию о текущей версии.

Обзор пунктов меню

Пункт меню | Описание функции
"Справка" | Запуск интегрированной справочной системы
"Проверить наличие обновлений" | Проверить наличие обновлений программы.
"О программе" | Открыть окно с информацией о текущей версии программы


Обзор панелей инструментов

ONI

Обзор панелей инструментов

Для удобства доступа к основным функциям программы могут используются панели инструментов, по умолчанию расположенные в верхней части основного окна программы. Как и в главном меню, значки вызова функций объединены в группы по функциональному признаку.

Обзор панелей инструментов


Рабочая область

ONI

Рабочая область

В рабочей области редактора отображается редактируемое окно проекта в том виде в котором в дальнейшем оно будет отображаться на экране панели. Для удобства позиционирования и выравнивания визуальных элементов интерфейса, поверх окна выводится вспомогательная сетка разметки, которую можно отключить при необходимости.


Панель закладок

ONI

Панель закладок

Панель закладок располагается в верхней части рабочей области и используется для навигации между открытыми для редактирования окнами проекта.

При желании все вспомогательные окна программы Visual Studio можно также разместить в рабочей области и отобразить в виде закладок на панели. Для этого правой клавишей мыши вызовите меню, кликнув по заголовку сворачиваемого окна и выберите пункт "Свернуть в закладку на панели".

Окно будет помещено в рабочую область и на панели задач отобразится новая закладка.

Чтобы отменить закрепление любого окна в рабочей области, удерживая левую клавишу мыши потяните курсором за соответствующую окну вкладку.


Окно проекта

ONI

Окно проекта

Окно проекта

В окне проекта отображается вся структура ресурсов и опций проекта доступных пользователю для реализации поставленной задачи.

Двойной щелчок мыши по оному из пунктов панели откроет соответствующее диалоговое окно для просмотра или изменения связанных свойств.


Менеджер окон

ONI

Менеджер окон

Менеджер окон

В окне менеджера окон отображаются все окна проекта в виде структуры, что облегчает навигацию между ними и редактирование свойств.

Для примера на рисунке слева показан менеджер окон вновь созданного проекта. По умолчанию создается одно пустое базовое окно (выделено), а также автоматически добавляются преднастроенные служебные окна, реализующие стандартные функции ввода.

Все служебные окна могут быть изменены или вовсе удалены из проекта на усмотрение пользователя.

Добавить или изменить существующее окно, можно через контекстное меню вызываемое правой клавишей мыши.


Менеджер элементов

ONI

Менеджер элементов

В окне менеджера элементов отображаются в виде структуры все элементы, расположенные в активном на данный момент окне.

Свойства каждого элемента можно просмотреть или изменить, дважды щелкнув соответствующую ему строку левой клавишей мыши в окне менеджера. Также из окна менеджера можно управлять блокировкой и видимостью каждого элемента.


Окно информации

ONI

Окно информации

Окно информации по умолчанию располагается в нижней части основного окна программы в свернутом состоянии и содержит две вкладки имеющих различное функциональное назначение.

Вкладка "Ошибки" используется для вывода системных предупреждений и сообщений об ошибках в результате операций в программе.

Информация

На вкладке "Отчет" отображается ход выполнения операций, для которых предусмотрен пошаговый вывод отладочной информации о ходе процесса выполнения, например, компиляции проекта.

Симулятор

Примечание:

Если окно информации свернуто, то оно отобразится автоматически на некоторое время при появлении новых сообщений.


Клавиши быстрого доступа

ONI

Клавиши быстрого доступа

Для удобства работы в программе ONI Visual Studio предусмотрен вызов наиболее часто используемых функций с использованием функциональных и сочетаний "горячих" клавиш.

Доступные быстрые функции и соответствующие им комбинации клавиш представлены в таблицах.

Функциональные клавиши

Клавиша | Описание функции
F1 | Запустить интегрированную справочную систему
F5 | Запустить симулятор для отладки проекта
F6 | Запустить процесс компиляции проекта

Горячие клавиши

Сочетание | Описание функции
Ctrl+N | Открыть диалог создания нового проекта
Ctrl+O | Открыть диалог открытия существующего проекта
Ctrl+S | Сохранить редактируемый проект
Ctrl+Z | Отменить последнее действие в редакторе
Ctrl+Y | Повторить отмененное действие в редакторе заново
Ctrl+F | Открыть диалоговое окно "найти"
Ctrl+H | Открыть диалоговое окно "заменить"
Ctrl+X | Вырезать выделенные элементы в буфер обмена
Ctrl+С | Копировать выделенные элементы в буфер обмена
Ctrl+V | Вставить элементы или данные из буфера обмена
Ctrl+A | Выделить все
Ctrl+"колесо мыши" | Изменить масштаб рабочей области
Alt+X | Выйти из программы


Создание нового проекта

ONI

Создание нового проекта

Для создания нового проекта выберите пункт "Создать новый проект" в меню "Файл" в главном окне программы. Либо воспользуйтесь быстрым сочетанием клавиш "Ctrl+N".

В открывшемся окне укажите имя и путь к месту сохранения файлов проекта. Нажмите "ОК" для сохранения введенных данных, будет запущен диалог создания нового проекта.

Шаг 1: Выберите тип используемой панели из выпадающего списка доступного оборудования, при этом в поле "Описание продукта" отобразится краткое техническое описание модели.

Для перехода к следующему шагу нажмите "Далее", или "ОК", чтобы зарыть диалог создания нового проекта. Во втором случае вернуться к настройкам можно используя раздел главного меню "Настройки" или соответствующие пункты в окне проекта.

Шаг 2: Настройка параметров встроенных коммуникационных портов. На вкладке "HMI Property" задается IP адрес порта Ethernet и желаемая ориентация экрана.

Вкладки COM1-COM4 используются для настройки последовательных портов. Здесь определяется роль панели (Master-Slave), производитель и тип подключаемого оборудования-контроллера, а также его адрес по умолчанию. В нижней части окна задаются параметры порта: скорость, количество бит данных и т.д.

Для перехода к следующему шагу нажмите "Далее", или "ОК", чтобы зарыть диалог создания нового проекта. Во втором случае вернуться к настройкам можно используя раздел главного меню "Настройки" или соответствующие пункты в окне проекта.

Шаг 3: Окно настройки подключений панели с помощью сетей Ethernet содержит три вкладки. Вкладка "Удаленный HMI" служит для настройки подключения к удаленной панели оператора, что позволяет использовать регистры хранения данных удаленной панели в локальном проекте. Вкладка "Удаленный ПЛК" позволяет настроить подключение к удаленному ПЛК, который подключен к одному из COM портов удаленной панели оператора, которая, в данном случае, выполняет роль шлюза. При таком подключении в локальном проекте появляется возможность работать напрямую с регистрами памяти удаленного ПЛК. Третья вкладка "Ethernet ПЛК" позволяет настроить прямое подключение к ПЛК, в случае если ПЛК имеет встроенный порт Ethernet и объединен в одну сеть с панелью оператора.

Для перехода к следующему шагу нажмите "Далее", или "ОК", чтобы зарыть диалог создания нового проекта. Во втором случае вернуться к настройкам можно используя раздел главного меню "Настройки" или соответствующие пункты в окне проекта.

Шаг 4: Последний шаг диалога создания проекта позволяет просмотреть все порты, для которых выбрана роль "Slave", а также используемые протоколы и предоставляемые ресурсы. Также на данном этапе можно настроить дополнительные сервисы в случае необходимости использования панели в режиме "Slave" при подключении через Ethernet.

В любой момент можно вернуться к предыдущему шагу диалога настроек нажав кнопку "Назад", либо выбрать соответствующий пункт в дереве настроек слева. Кнопка "ОК" завершает диалог создания проекта и открывает новый проект в окне редактора.


Общие сведения

ONI

Общие сведения

ONI Visual Studio предоставляет возможность выполнить основные настройки в процессе создания нового проекта, однако в случае необходимости, можно изменить настройки в любой момент времени. Для этого воспользуйтесь разделами меню "Настройки", либо окном проекта.


Выбор оборудования

ONI

Выбор оборудования

Позволяет выбрать тип используемого оборудования и выполнить основные настройки для порта Ethernet. Окно настроек показано на рисунке.

При необходимости переноса проекта с одного типа панели на другой, можно воспользоваться функцией "Сменить тип HMI". Щелкните левой клавишей мыши по кнопке, расположенной в нижней части экрана и в появившемся окне выберите новый тип панели из выпадающего списка.

Для большей информативности характеристики старой и новой панелей отображаются одновременно. Нажмите "Заменить" для сохранения настроек или "Отмена" если замены не требуется.

Примечание

Если разрешение экранов старого и нового оборудования не совпадают, то в процессе замены все экраны проекта будут промасштабированы автоматически кратно соотношению разрешений, но может потребоваться и ручная корректировка визуальных элементов и шрифтов подписей.


Общие сведения местные подключения

ONI

Общие сведения

К местным подключениям относятся подключения, выполняемые с помощью встроенных коммуникационных портов COM1-COM4*. Для доступа к настройкам перейдите к пункту меню "Настройки > Настройки связи > Местные подключения", либо выберите соответствующий пункт в окне проекта.

По умолчанию коммуникационные порты отключены, для того, чтобы включить порт выберите роль, которую будет выполнять панель при коммуникации.

Примечание

* Количество и обозначение портов может отличаться в зависимости от модели оборудования, пожалуйста уточните технические характеристики в соответствующем разделе данного руководства.


Подключение в роли ведущего

ONI

Подключение в роли ведущего (Master)

Порядок настройки

1.Выберите роль ведущего устройства, в окне настройки будут отображены доступные опции и параметры для конфигурации.

Подключение в роли ведущего

2.Из выпадающего списка выберите изготовителя и тип подключаемого оборудования, а также укажите имя для идентификации ПЛК в проекте.

3.Если подключение выполняется к одному ПЛК, то можно указать его адрес в качестве адреса по умолчанию. В дальнейшем данный адрес будет автоматически выбираться в настройках элементов.

4.Проверьте и при необходимости скорректируйте настройки скорости и конфигурацию протокола.

5.Кнопка "Расширенные" открывает доступ к расширенным настройкам временных параметров и формата данных при передаче данных*.

6.Нажмите "ОК" чтобы закончить настройку и сохранить данные.

Примечание

Расширенные настройки по умолчанию выполнены в соответствии со спецификацией выбранного оборудования, поэтому без необходимости не рекомендуется изменять их.

Подключение в роли ведущего

Примечание

Вернуться к значениям параметров по умолчанию можно нажатием кнопки "Сброс".


Подключение в роли ведомого

ONI

Подключение в роли ведомого (Slave)

Порядок настройки

1.Выберите роль ведомого устройства, в окне настройки будут отображены доступные опции и параметры для конфигурации.

Подключение в роли ведомого

2.Из выпадающего списка выберите протокол, который будет использоваться для доступа к ресурсам панели.

3.Укажите собственный адрес, который должен использовать ведущий (Master) для адресации запросов к панели.

4.Проверьте и при необходимости скорректируйте настройки скорости и конфигурацию протокола.

5.Кнопка "Расширенные" открывает доступ к расширенным настройкам временных параметров и формата данных при передаче данных*.

6.Нажмите "ОК" чтобы закончить настройку и сохранить данные.

Примечание

Расширенные настройки по умолчанию выполнены в соответствии со спецификацией выбранного оборудования, поэтому без необходимости не рекомендуется изменять их.

Подключение в роли ведомого

Примечание

Вернуться к значениям параметров по умолчанию можно нажатием кнопки "Сброс".


Общие сведения удаленные подключения

ONI

Общие сведения

К удаленным подключениям относятся подключения, выполняемые с помощью встроенного порта Ethernet*. Для доступа к настройкам перейдите к пункту меню "Настройки > Настройки связи > Удаленные подключения", либо выберите соответствующий пункт в окне проекта.

В данную группу входит три вида возможных структур обмена информацией: "Удаленный HMI", "Удаленный ПЛК", "Ethernet ПЛК".

Примечание

* Наличие портов зависит от модели оборудования, пожалуйста уточните технические характеристики в соответствующем разделе данного руководства.


Подключение к удаленной панели

ONI

Подключение к удаленному HMI

Подключение к удаленной панели позволяет получить доступ к регистрам памяти удаленного устройства HMI и использовать их в работе локального проекта.

Структурная схема

Подключение к удаленной панели

Порядок настройки

1.Для добавления нового подключения нажмите кнопку "Добавить" в нижней части окна настроек.

Подключение к удаленной панели

2.В открывшемся окне "Удаленный HMI" укажите IP адрес удаленной панели.

Подключение к удаленной панели

3.Выберите модель оборудования и введите имя для его идентификации в проекте.

4.Нажмите "ОК" чтобы закончить настройку и сохранить данные. В окне настроек отобразится новое подключение.

Подключение к удаленной панели

5.Далее нажмите "ОК", чтобы закончить и сохранить настройки, либо повторите все операции заново для добавления необходимого количества подключений.


Подключение к удаленному контроллеру

ONI

Подключение к удаленному ПЛК

Подключение к удаленному контроллеру позволяет получить доступ к регистрам памяти удаленного ПЛК подключенного к удаленной панели HMI и использовать их в работе локального проекта. В данном случае удаленная панель оператора выступает в роли шлюза.

Структурная схема

Подключение к удаленному контроллеру

Порядок настройки

1.Для добавления нового подключения нажмите кнопку "Добавить" в нижней части окна настроек.

Подключение к удаленному контроллеру

2.В открывшемся окне "Удаленный ПЛК" укажите IP адрес удаленной панели.

Подключение к удаленному контроллеру

3.Выберите COM порт удаленной панели к которому подключен удаленный контроллер.

4.Выберите производителя и тип используемого контроллера, а также укажите имя для идентификации контроллера в проекте.

5.Если подключение выполняется к одному ПЛК, то можно указать его адрес в качестве адреса по умолчанию. В дальнейшем данный адрес будет автоматически выбираться в настройках элементов.

6.Кнопка "Расширенные" открывает доступ к расширенным настройкам временных параметров и формата данных при передаче данных*.

7.Нажмите "ОК" чтобы закончить настройку и сохранить данные, в окне настроек отобразится новое подключение.

Подключение к удаленному контроллеру

8.Далее нажмите "ОК", чтобы закончить и сохранить настройки, либо повторите все операции заново для добавления необходимого количества подключений.

Примечание

Расширенные настройки по умолчанию выполнены в соответствии со спецификацией выбранного оборудования, поэтому без необходимости не рекомендуется изменять их.

Подключение к удаленному контроллеру

Примечание

Вернуться к значениям параметров по умолчанию можно нажатием кнопки "Сброс".


Подключение к контроллеру Ethernet

ONI

Подключение к контроллеру Ethernet

Подключение к контроллеру через сеть Ethernet позволяет получить доступ к регистрам памяти удаленного ПЛК и использовать их в работе локального проекта.

Структурная схема

Подключение к контроллеру Ethernet

Порядок настройки

1.Для добавления нового подключения нажмите кнопку "Добавить" в нижней части окна настроек.

Подключение к контроллеру Ethernet

2.В открывшемся окне "Ethernet ПЛК" выберите производителя и тип подключаемого контроллера, а также укажите имя для идентификации ПЛК в проекте.

Подключение к контроллеру Ethernet

3.Если подключение выполняется к одному ПЛК, то можно указать его адрес в качестве адреса по умолчанию. В дальнейшем данный адрес будет автоматически выбираться в настройках элементов.

4.Укажите IP адрес подключаемого ПЛК и скорректируйте номер порта если он отличается от стандартного для выбранного типа оборудования.

5.Кнопка "Расширенные" открывает доступ к расширенным настройкам временных параметров и формата данных при коммуникации*.

6.Нажмите "ОК" чтобы закончить настройку и сохранить данные, в окне настроек отобразится новое подключение.

Подключение к контроллеру Ethernet

7.Далее нажмите "ОК", чтобы закрыть окно и сохранить настройки, либо повторите все операции заново для добавления необходимого количества подключений.

Примечание

Расширенные настройки по умолчанию выполнены в соответствии со спецификацией выбранного оборудования, поэтому без необходимости не рекомендуется изменять их.

Подключение к контроллеру Ethernet

Примечание

Вернуться к значениям параметров по умолчанию можно нажатием кнопки "Сброс".


Сервисы

ONI

Сервисы

Если панель выступает в роли ведомого устройства, она предоставляет локальные сервисы (ресурсы) по запросу внешнего ведущего (Master) устройства. Просмотреть и настроить сервисы доступные из вне, можно воспользовавшись меню "Настройки > Настройки связи > Сервисы", либо соответствующим пунктом в окне проекта.

1.В окне настроек отображаются сервисы, созданные автоматически при выборе роли ведомого для одного из встроенный коммуникационных портов COM1-COM4. Что бы изменить настройки этих сервисов необходимо воспользоваться соответствующими вкладками в окне настроек.

2.В отличии от последовательных портов, сервисы для порта Ethernet автоматически не создаются, и в случае, если панель используется в качестве ведомого устройства с доступом через порт Ethernet, необходимо добавить новый сервис вручную, вызвав диалог нажатием кнопки "Добавить".

3.Выберите протокол из выпадающего списка.

4.При необходимости измените адрес порта, заданный по умолчанию для данного протокола.

5.Укажите адрес панели для адресации запросов к ней от ведущего (Master) устройства.

6.Нажмите "OK", чтобы сохранить изменения и закрыть окно.

7.В окне настроек должна появиться новая строка, соответствующая созданному сервису.

8.Далее нажмите "ОК", чтобы закончить и сохранить настройки, либо повторите все операции заново для добавления всех необходимых сервисов.


Общие сведения настройки системы

ONI

Общие сведения

В разделе "Настройки системы" определяются глобальные настройки, которые имеют эффект на все разделы и работу проекта в целом. Для удобства навигации все настройки разделены на несколько групп, для доступа к которым, служит раздел меню "Настройки > Настройки системы", либо разделы в окне проекта.


Общие настройки

ONI

Общие настройки

Общие настройки проекта, представленные на вкладке "Общие настройки", позволяют предопределить работу следующих функций панели.

1.Настройки защиты проекта от несанкционированного доступа или изменения:

·Выгрузка - опция защиты проекта от выгрузки из панели оператора.

·Декомпиляция - опция защиты выгруженного проекта от декомпиляции.

·Перезапись - опция защиты загруженного в панель проекта от перезаписи новым.

Для активации желаемой опции установите галочку напротив и в появившемся поле введите пароль, который будет необходим в дальнейшем при попытке выполнить запрещенное действие.

2.Настройки подсветки и экранной заставки.

На рисунке показан случай, когда все опции управления подсветкой дисплея включены, однако они могут быть активированы и в произвольном порядке в зависимости от предпочтений.

При активации опций затенения экрана и отключения подсветки, необходимо задать время бездействия сенсора до момента активации функции. Для экрана-заставки, также задается время бездействия и выбирается окно проекта из списка существующих, которое будет активировано при окончании временного интервала.

Выход из режима отображения экрана-заставки можно защитить паролем, для этого активируется соответствующая опция и определяется уровень доступа, которым должен обладать пользователь для совершения операции.

3.Настройки порядка расположения байт в регистрах памяти при работе с данными 16 и 32 разрядов.

4.Настройка ширины полос прокрутки для рабочих экранов.

5.Настройки процесса инициализации при запуске проекта. В данном разделе выбирается стартовое окно и макрос, который будет выполнен при начальной загрузке панели и старте проекта.

И окно, и макрос выбираются из выпадающего списка доступных, поэтому они должны быть добавлены в проект до настройки данной опции.

6.Настройка окна по умолчанию, которое будет отображено при вызове функций перехода к домашнему окну.

7.Настройка выпадающих меню-шторок. Установите галочку если хотите использовать данную опцию интерфейса, при этом следует помнить, что работа данной опции может быть не корректной на панелях с резистивным сенсором экрана ввиду особенности конструкции.

8.Настройка встроенных часов. По умолчанию в проекте используются встроенные в панель часы реального времени, однако можно также выбрать часы подключенного оборудования в качестве источника времени. При этом должно быть настроено хотя бы одно внешнее подключение.

9.Настройки зуммера используются для контроля встроенного источника звука, он может быть включен или отключен в зависимости от активных опций, а также его состояние может зависеть от состояния внешнего регистра если необходимо оперативно менять его состояние.

10. В завершении нажмите "ОК", чтобы закрыть окно и сохранить настройки.


Расширенные настройки

ONI

Расширенные настройки

Расширенные настройки проекта, представленные на вкладке "Расширенные настройки", позволяют предопределить работу следующих функций панели.

1.Настройка отображения окна шаблона и соответственно порядка обработки событий касания экрана.

·Под основным окном - окно шаблон размещено под основным окном и элементы основного окна перекрывают элементы окна шаблона.

·Поверх основного окна - окно шаблон размещено над основным окном и элементы основного окна перекрывают элементы окна шаблона.

2.Настройка производительности интерфейса. Для повышения производительности можно отключить опцию обработки векторных шрифтов.

2.Настройка журнала событий. В данном разделе выбирается место сохранения журнала событий и его объем. Если выбран вариант "Не сохранять" журнал формируется в оперативной памяти и не сохраняется при отключении питания панели.

В случае если выбран один из вариантов HMI, SD Card, USB1 журнал сохраняются в соответствующей памяти и срок его хранения не зависит от наличия питания.

Для вариантов хранилища SD Card или USB, панель должна поддерживать работу с данным носителем, и он должен быть установлен в соответствующий слот. В противном случае будет сформировано сообщение об ошибке.

4.Настройка опций управления жестами для панелей с емкостным сенсором.

5.Настройка начального отображения компонента, внешний вид которого зависит от внешнего условия или данных.

6.Настройка отображения нарушения соединений. Если опция активна, то в углу экрана будет отображаться значок ошибки при проблемах с коммуникациями.

7.Настройка журнала пользователей. Если опция активна, то события ввода пароля, смены пользователей и т.п., будут заноситься в журнал событий.

8.В завершении нажмите "ОК", чтобы закрыть окно и сохранить настройки.


Языковые настройки

ONI

Языковые настройки

ONI Visual Studio позволяет создавать проекты HMI с поддержкой до 32 языков. Для управления доступными языками и изменения их состава служит раздел "Языковые настройки" в настройках системы. Внешний вид окна настроек представлен на рисунке, описание разделов приведено ниже.

1.Настройка количества языков интерфейса. Выбирается общее количество доступных пользователю языков интерфейса, которые будут добавлены в проект.

2.Настройка языков. Набор языков интерфейса в каждом проекте может быть произвольным, язык выбирается для каждой позиции из общего списка всех возможных.

3.Настройка языка по умолчанию. В данном разделе выбирается язык по умолчанию, который будет активен при первоначальной загрузке проекта.

4.Настройка шрифта. Для каждого языка в проекте задается шрифт по умолчанию, который будет автоматически выбираться в свойствах при добавлении новых элементов.

5.ONI Visual Studio позволяет настроить шрифт для каждого языка независимо, однако если это не требуется и для всех языков планируется использовать одинаковый шрифт, можно скопировать однажды выполненные настройки на все языки нажав данную кнопку.

6.Нажмите "ОК", чтобы закрыть окно и сохранить настройки.


Шаблоны шрифтов

ONI

Шаблоны шрифтов

Для удобства редактирования проекта и обеспечения единства оформления в программе ONI Visual Studio предусмотрена возможность настроить шаблоны шрифтов для дальнейшего использования в свойствах элементов. Данные настройки доступны в разделе "Шаблоны шрифтов".

Настройки шаблонов шрифтов

1.Нажимайте кнопку "Добавить", чтобы добавить необходимое количество шаблонов.

2.Добавленные шаблоны отобразятся в списке, выберите нужный для редактирования свойств.

3.Введите имя для идентификации шаблона в проекте и измените настройки шрифта.

4.Нажмите "ОК", чтобы закрыть окно и сохранить настройки.


Уровни доступа

ONI

Уровни доступа

Уровни доступа - это один из способов разграничить полномочия пользователей для доступа к различным функциям проекта. Для этого в свойствах каждого объекта предусмотрена возможность выбрать минимальный уровень "Level" из ранее заданных, которым должен обладать пользователь для активации объекта и связанных с ним функции. При этом следует знать, что уровень с большим порядковым номером наследует полномочия младших уровней. Следовательно пользователь с вторым уровнем, автоматически получает доступ к функциям, требующим наличия 1-ого уровня доступа и т.д.

Для администрирования уровней доступа в проекте используется вкладка "Уровни доступа" в окне настроек системы. Открыть вкладку можно через меню "Настройки > Настройки системы > Уровни доступа", либо выбрав соответствующий пункт в окне проекта.

Настройка уровней доступа

1.Пункт определяет общее количество уровней доступа, задействованных в проекте. Всего можно задействовать до 16 уровней.

2.Список настроенных уровней и соответствующих им паролей, а также краткое текстовое описание для удобства идентификации.

3.Нажмите "ОК" для сохранения настроек и выхода меню.

Примечание

Уровень доступа определяется системой при вводе пользователем только пароля, поэтому необходимо задавать различные пароли в настройках для исключения коллизий.


Настройка прав пользователей

ONI

Права пользователей

Если возможностей администрирования доступа к ресурсам проекта с помощью уровней пользователей недостаточно, можно настроить более сложную систему прав пользователей в виде списка, при этом каждому из пользователей права назначаются индивидуально.

Для администрирования пользователей и изменения прав используется вкладка "Уровни доступа" в окне настроек системы. Открыть вкладку можно через меню "Настройки > Настройки системы > Права пользователей", либо выбрав соответствующий пункт в окне проекта.

Настройка прав пользователей

1.Нажмите "Добавить", чтобы открыть диалоговое окно добавления нового пользователя.

Настройка прав пользователей

2.Введите имя нового пользователя.

3.Укажите пароль, который будет использовать пользователь для подтверждения прав.

4.Укажите время простоя, по истечении которого будет автоматически выполнен выход из системы.

5.Отметьте права, которые будут доступны новому пользователю.

6.Нажмите "ОК" для выхода и сохранения настроек.

В окне настроек отобразится новая строка соответствующая новому пользователю.

Настройка прав пользователей

При необходимости добавить несколько пользователей повторите все операции заново, также предусмотрены возможности удалить или изменить существующие записи пользователей.

7.Удалить выбранную запись.

8.Изменить настройки выбранной записи.

9.Нажмите "ОК" чтобы сохранить настойки и закрыть окно.


Настройка планировщика задач

ONI

Расписание задач

В программе ONI Visual Studio предусмотрена возможность добавить в проект задачи, которые будут выполняться по заданному расписанию. Для редактирования таких задач служит раздел "Расписание задач" настроек системы, который можно вызвать через меню "Настройки > Настройки системы > Расписание задач", либо выбрав аналогичный пункт в окне проекта.

Настройка планировщика задач

1.Нажмите "Новый", чтобы добавить пункт новой задачи в расписание.

Настройка планировщика задач

2.Укажите название задачи для ее идентификации в проекте.

3.Активируйте опцию управления, если помимо расписания существует иное условие выполнения задачи. Логическая единица по указанному адресу будет блокировать выполнение задачи.

4.Выберите режим планирования:

·День - ежедневная задача

·Неделя - еженедельная задача

·Адрес HMI - расписание загружается из регистров памяти панели или ПЛК

5.Укажите время начала выполнения задачи.

6.Укажите время окончания выполнения задачи (при необходимости).

7.Выберите действия которые будут выполняться при начале и окончании задачи.

·Выполнять при включении - выполнить задачу при включении питания

·Bit - изменить - установить/сбросить бит по адресу

·Word - изменить - изменить слово данных по адресу

·Запуск макроса - выполнить макрос из выпадающего списка

·Всплывающее окно - вызвать всплывающее окно

·Зуммер - подать звуковой сигнал

·Проиграть аудио - воспроизвести звуковой файл из библиотеки

8.Нажмите "ОК" для сохранения и выхода из диалога создания новой задачи, в окне настроек отобразится новая строка соответствующая созданной задаче в расписании.

Настройка планировщика задач

При необходимости добавить несколько задач в расписание повторите все операции заново. Также предусмотрены возможности удалить или изменить существующие задачи из расписания либо полностью очистить расписание.

9.Удалить выбранную задачу.

10. Удалить все задачи и полностью очистить расписание.

11. Редактировать выбранную задачу.

12. Нажмите "ОК" чтобы сохранить настойки и закрыть окно.


Настройка сбора данных

ONI

Сбор данных

Функции регистратора или сбора данных предусмотренные в программе ONI Visual Studio позволяют реализовать в проекте HMI автоматический сбор и накопление данных, для последующего анализа. Если в проекте планируется использовать представление данных в виде временных графиков то, предварительная настройка сбора информации является обязательной.

Чтобы перейти к настройкам откройте меню "Настройки > Настройки системы > Сбор данных", либо выберите соответствующий пункт в окне проекта.

Настройка сбора данных

1.Нажмите "Новый", чтобы открыть диалоговое окно создания нового процесса сбора данных.

Настройка сбора данных

2.Укажите имя для идентификации процесса сбора данных в проекте.

3.Активируйте опцию "Каналы по порядку", если в настраиваемом процессе планируется опрашивать блок данных, состоящий из нескольких последовательно расположенных регистров.

A.Выберите устройство источник и укажите начальный адрес блока данных.

B.Укажите регистр, значение в котором будет использоваться в качестве индекса если используется косвенная адресация блока данных в памяти устройства источника. Значение регистра является индексом и добавляется к заданному начальному адресу, для вычисления адреса источника данных.

4.Настройте опции внешнего управления сбором данных:

·Пауза - временный останов сбора при установке логической единицы в управляющем регистре.

·Сброс - очистка накопленных данных при установке логической единицы в управляющем регистре.

·Выполнять если открыто окно - выполнять процесс только если открыто указанное окно.

5.Выберите режим сбора данных:

·Циклический - периодически с заданным интервалом от 0.1 с.

·Вызываемый - по внешнему событию (изменение состояния регистра).

6.Настройка сохранения собранных данных. В данном разделе выбирается место сохранения и объем накапливаемых данных. Если выбран вариант "Не сохранять" данные записываются в оперативную память и не сохраняется при отключении питания панели.

Настройка сбора данных

В случае если выбран один из вариантов HMI, SD Card, USB1 данные сохраняются во флэш памяти и их сохранность не зависит от наличия питания.

Настройка сбора данных

Для вариантов хранилища SD Card или USB, панель должна поддерживать работу с данным носителем, и он должен быть установлен в соответствующий слот. В противном случае будет сформировано сообщение об ошибке.

7.Перейти к настройке каналов сбора данных для данного процесса, будет открыта соответствующая вкладка окна настройки.

Если опция "Каналы по порядку" активна.

Адреса всех каналов назначаются автоматически и последовательно начиная с начального с учетом выбранного формата данных.

Настройка сбора данных

8.Нажмите "Добавить", чтобы добавить нужное количество каналов сбора данных.

9.Выберите формат данных для каждого канала.

10. Укажите количество выборок данных производимых, при каждом выполнении процесса.

11. Нажмите "ОК" для завершения и сохранения настроек.

Если опция "Каналы по порядку" не активна.

Адрес источника данных для каждого канала можно задать индивидуально.

Настройка сбора данных

12. Укажите тип данных регистрируемых в данном процессе "Bit" или "Word".

13. Нажмите "Добавить", чтобы добавить нужное количество каналов сбора данных.

14. Укажите устройство и адрес источника данных для каждого канала.

15. Выберите формат данных для каждого канала.

16. Укажите количество выборок данных реализуемое, при каждом выполнении процесса.

17. Нажмите "ОК" для завершения и сохранения настроек.

В окне настроек отобразится новый процесс сбора данных и его краткие характеристики.

Настройка сбора данных

18. Нажмите "ОК" для завершения и сохранения настроек, окно будет закрыто.


Настройка удаленного управления от ПЛК

ONI

Управление от ПЛК

Функция "Управление от ПЛК" позволяет выполнить определенное действие в проекте по условию изменения данных в регистре ПЛК, который задан в качестве управляющего.

Чтобы перейти к настройкам откройте меню "Настройки > Настройки системы > Управление от ПЛК", либо выберите соответствующий пункт в окне проекта.

Удаленное управление от ПЛК

1.Нажмите "Добавить", чтобы открыть диалоговое окно добавления новой функции управления.

Удаленное управление от ПЛК

2.Выберите действие из выпадающего списки, которое будет выполняться при выполнении условий.

·Переключить окно - переключить окно проекта по номеру.

·Сообщить номер активного окна - в указанный регистр будет записан номер соответствующий открытому окну проекта HMI.

·Управление подсветкой - управление подсветкой экрана панели.

·Выполнить макрос - выполнить макрос из списка ранее созданных.

·Управление звуком - подать сигнал зуммером или воспроизвести аудио-файл.

·Печать листа - печать экрана.

·Отключить зуммер - принудительное отключение звука зуммера.

·Захват экрана - выполнить и сохранить снимок экрана

3.Если действие требует привязки к определенному окну, активируйте данную опцию и укажите окно проекта.

4. Укажите устройство и адрес бита или регистра данных ассоциируемых с выбранным действием.

Примечание

Действие будет выполняться по условию состояние бита или данных в регистре, либо сохранять данные в указанный регистр.

5.Активируйте дополнительные опции при необходимости.

6.Нажмите "ОК", чтобы закрыть окно и сохранить сделанные настройки.

В окне настройки отобразиться новое действие.

7. Нажмите "ОК" для завершения и сохранения настроек, окно настроек закроется.


Настройка системных сообщений

ONI

Тревоги и события

Аварийные и тревожные состояния, которые генерируются автоматизированным оборудованием, могут быть транслированы в текстовые сообщения для упрощения считывания оператором и ускорения идентификации проблемы. Для этого в настройках проекта ONI Visual Studio заранее подготавливается список текстовых сообщений, которые будут выводится на экран и вноситься в журнал при наступлении событий, требующих внимания со стороны персонала.

Чтобы перейти к настройкам откройте меню "Настройки > Настройки системы > Тревоги и события", либо выберите соответствующий пункт в окне проекта.

Настройка системных сообщения

1.Все сообщения могут быть разделены на несколько групп (от 1 до 32). Для редактирования сообщений группы, выберите ее номер из выпадающего списка.

2.Если в проекте настроено несколько языков для интерфейса, то все сообщения можно также выполнить многоязычными. При редактировании последовательно выбирайте настроенные языки для редактирования текстов сообщений.

3.Настройка сохранения сообщений. В данном разделе выбирается место сохранения и объем накапливаемых данных. Если выбран вариант "Не сохранять" данные записываются в оперативную память и не сохраняется при отключении питания панели. При достижении максимального значения записей, самые старые записи будут автоматически удаляться при наступлении новых событий.

Настройка системных сообщений

В случае если выбран один из вариантов HMI, SD Card, USB1 данные сохраняются во флэш-памяти и их сохранность не зависит от наличия питания.

Настройка системных сообщений

Для вариантов хранилища SD Card или USB, панель должна поддерживать работу с данным носителем, и он должен быть установлен в соответствующий слот. В противном случае будет сформировано сообщение об ошибке.

4.Настройка счетчиков событий позволяет получить информацию об общем количестве сообщений и сформировать общий флаг при наличии аварийных.

Настройка системных сообщений

5.Если к панели подключен принтер, в данном разделе можно настроить вывод системных сообщений на печать.

Настройка системных сообщений

6.Для того, чтобы добавить новое сообщение вызовите диалоговое окно нажав "Создать".

Настройка системных сообщений

7.Выберите группу в которую будет добавлено новое сообщение, если это не было сделано на 1 шаге.

8.Всем сообщениям назначается один из трех уровней приоритета.

9.Настроенные языки интерфейса.

10. Поле ввода текста сообщения.

Примечание

Если в проекте несколько языков, то операции 9, 10 необходимо повторить для каждого языка выбирая их последовательно. Также для удобства редактирования предусмотрено несколько опций:

·A - Позволяет выбрать заранее настроенное текстовое сообщение из текстовой библиотеки

·B - Скопировать введенный текст для всех используемых языков проекта.

·С - Добавить тексты сообщений в текстовую библиотеку.

·D - Добавить в сообщение переменную из таблицы переменных для сообщений.

11. Настройки звукового сопровождение наступившего события. Это может быть звук встроенного зуммера "Зуммер", либо звуковой файл из библиотеки "Аудио", которые будут воспроизведены при возникновении события.

12. Настройка действий связанных с событием. Каждому событию может быть назначено несколько действий которые будут выполнены в одном из трех случаев:

·Нарушение - наступление события.

·Подтверждение - подтверждение пользователя.

·Восстановление - самопроизвольное восстановление.

В каждом случае может быть выполнено одно или несколько действий из числа доступных.

·Макрос - выполнить макрос

·Bit - адрес - установить или сбросить бит по адресу

·Word - адрес - изменить слово данных по заданному адресу

·Всплывающее окно - вызвать всплывающее окно из списка

·Печать информации - вывести сообщение на печать

·Отправить электронную почту - отправить сообщение по электронной почте

13. Кнопка вызывает диалог добавления условий при выполнении которых выводится данное сообщение. В качестве условия может выступать состояние битовой переменной или значение слова данных.

Настройка системных сообщений

Во втором случае, необходимо также задать уставки с которыми будет выполняться сравнение данных в заданном регистре и по результатам которого будет принято решение о формировании сообщения.

Настройка системных сообщений

Если все введено правильно, после закрытия окна, в поле "Условие вызова" должны отобразиться новые условия.

Настройка системных сообщений

14. Нажмите "ОК", чтобы закрыть окно и сохранить изменения. Диалоговое окно закроется, а в списке сообщений в окне настроек отобразится созданное сообщение.

Настройка системных сообщений

15. Нажмите "ОК" для завершения и сохранения настроек, окно настроек закроется.


Общие сведения

ONI

Общие сведения

Библиотеки используются для структурирования и хранения ресурсов проекта HMI необходимых для его создания и выполнения. Они позволяют повысить удобство работы разработчика и сократить объем данных, оптимизировав их использование.

В программе ONI Visual Studio предусмотрено несколько библиотек по типу ресурсов, работа с которыми описана в последующих разделах.


Библиотека текстов

ONI

Библиотека текстов

Библиотека используется для хранения различных текстов: переменных, сообщений, надписей, меток и т.п.

Для просмотра данных и редактирования библиотеки воспользуйтесь пунктом меню "Библиотеки > Библиотека текстов", либо выберите аналогичный пункт в окне проекта. Будет запущен менеджер библиотеки, главное окно которого представлено на рисунке.

Далее представлено описание элементов управления менеджера.

1.Поле поиска по библиотеке.

2.Настройка отображения многоязычных текстов. При нажатии данной кнопки будет выведено окно настойки, показанное на рисунке, с помощь которого можно настроить порядок отображения текстов при наличии нескольких языков в проекте.

A.Доступные языки и порядок отображения текстов в окне библиотеки.

B.Переход к языковым настройкам проекта.

C.Элементы управления порядком отображения.

D.Подтвердить или отменить изменения и закрыть окно.

3.Выполнить сортировку элементов библиотеки по имени.

4.Область данных в которой в виде таблицы отображаются все элементы библиотеки.

A.Имя элемента библиотеки.

B.Количество возможных статусов от 1 до 255.

C.Таблица вариантов текстов в зависимости от выбранного языка и действующего статуса.

Для редактирования любого поля достаточно выделить изменяемый текст с помощью курсора мыши и внести изменения с помощью клавиатуры.

5.Кнопки управления элементами библиотеки.

·Новый - добавить новый элемент в библиотеку.

·Удалить - удалить элемент из библиотеки.

·Импорт - импортировать элементы библиотеки из файла.

·Экспорт - экспортировать элементы библиотеки.

·Очистить - удалить все записи из библиотеки.

6.Алфавитный указатель для облегчения поиска элементов в библиотеке.

7.Выход из менеджера библиотеки.

·ОК - сохранить изменения и закрыть окно менеджера.

·Отмена - отменить изменения и закрыть окно менеджера.


Библиотека графики

ONI

Библиотека графики

Библиотека используется для хранения графических элементов, используемых для построения и оформления интерфейса управления.

Для просмотра данных и редактирования библиотеки воспользуйтесь пунктом меню "Библиотеки > Библиотека графики", либо выберите аналогичный пункт в окне проекта. Будет запущен менеджер библиотеки, главное окно которого представлено на рисунке.

Далее представлено описание элементов управления менеджера.

1.В данной области представлена структура данных библиотеки, которая по умолчанию состоит из трех основных разделов.

·Текущий проект - библиотека содержит графику текущего проекта.

·Избранные - раздел содержит элементы отмеченные как избранные.

·Библиотека графики - системная библиотека графики.

Для просмотра элемента библиотеки выделите желаемый раздел курсором мыши, щелкнув по нему левой кнопкой мыши.

2.Область просмотра элементов выбранной библиотеки.

3.Дополнительные фильтры просмотра элементов библиотеки.

·Только векторная графика - отображать элементы выполненные в векторной графике.

·Только редактируемая графика - отображать только доступную для редактирования графику.

4.Область просмотра настроенных статусов выделенного элемента библиотеки.

5.Кнопки управления элементами библиотеки.

·Импортировать - импортировать выделенный элемент в библиотеку текущего проекта.

·Добавить в избранное - добавить выделенный элемент в избранное.

·Добавить новую графику - запускает диалог добавления нового элемента в библиотеку.

·Редактировать - изменить графический элемент библиотеки.

·Переименовать - переименовать выделенный элемент. библиотеки.

·Удалить - удалить выделенный элемент из библиотеки.

6.Кнопка выхода из менеджера библиотеки.

Добавление нового элемента

Добавить новый элемент в библиотеку можно нажав кнопку "Добавить новую графику" в окне менеджера библиотеки, либо выбрав аналогичный пункт в главном меню "Библиотеки". Запустится диалог добавления нового элемента.

1.Введите имя нового элемента. Имя не должно повторять уже существующие в библиотеке имена.

2.Укажите количество статусов и размер изображения в пикселах.

3.Если новый элемент планируется создать на базе существующего, выберите опцию "Модифицировать существующий элемент" и выберите исходный элемент из библиотеки.

4.Для продолжения нажмите "ОК", либо "Отмена" для возврата. В рабочей области программы появится новая вкладка для редактирования новой графики.

Область "А" служит для переключения между статусами элемента, область "B" для редактирования графики выбранного статуса.

5.По окончании редактирования сохраните изменения выполнив команду "Сохранить проект" из меню "Файл".


Текстовая библиотека

ONI

Библиотека адресных меток

В ONI Visual Studio предусмотрена возможность присваивать текстовые метки для любого адреса во внутренней памяти панели, либо адреса в памяти внешнего устройства. Это позволяет в проекте обращаться к данным по имени метки, исключив операции выбора устройства и ввода адреса при настройке элементов интерфейса. Кроме того, это позволяет упростить адаптацию проекта к новому устройству в случае смены адресного плана размещения данных. В этом случае достаточно изменить адреса соответствующие адресным меткам.

Для просмотра данных и редактирования библиотеки воспользуйтесь пунктом меню "Библиотеки > Библиотека адресных меток", либо выберите аналогичный пункт в окне проекта. Будет запущен менеджер библиотеки, главное окно которого представлено на рисунке.

Библиотека адресных меток

Далее представлено описание элементов управления менеджера.

1.Таблица настроенных адресных меток.

2.Кнопки управления элементами библиотеки.

·Новый Bit - добавить новый элемент в библиотеку. При нажатии кнопки будет запущен диалог добавления новой метки, соответствующей биту данных.

Библиотека адресных меток

A.Имя адресной метки.

B.Выбор источника данных - устройство или внутренняя память панели.

C.Адрес регистра данных.

D.Данная опция позволяет назначить адресную метку для определенного бита в слове данных.

Библиотека адресных меток

·Новый Word - добавить новый элемент в библиотеку. При нажатии кнопки будет запущен диалог добавления новой метки, соответствующей регистру данных.

Библиотека адресных меток

A.Имя адресной метки.

B.Выбор источника данных - устройство или внутренняя память панели.

C.Адрес регистра данных.

·Удалить - удалить выделенный элемент из библиотеки.

·Правка - изменить выделенный элемент.

·Удалить все - удалить все элементы из библиотеки.

·Копировать - копировать выделенный элемент.

Информация из библиотеки может быть экспортирована во внешний файл для последующего редактирования или импорта в новый проект.

·Импорт - импортировать элементы библиотеки из файла.

·Экспорт - экспортировать элементы библиотеки в файл.

·Закрыть - закрыть окно менеджера библиотеки.

3.Выбор формата файла для сохранения экспортируемых данных.

·Csv - файл значений разделенный запятыми.

·Cfg - конфигурационный файл с данными.


Общие сведения

ONI

Общие сведения

В общем случае проект графического HMI состоит из одного или нескольких окон в которых располагаются элементы управления и индикации. ONI Visual Studio позволяет пользователю самостоятельно определить количество и дизайн окон в зависимости от поставленной задачи.

Для того, чтобы добавить новое окно в проект выберите пункт меню "Окна > Создать новое окно", либо перейдите в менеджер окон и дважды щелкните пункт "Создать новое окно" в разделе соответствующим типу нового окна. Будет открыто диалоговое окно "Новое окно" для настройки.

Для удобства все доступные настройки и функции объединены в группы и разнесены на несколько вкладок, переключение между которыми осуществляется в верхней части окна.


Общие настройки

ONI

Общие настройки

Вкладка используется для настройки основных свойств нового окна. Внешний вид и назначение основный полей представлено на рисунке.

1.Имя, краткое описание или текстовый идентификатор нового окна, для упрощения навигации между окнами при редактировании проекта.

2.Поле определяет порядок нумерации окон при добавлении нового. Номер каждого уникальный и используется для навигации между окнами проекта.

·Авто - окну присваивается наименьший свободный номер по порядку в соответствии с выбранным типом нового окна.

·Последний - окну присваивается очередной номер по возрастанию начиная с наибольшего номера существующего в группе.

·Заданный - номер окна задается пользователем вручную, при этом следует помнить, что в проекте не должно быть окон с одинаковым номером.

·Вставка со смещением - данная опция позволяет назначить окну ранее задействованный номер, при этом все окна с номером равным или большим заданному будут перенумерованы в сторону увеличения на единицу.

3.Если необходим ввод номера окна вручную, то укажите его в данном поле.

4.Если диалог создания нового окна был запущен из меню, то в данном поле присутствует возможность выбрать тип создаваемого окна. При сохранении окно будет размещено в соответствующем разделе в менеджере окон.

·Базовое окно - основной тип окон проекта

·Окно клавиатуры - окно экранной клавиатуры выводимой при необходимости ввода данных

·Системное окно - системное окно для вывода информационных сообщений

5.Задайте размер окна в пикселях и его ориентацию.

6.Настройки безопасности. Выберите уровень доступа, которым должен обладать пользователь для доступа к элементам окна. Активируйте опцию "При закрытии окна установить уровень доступа" если необходимо сменить текущий уровень доступа при закрытии окна, и выберите уровень который будет активирован.

7.Опционально основное окно может быть выведено на экран в виде всплывающего окна. Для этого предусмотрена опция "Всплывающее окно". После ее активации выберите позицию, в которой будет выводиться окно, а также выберите опции "Показывать заголовок" и "Монополизировать" если требуется ограничить активную область сенсора всплывающим окном.

8.Поверх каждого окна можно вывести до трех вспомогательных, что можно использовать, например, если в нескольких окнах используются идентичные элементы управления или шаблоны оформления.


Оформление

ONI

Оформление

Вкладка используется для настройки внешнего вида и оформления нового окна. Внешний вид и назначение основный полей вкладки представлено на рисунке.

1.Настройки фона окна. Можно выбрать монотонный цвет, фоновое изображение или один из вариантов текстурного заполнения.

2.Настройка размеров и цвета границ окна.


Действия и функции

ONI

Действия и функции

Вкладка используется для настройки действий который могут быть выполнены при открытии или закрытии окна в процессе выполнения проекта.

1.Для того чтобы добавить новое действие нажмите "Добавить". Откроется окно настройки действия.

2.Из выпадающего списка выберите событие при наступлении которого, будет выполнено дальнейшее действия.

3.Выберите и настройте действие, которое будет выполнено.

·Bit - изменение - изменить битовую переменную

·Word - изменение - изменить слово данных

·Выполнить макрос - выполнить макрос из числа настроенных в проекте

·Переключить окно - открыть заданное окно проекта

4.Нажмите "ОК" для сохранения настроек. В списке должно появиться новое действие.

5.При необходимости изменить порядок действий, удалить или отредактировать, выберите необходимое действие из списка и воспользуйтесь кнопками в данном поле.


Таймеры

ONI

Таймеры

Вкладка используется для создания и настройки таймеров, по условию срабатывания которых может выполняться определенное действие.

1.Для того чтобы добавить новый таймер нажмите "Добавить". Откроется окно настройки таймера, которое содержит несколько вкладок.

Вызов и останов

На данной вкладке настраивается период работы таймера, а также условия его запуска и останова.

2.Период работы таймера и задержка начала его работы с момента наступления события определенного, как условие для запуска.

3.Поле настройки условия запуска таймера. Может быть выбрано состояние бита, значение слова данных или логическое условие. Также в качестве условия выполнения таймера может быть указано состояние окна: открыто или закрыто.

4.Поле настройки условия останова таймера. Можно выбрать событие закрытия окна, условие выполнение заданного количества циклов с момента запуска, либо логическое или арифметическое условие.

Функция таймера

На данной вкладке настраивается действие, которое будет выполняться при каждом срабатывании таймера.

5.Запуск макроса - активируйте опцию и выберите макрос который будет выполнен при срабатывании таймера.

6.Изменение состояния - активируйте опцию и выберите тип переменной которая будет меняться при срабатывании таймера.

7.В данном поле выбирается тип операции выполняемой с переменной величиной.

8.Поле адреса переменной. Укажите адрес регистра или выберите соответствующую ему адресную метку.

9.Нажмите "ОК" для сохранения настроек. В списке должен появиться новый таймер с кратким описанием выполняемой функции.

10. При необходимости изменить состав таймеров, удалить или отредактировать, выберите таймер в таблице и воспользуйтесь кнопками редактирования в данном поле.


Передача данных

ONI

Передача данных

На данной вкладке можно выполнить настройку периодической передачи данных между внутренними регистрами панели оператора или обмен данными с внешним устройством.

1.Для того чтобы добавить новый процесс нажмите "Добавить". Откроется окно настройки передачи данных, которое содержит несколько вкладок.

Вызов и останов

На данной вкладке настраивается период выполнения, а также условия начала и завершения цикла передачи данных.

2.Период выполнения и задержка начала работы с момента наступления события определенного, как условие для запуска.

3.Поле настройки условия начала передачи данных. Может быть выбрано состояние бита, значение слова данных или логическое условие. Также в качестве условия выполнения таймера может быть указано состояние окна: открыто или закрыто.

4.Поле настройки условия завершения передачи данных. Можно выбрать событие закрытия окна, условие выполнение заданного количества циклов с момента запуска, либо логическое или арифметическое условие.

Передача данных

На данной вкладке настраивается тип и объем передаваемых данных, а также адреса источника и места назначения.

5.Передача данных может быть выполнена как в одностороннем режиме, так и в обоих направлениях между источником и местом назначения.

6.Тип и количество перемещаемых данных.

·Bit - бит

·Word - 16 битное слово

7.Адрес источника данных*

8.Адрес места назначения*

Примечание

В случае если перемещается более одного бита или слова данных, в данном поле задается начальный адрес размещения блока данных в памяти, все последующие адреса рассчитываются по порядку в сторону увеличения.

Уведомления

На данной вкладке настраиваются уведомления о начале или завершении процесса передачи данных (записи нового значения в память). Уведомление может выполнено путем изменения бита по заданному адресу, изменения слова данных или запуска выбранного макроса.

9.Нажмите "ОК" для завершения настройки, в списке должна отобразиться новая строка процессе передачи данных.

10.При необходимости изменить один из процессов передачи данных выберите его из списка и воспользуйтесь кнопками в данном поле.


Общие сведения

ONI

Общие сведения

Элемент "Клавиша" сочетает в себе функции визуального индикатора для отображения информации и простейшего элемента управления. При этом обе функции могут быть реализованы, как по отдельности, так и одновременно в зависимости от настроек.

Для удобства редактирования проекта, в главном меню и на панели инструментов предусмотрено несколько вариантов управления позволяющих добавить элемент в проект.

При этом пользователь может сразу предопределить желаемую функцию, а ONI Visual Studio открыть соответствующую вкладку в окне настройки.

При выборе одной из функций переключателя в меню или на панели инструментов открывается окно настроек и автоматически запускается диалог добавления новой функции.

1.Активировать либо деактивировать функцию клавиши.

2.Если окно для добавления новой функции не открылось автоматически, либо необходимо назначить элементу несколько функций, то его всегда можно вызвать, нажатием одной из кнопок в данном поле.

3.Для удобства навигации в проекте каждому элементу может быть задано текстовое описание.

4.Если элементу назначено несколько функций, то порядок их выполнения может быть изменен при необходимости. Элементы управления списком функций активируются при выделении одной из них.


Изменить - Bit

ONI

Изменить бит

Функция изменяет состояние битовой переменной при нажатии или отпускании сенсора экрана в области элемента.

1.Событие, по условию наступления которого будет выполнено действие.

·Нажать - действие будет выполнено при нажатии экрана

·Отпустить - действие будет выполнено при снятии нажатия с экрана

2.Действие которое будет выполнено при наступлении события определенного в п.1.

·Установить [1] - установить бит в состояние логической единицы

·Установить [0] - установить бит в состояние логического нуля

·Инвертировать - Инвертировать бит

·Сброс - Сбросить бит

·Импульс [1] - Переключить бит в состояние логической единицы на заданное время

·Импульс [0] - Переключить бит в состояние логического нуля на заданное время

3.Адрес битового регистра для выбранной операции.

4.Нажмите "ОК", чтобы сохранить изменения и закрыть диалоговое окно.


Изменить - Word

ONI

Изменить слово данных

Функция изменяет состояние (значение) слова данных при нажатии или отпускании сенсора экрана в области элемента.

1.Событие, по условию наступления которого будет выполнено действие.

·Нажать - действие будет выполнено при нажатии экрана

·Отпустить - действие будет выполнено при снятии нажатия с экрана

2.Действие которое будет выполнено при наступлении события определенного в п.1.

·Сложить - выполнить операцию сложения

·Вычесть - выполнить операцию вычитания

·Увеличить - циклически увеличивать значение в регистре с заданным интервалом

·Уменьшить - циклически уменьшать значение в регистре с заданным интервалом

·Задать значение - записать значение или константу в регистр

·Задать строку - записать текстовую строку в регистр (в несколько регистров подряд)

·Изменить разряд - изменить количество единиц, десятков, сотен и т.д. в значении

·Логическая операция - выполнить побитную логическую операцию

3.Данные для выполнения выбранного действия.

4.Адрес регистра данных с которыми выполняются операции.

5.Нажмите "ОК", чтобы сохранить изменения и закрыть диалоговое окно.


Операции с окнами

ONI

Операции с окнами

Функция позволяет организовать управление окнами проекта при нажатии или отпускании сенсора экрана в области элемента.

1.Событие, по условию наступления которого будет выполнено действие.

·Нажать - действие будет выполнено при нажатии экрана

·Отпустить - действие будет выполнено при снятии нажатия с экрана

2.Действие которое будет выполнено при наступлении события определенного в п.1.

·Переключить окно - открыть окно по его номеру

·Закрыть всплывающее окно - закрыть всплывающее окно по его номеру

·Вывести всплывающее окно - вывести всплывающее окно по его номеру

·Вернуться в предыдущее окно - вернуться к предыдущему окну проекта

·Панель управления окном - область управления позицией всплывающего окна, позволяет реализовать функции перетаскивания окна по экрану.

·Вернуться в главное окно - открыть окно заданное в настройках проекта, как главное

3.Поле выбора окна в отношении которого будет выполнено выбранное действие.

4.Если вызываемое окно требует определенного уровня доступа, данная опция позволяет выводить запрос пароля автоматически при попытке вызова окна.

5.Нажмите "ОК", чтобы сохранить изменения и закрыть диалоговое окно.


Специальные функции

ONI

Специальные функции

Данное действие позволяет вызвать одну из специальных функций при нажатии или отпускании сенсора экрана в области элемента.

1.Событие, по условию наступления которого будет выполнено действие.

·Нажать - действие будет выполнено при нажатии экрана

·Отпустить - действие будет выполнено при снятии нажатия с экрана

2.Функции виртуальной клавиатуры.

·Return - вернуть курсов в начало новой строки

·Backspace - удалить символ перед курсором

·Очистить - очистить поле ввода

·Отменить - отменить действие

·UNICODE - вставить символ UNICODE в поле ввода

·Операция с текстом - операции редактирования текста (вырезать, вставить, копировать)

·Аппаратные клавиши - имитировать нажатие аппаратных клавиш панели

3.Функция вызова макроса.

4.Системные функции.

·Калибровка - запустить процедуру калибровки сенсорного экрана

·Импорт/Экспорт - импортировать или экспортировать проект или рецепт на внешний носитель

·Снимок экрана - сохранить снимок экрана на внешний носитель USB или SD

·Очистить события - очистить события из выбранной группы

·Удалить все рецепты - удалить все рецепты из памяти

·Очистить RW регистры - удалить данные из энергонезависимой памяти панели

·Удалить все архивы - удалить все журналы и архивы данных

5.Распечатать содержимое экрана с выбранной ориентацией.

6.Нажмите "ОК", чтобы сохранить изменения и закрыть диалоговое окно.


Передача данных

ONI

Передача данных

Нажатие или отпускание сенсора экрана в области элемента вызывает процесс передачи данных если данная функция добавлена и настроена.

1.Событие, по условию наступления которого будет выполнено действие.

·Нажать - действие будет выполнено при нажатии экрана

·Отпустить - действие будет выполнено при снятии нажатия с экрана

2.Тип и количество перемещаемых данных.

·Bit - бит

·Word - слово данных 16 бит

3.Адрес источника данных*

4.Адрес места назначения*

5.Нажмите "ОК", чтобы сохранить изменения и закрыть диалоговое окно.

Примечание

В случае если перемещается более одного бита или слова данных, в данном поле задается начальный адрес размещения блока данных в памяти, все последующие адреса рассчитываются по порядку в сторону увеличения.


Передача рецепта

ONI

Передача рецепта

Данная функция позволяет настроить передачу данных рецепта между HMI-панелью и подключенным ПЛК, при нажатии или отпускании сенсора экрана в области элемента.

1.Событие, по условию наступления которого будет выполнено действие.

·Нажать - действие будет выполнено при нажатии экрана

·Отпустить - действие будет выполнено при снятии нажатия с экрана

2.Направление и количество перемещаемых данных.

3.Адреса источника данных (имя рецепта) и места назначения*.

4.Флаг активной передачи. Бит по указанному адресу будет установлен в состояние логической единицы если процесс передачи данных активен.

5.Нажмите "ОК", чтобы сохранить изменения и закрыть диалоговое окно.

Примечание

В случае если перемещается более одного бита или слова данных, в данном поле задается начальный адрес размещения блока данных в памяти, все последующие адреса рассчитываются по порядку в сторону увеличения.


Общие сведения

ONI

Общие сведения

Элемент "Индикатор" сочетает в себе функции визуального индикатора для отображения информации и простейшего элемента управления. При этом обе функции могут быть реализованы, как по отдельности, так и одновременно в зависимости от настроек.

Для удобства редактирования проекта, в главном меню и на панели инструментов предусмотрено несколько вариантов управления позволяющих добавить элемент в проект.

При этом пользователь может сразу предопределить желаемую функцию, а ONI Visual Studio открыть соответствующую вкладку в окне настройки.

При выборе одной из функций индикатора в меню или на панели инструментов открывается окно настроек на вкладке "Индикатор". Поля на данной вкладке позволяют определить режим работы и условия переключения внешнего вида (статуса) индикатора.

1.Активировать либо деактивировать функцию индикатора для данного элемента.

2.Выбрать режим работы.

·Состояние регистра - состояние индикатора определяется состоянием битового регистра или значением данных по указанному адресу

·Цикличная смена - циклическая смена всех возможных состояний индикатора по замкнутому кругу с заданным временным интервалом.

3.Тип индикатора в зависимости от типа данных.

·Bit - регистр - битовый индикатор, отображает состояние бита в регистре или слове данных

·Word - регистр - индикатор, состояние которого определяется значением в регистре данных

·Последовательность - индикатор отображает состояние последовательности бит


Bit - индиктор

ONI

Bit - индикатор

Используется для отображения состояния битового регистра, соответственно может иметь только два возможных статуса соответствующих логическому нулю или логической единице в регистре.

1.Адрес регистра, состояние которого будет отображать индикатор. В случае если данный элемент также используется в качестве клавиши и функция индикатора необходима для отображения ее состояния, можно активировать опцию "Использовать адрес клавиши", значение адреса будет автоматически скопировано.

2.Список возможных статусов отображения элемента и их соответствие состояниям выбранного регистра.

3.Выбор прямой или инвертированной индикации. Если выбрана инверсия, то состоянию логического нуля в регистре будет соответствовать 1-ый статус элемента и наоборот.

4.Режим мерцания используется для привлечения дополнительного внимания к элементу и может быть независимо настроен для каждого из статусов. Для изменения настройки выберите требуемую строку в списке статусов и выберите один из вариантов мерцания.

·Нет - мерцание не выполняется

·Мерцающий текст - мерцающий текст надписи

·Мерцающий фон - мерцающее фоновое изображение элемента

5.При необходимости можно добавить текстовое описание для упрощения идентификации элемента в окне менеджера элементов.


Word - индикатор

ONI

Word - индикатор

Используется для отображения состояния регистра данных 16 бит, и в отличие от битового индикатора может иметь до 256 возможных статусов с индивидуальной настройкой.

1.Адрес регистра, состояние которого будет отображать индикатор. В случае если данный элемент также используется в качестве клавиши и функция индикатора необходима для отображения его состояния, можно активировать опцию "Использовать адрес клавиши", значение адреса будет автоматически скопировано.

2.Количество отображаемых статусов элемента.

3.Список возможных статусов элемента и их соответствие состояниям выбранного регистра.

4.В данном поле задается условие активации статуса - состояние регистра. При этом в качестве условия можно выбрать сравнение значения в регистре с константой или переменной.

Или проверить состояние определенного бита в регистре по его номеру. Во втором случае, можно также выбрать режим прямой или инвертированной индикации. В случае последней статус будет активен если указанный бит находится в состоянии логического нуля.

5.Режим мерцания используется для привлечения дополнительного внимания к элементу и может быть независимо настроен для каждого из статусов. Для изменения настройки выберите требуемую строку в списке статусов и выберите один из вариантов мерцания.

·Нет - мерцание не выполняется

·Мерцающий текст - мерцающий текст надписи

·Мерцающий фон - мерцающее фоновое изображение элемента

6.В данном поле настраивается реакция индикатора на состояние регистра, которое не соответствует ни одному из заданных статусов.

·Показать статус ошибки - отображать статус соответствующий состоянию "ошибка"

·Сохранять последний статус - сохранить последний статус до устранения ошибки

·Уведомление об ошибке - сообщить об ошибке статуса, установив бит в указанном регистре

7.При необходимости можно добавить текстовое описание для упрощения идентификации элемента в окне менеджера элементов.


Общие сведения

ONI

Общие сведения

Элемент "Дисплей" используется для вывода или ввода/вывода текстовых или цифровых данных на экран.

Для удобства редактирования проекта, в главном меню и на панели инструментов предусмотрено несколько вариантов управления позволяющих добавить элемент "Дисплей" в проект.

При этом пользователь может сразу предопределить желаемую функцию, а ONI Visual Studio активировать соответствующую опцию в окне настройки.

Вне зависимости от выбранной функции, сохраняется возможность ее изменить в любой момент на один из четырех возможных вариантов.

·Цифровой дисплей - вывод на экран цифровых значений

·Цифровой ввод - поле ввода цифровых значений

·Символьный дисплей - вывод на экран текстовый и символьных данных

·Символьный ввод - поле ввода символьных значений


Цифровой дисплей

ONI

Цифровой дисплей

Основные настройки элемента задаются на вкладке "Общие" в окне настроек, внешний вид которой представлен на рисунке.

1.Поле адреса регистра памяти, значение в котором будет отображаться дисплеем.

2.Опция позволяет скрыть символы маской, если индикатор используется для отображения пароля.


Цифровой ввод

ONI

Цифровой ввод

Основные настройки элемента задаются на вкладке "Общие" в окне настроек, внешний вид которой представлен на рисунке.

1.Поле ввода адреса регистра памяти, значение из которого будет отображаться дисплеем.

2.Опция маскировки позволяет скрыть символы маской, что может потребоваться если поле используется для ввода или отображения пароля.

3.Опция позволяет разделить отображаемые и вводимые данные и задать адреса для чтения и записи независимо.

4.Поле ввода адреса регистра памяти, в который будет сохранено значение вводимое в поле ввода. Поле активируется при выборе опции "Адреса чтения и записи различны"


Формат дисплея

ONI

Формат числа

Настройки формата дисплея, определяют тип данных с которым предстоит работать, а также формат в котором данные будут отображаться на экране. В процессе подготовки данных к выводу на экран ONI Visual Studio позволяет выполнить конвертацию или масштабирование значения в памяти перед выводом на экран.

Описание полей на вкладке настроек приведено ниже.

1.Формат данных.

2.Количество разрядов дисплея.

3.Количество знаков после десятичной точки.

4.Отображать знак "+" в случае если значение положительное.

5.Отображать все разряды числа в соответствии с выбранным форматом.

6.Верхний и нижний пределы значений данных.

7.Индикация нарушения предельных значений, изменением цвета шрифта.

8.Активировать опцию конвертации и масштабирования значений.

9.Пропорциональное преобразование значения к заданному диапазону.

10. Масштабирование с помощью коэффициентов "усиление" и "смещение".

11. Логические операции и операции сдвига.


Символьный дисплей

ONI

Символьный дисплей

Основные настройки элемента задаются на вкладке "Общие" в окне настроек, внешний вид которой представлен на рисунке.

1.Поле ввода начального адреса регистров памяти, значения в которых будут отображаться дисплеем. Количество регистров необходимых для размещения данных зависит от используемой кодировки символов и организации памяти. Например, при использовании внутренней памяти панели для размещения 10 символов в кодировке ASCII понадобится 5 регистров LW0-LW4.

2.Настройки кодировки символов и параметров отображения.

·ASCII - если опция выбрана, данные будут преобразовываться в символы таблицы ASCII. Каждый символ кодируется одним байтом и одно слово данных (16 бит) содержит информацию о двух символах.

·Пароль - опция маскировки позволяет скрыть символы маской, что может потребоваться если поле используется для отображения пароля.

·Unicode - если опция выбрана, данные будут преобразовываться в символы таблицы UNICODE. Каждый символ кодируется двумя байтами, одно слово данных (16 бит) содержит информацию об одном символе.

·Перестановка байт в слове - опция становится активной в случае выбора кодировки ASCII и определяет порядок расположения кодов символов в слове данных.

3.Поле настройки метода прокрутки текста в области, если его размер превышает видимую часть.

·Сенсор - непосредственная прокрутка, касанием сенсора в области текстового поля (только для емкостных экранов).

·Полоса прокрутки - полоса прокрутки в левой части поля индикатора.

·Ширина - желаемая ширина полосы прокрутки в пикселах.


Символьный ввод

ONI

Символьный ввод

Основные настройки элемента задаются на вкладке "Общие" в окне настроек, внешний вид которой представлен на рисунке.

1.Поле ввода начального адреса регистров памяти, значения в которых будут отображаться дисплеем. Количество регистров необходимых для размещения данных зависит от используемой кодировки символов и организации памяти. Например, при использовании внутренней памяти панели для размещения 10 символов в кодировке ASCII понадобится 5 регистров LW0-LW4.

2.Настройки кодировки символов и параметров отображения.

·ASCII - если опция выбрана, данные будут преобразовываться в символы таблицы ASCII. Каждый символ кодируется одним байтом и одно слово данных (16 бит) содержит информацию о двух символах.

·Пароль - опция маскировки позволяет скрыть символы маской, что может потребоваться если поле используется для отображения пароля.

·Unicode - если опция выбрана, данные будут преобразовываться в символы таблицы UNICODE. Каждый символ кодируется двумя байтами, одно слово данных (16 бит) содержит информацию об одном символе.

·Перестановка байт в слове - опция становится активной в случае выбора кодировки ASCII и определяет порядок расположения кодов символов в слове данных.

3.Поле настройки метода прокрутки текста в области, если его размер превышает видимую часть.

·Сенсор - непосредственная прокрутка, касанием сенсора в области текстового поля (только для емкостных экранов).

·Полоса прокрутки - полоса прокрутки в левой части поля индикатора.

·Ширина - желаемая ширина полосы прокрутки в пикселах.

4.Опция позволяет разделить отображаемые и вводимые данные и задать адреса для чтения и записи независимо.

5.Поле ввода начального адреса регистров памяти, в которых будет сохранено значение вводимое в поле ввода. Данное поле активно при выборе опции "Адреса чтения и записи различны"


Формат дисплея

ONI

Формат дисплея

Настройки формата дисплея, определяют порядок расположения текстовой информации в поле вывода и ее объем.

Описание полей на вкладке настроек приведено ниже.

1.Форматирование текста.

·Количество строк - максимальное количество строк текста.

·Показывать строк - количество строй текста, которое отображается на экране.

·Количество символов - количество символов в строке.


Настройки клавиатуры

ONI

Настройки клавиатуры

На данной вкладке можно настроить параметры клавиатуры, которая будет использоваться для ввода значений в поле ввода.

Описание полей на вкладке настроек приведено ниже.

1.Режим управления экранной клавиатурой.

·Сенсор - клавиатура будет вызываться автоматически при касании экрана.

·Триггер - клавиатура будет отображаться в зависимости от состояния заданного бита.

2.Если опция активна, то при выполнении условий заданных в п.1. на экран будет выведена выбранная клавиатура в виде всплывающего окна.

3.Поле настройки позиции виртуальной клавиатуры при ее выводе на экран.

·Авто позиция - позиция клавиатуры определяется автоматически в привязке к полю ввода.

·Относительная позиция - заданное положение относительно сторон экрана.

·Фиксированная позиция - заданное положение в пикселах.

4.Если опция активна, то виртуальная клавиатура выводится на экран не будет. В данном случае ввод значений в поле возможен либо с внешней аппаратной клавиатуры, либо с помощью настроенных ранее элементов существующего окна, которые имитируют нажатие клавиш.

5.Данная функция может быть использована для автоматического перехода между полями при вводе данных. Если опция активна, то при окончании ввода в данном поле, фокус ввода автоматически перейдет к полю с большим номером "Порядок ввода" по порядку.

Если на экране присутствует несколько независимых цепочек ввода информации их можно разделить на группы, при этом фокус ввода будет передаваться от элемента к элементу в пределах одной группы. Опция "Не переходить к следующему полю" отключает автоматический переход к следующему полю ввода.


Настройки шрифта

ONI

Настройки шрифта

На данной вкладке настраивается шрифт, который будет использоваться при отображении значений в поле дисплея. Шрифт может быть настроен как вручную, так и выбран из ранее настроенных шаблонов.

Описание полей на вкладке настроек приведено ниже.

1.Настройки шрифта.

2.Импортировать ранее настроенный шаблон шрифта.


График

ONI

График

Компонент "График" предназначен для графического отображения информации в виде линейного графика зависимости параметра от времени.

Основные настройки компонента задаются на вкладке "Общие" в окне настроек. Вид вкладки представлен на рисунке ниже.

К основным настройкам графика относится выбор типа отсчета и объем выводимой информации по временной оси [1]. Можно указать количество точек данных или задать временной интервал, который будет выведен в видимой области графика. В случае если объем данных превышает заданный размер видимой области, то для навигации [2] может использоваться полоса прокрутки или листание жестом.

Направление построения графика может быть как горизонтальным, так и вертикальным [3]. Для удобства считывания процесс построения графика может быть приостановлен установкой бита в указанном регистре в состояние логической единицы [4].

Для измерения значения переменной в поле графика может быть использован курсор [5]. Если данная опция активна, то необходимо указать в настройках битовый регистр - состояние которого будет управлять отображением курсора и регистры данных в которые будет записано значение переменной. В приведенном примере отображением курсора управляет регистр LB1, данные сохраняются в регистры начиная с LW100 последовательно. При этом первые семь регистров служат для сохранения временной метки в порядке: год, месяц, день, час, минуты, секунды и миллисекунды (в примере соответственно LW100-LW106), начиная с седьмого регистра записываются данные каналов (в примере LW107- первый канал, LW108-второй и т.д.).

Видимая область графика может быть масштабирована с помощью регистра, в котором сохраняется значение масштаба 1-100%. Для этого необходимо активировать данную опцию и указать регистр, как показано в примере. Для панелей с емкостным сенсором может быть задействована функция масштабирования жестом по аналогии со смартфонами и планшетами.


График XY

ONI

График XY

Компонент "График XY" предназначен для графического отображения информации в виде линейного графика зависимости Y от X.

Основные настройки компонента задаются на вкладке "Общие" в окне настроек. Вид вкладки представлен на рисунке ниже.

К основным настройкам графика относится выбор способа обновления графика [1]. Можно выбрать цикличный способ обновления и указать временной интервал, либо обновление по событию и указать адрес регистра, изменение состояние которого будет служить условием для обновления данных. Также к основным настройкам относится количество точек данных выводимых на экран [2], а также регистры управления процессом вывода данных: пауза и очистка [3].

Для измерения значения переменной в поле графика может быть использован курсор [4]. Если данная опция активна, то необходимо указать в настройках битовый регистр - состояние которого будет управлять отображением курсора и регистры данных в которые будет записано значение переменной. В приведенном примере отображением курсора управляет регистр LB5, данные сохраняются в регистры начиная с LW0 последовательно. При данные каналов сохраняются последовательно начиная с указанного регистра (в примере LW0- первый канал, LW1-второй и т.д.).


Точечный график

ONI

Точечный график

Компонент "Точечный график" предназначен для отображения значений нескольких смежных регистров в виде точек объединенных прямой линией.

Основные настройки компонента задаются на вкладке "Общие" в окне настроек. Вид вкладки представлен на рисунке ниже.

На данной вкладке определяется количество точек отображаемых на экране и направление построения графика (горизонтальное или вертикальное) [1]. В случае если объем данных превышает заданный размер видимой области, то для навигации может использоваться полоса прокрутки или листание жестом [3].

В поле [2] можно настроить способ обновления данных и выбрать либо цикличный способ обновления и указать временной интервал, либо обновление по событию и указать адрес регистра, изменение состояние которого будет служить условием для обновления данных.

Процесс построения графика можно приостановить и очистить данные с помощью регистров указанных в данном разделе настроек [4]. В приведенном примере установка бита LB0 в состояние логической единицы приостановит процесс вывода данных на экран, установка бита LB1 очистит данные.

Для измерения значения переменной в поле графика может быть использован курсор [5]. Если данная опция активна, то необходимо указать в настройках битовый регистр - состояние которого будет управлять отображением курсора и регистры данных в которые будет записано значение переменной. В приведенном примере отображением курсора управляет регистр LB5, данные сохраняются в регистры начиная с LW100 последовательно. При этом первые два регистра содержат порядковый номер точки (в примере соответственно LW100-LW101), начиная со второго регистра записываются данные каналов (в примере LW102- первый канал, LW103-второй и т.д.).

Видимая область графика может быть масштабирована с помощью регистра, в котором сохраняется значение масштаба 1-100%. Для этого необходимо активировать данную опцию и указать регистр, как показано в примере. Для панелей с емкостным сенсором может быть задействована функция масштабирования жестом по аналогии со смартфонами и планшетами.


Круговой график

ONI

Круговой график

Компонент "Круговой график" предназначен для отображения информации в виде кругового графика в котором значение величины определяет радиус до кривой графика, угол вектора определяется значением времени.

Основные настройки компонента задаются на вкладке "Общие" в окне настроек. Вид вкладки представлен на рисунке ниже.

Поле [1] позволяет выбрать начальную точку и емкость графика в диапазоне от 1 до 24 часов, а также задать соотношение внешнего и внутреннего радиусов рабочего поля. Указанные выше настройки могут быть как статическими, заданными однажды при настройке проекта, так и меняться в процессе работы. Во втором случае необходимо установить галочки и выбрать регистры значения в которых будут определяющими.

Процесс построения графика можно приостановить с помощью регистра указанного в данном разделе настроек [2]. В приведенном примере установка бита LB0 в состояние логической единицы приостановит процесс вывода данных на экран.

Поле [3] управляет навигацией по накопленной информации. В приведенном примере регистр LW200 определяет количество циклов графика на которые необходимо сместиться во времени назад для просмотра данных невидимых в текущий момент времени. LW201 и LW202 определяют количество импортируемых циклов графика до текущего момента и после.

Для измерения значения переменной в поле графика может быть использован курсор [4]. Если данная опция активна, то необходимо указать в настройках битовый регистр - состояние которого будет управлять отображением курсора и регистры данных в которые будет записано значение переменной. В приведенном примере отображением курсора управляет регистр LB1, данные сохраняются в регистры начиная с LW100 последовательно. При этом первые семь регистров служат для сохранения временной метки в порядке: год, месяц, день, час, минуты, секунды и миллисекунды (в примере соответственно LW100-LW106), начиная с седьмого регистра записываются данные каналов (в примере LW107- первый канал, LW108-второй и т.д.).


График / Круговой график

ONI

График / Круговой график

Графики данного типа используют архивы собранных данных в качестве источника, поэтому процессы сбора данных должны присутствовать в проекте обязательно. Они могут быть настроены заранее, либо процесс настройки можно вызвать из окна настройки графика нажав кнопку [1].

Далее из числа настроенных выбирается процесс сбора данных, данные которого будут использоваться для построения графика [2]. Также в случае если в процессе присутствует несколько каналов сбора данных, в поле [3] необходимо отметить необходимые.

Для каждого канала можно настроить максимальное и минимальное значения, которые будут соответствовать минимуму и максимуму значений оси, а также цвет и стиль линии. Для выполнения настройки необходимо предварительно выделить настраиваемый канал в списке [3].

Компонент график может автоматически обработать объем накопленных данных и записать в регистры минимальное и максимальное значения при активации опции [5]. В данном примере минимальное значение массива данных 1 канала будет записано в LW100, максимальное LW200. Опция независимая и может быть включена или отключена для каждого канала индивидуально.


График XY / Точечный график

ONI

График XY / Точечный график

Данные графиков этого типа не зависят от процессов сбора данных и сохраняются в рабочей памяти панели оператора.

В настройках задается количество каналов выводимых на экран [1], а также стартовые адреса регистров хранения значений и тип данных [2]. При этом адреса регистров данных оси Y могут быть указаны независимо или назначены автоматически, в первом случае данные в памяти располагаются по порядку начиная с указанного адреса.

Для каждого канала можно настроить максимальное и минимальное значения, которые будут соответствовать минимуму и максимуму значений оси, а также цвет и стиль линии [3]. Для выполнения настройки необходимо предварительно выделить настраиваемый канал в списке [2].


Настройки поиска

ONI

Настройки поиска

Функция поиска позволяет отфильтровать и вывести на экран данные удовлетворяющие определенному критерию. Для ее настройки перейдите на вкладку "поиск" в окне настройки компонента.

Выберите тип поиска [1] из доступных вариантов:

·Поиск по дате

·Поиск по временному диапазону

·Поиск по дням

·Динамический выбор поиска

Примечание

В случае динамического выбора типа поиска - тип поиска определяется значением в указываемом регистре в следующем соответствии: 0-Поиск по дате, 1-Поиск по временному диапазону, 2-Поиск по дням.

Укажите бит запуска поиска и регистр в котором будут условия для его выполнения. В зависимости от типа поиска количество задействованных регистров и расположение данных различное, пожалуйста, руководствуйтесь подсказками в окне настроек. В приведенном примере в случае если в регистре LB0 находится логическая единица, в области графика отображаются результаты поиска , в противном случае выводятся текущие данные.

Также на вкладке поиска можно настроить экспорт данных, для этого активируйте соответствующую опцию.

Для настройки экспорта укажите битовый регистр изменение состояния которого будет запускать процесс экспорта [1], выберите место назначения для экспортируемых данных [2]. Это может быть внутренняя память панели HMI, карта памяти SD или USB диск. Экспорт данных выполняется в директорию имя которой может быть задано статично, в случае если опция [3] не активна, или динамически, тогда в качестве имени используется строковая переменная сохраненная по указываемому адресу. В первом случае используется имя введенное в поле в процессе настройки, например CSV_EVENT.

Экспорт данных может быть выполнен в новый файл за каждые сутки или в единый файл, в этом случае становится доступна возможность задать имя файла.

Процесс выполнения экспорта может быть визуализирован с использованием опции [5], при активации которой в указанный регистр сохраняется процент выполнения.

В дальнейшем данный регистр можно использовать для вывода информации с помощью визуальных компонентов построения интерфейса, например шкал.


Настройки шкалы

ONI

Настройки шкалы

Вкладка "шкала" позволяет настроить внешний вид и конфигурацию шкал обрамляющих область графика.

Поле [1] определяет фон и внешний вид рабочей области компонента, здесь можно выбрать цвета фона или отключить заливку, оставив фон прозрачным.

Поле [2] настраивает внешний вид, разметку и подписи оси "Х". В данном разделе можно выбрать цвет оси, количество делений и промежуточных делений шкалы, а также длину меток [A]. Поверх графика можно вывести сетку для удобства проведения измерений [B], выбрав ее цвет, и задать формат и вид подписей размещаемых по оси [C]. В зависимости от типа графика это может быть порядковый номер точки, временная метка или максимальное и минимальное значение шкалы. В последнем случае значения могут быть заданы в ручную или рассчитаны автоматически исходя из максимального и минимального значений данных.

Поле [3] настраивает внешний вид, разметку и подписи оси "Y". В данном разделе можно выбрать цвет оси, количество делений и промежуточных делений шкалы, а также длину меток [A]. Поверх графика можно вывести сетку для удобства проведения измерений [B], выбрав ее цвет, и задать формат и вид подписей размещаемых по оси [C]. В зависимости от типа графика это может быть порядковый номер точки, временная метка или максимальное и минимальное значение шкалы. В последнем случае значения могут быть заданы в ручную или рассчитаны автоматически исходя из максимального и минимального значений данных.


Надпись

ONI

Надпись

Текстовая надпись настраивается в свойствах элементов "Клавиша" и "Индикатор", и функционально может быть как обычной подписью для идентификации органов управления и выполняемых ими функций, так и дополнительным средством отображения состояния элемента, т.к. текст надписи может быть настроен для каждого статуса индивидуально.

Настроить надпись можно на соответствующей вкладке в окне настроек элементов "клавиша" и "индикатор".

Далее приведено описание полей настроек, представленных на рисунке.

1.Поле позволяет активировать либо деактивировать опцию использования текстовой метки для данного элемента. Если опция не активна, надпись выводится на экран не будет.

2.Надписи могут быть настроены независимо не только для каждого статуса, но и для каждого языка при создании многоязычных проектов. Для настройки надписи последовательно выбирайте ранее настроенные языки из выпадающего списка. Если текст надписи не меняется при смене языка интерфейса, то можно выбрать опцию "Независим от языка", независимая настройка будет отключена.

3.В качестве текстовой метки можно использовать элемент текстовой библиотеки, для этого активируйте данную опцию и выберите элемент из списка.

4.Обратная функция - сохранение введенных текстов надписи в библиотеке текстов, что позволяет сохранить тексты для последующего использования в подобных элементах.

5.В данном поле отображаются все доступные статусы элемента и соответствующие им текстовые надписи. Для редактирования текста, выделите строку, которую требуется изменить и воспользуйтесь полем ввода 6 или форматирования 9.

6.Поле ввода или редактирования текста надписи.

7.Опция копирования текста для ускорения ввода и настройки. Может быть задействована если текст одинаков для всех статусов или языков.

·Все статусы - скопировать текущий текст на все доступные статусы элемента.

·Все языки - скопировать текущий текст на все языки применимые к текущему статусу.

·Все - скопировать текущий текст одновременно на все языки и на все статусы.

8.Настройки выравнивания текстовой метки относительно границ элемента при выводе на экран.

9.Настройки шрифта и оформления текста метки. Данные настройки могут быть выполнены независимо для каждого статуса и для каждого языка, а также загружены из шаблона если они используются в проекте.

10. Кнопки копирования настроек для удобства редактирования, позволяют скопировать форматирование текста на:

·Все статусы - скопировать форматирование на все доступные статусы элемента.

·Все языки - скопировать форматирование на все языки применимые к текущему статусу.

·Все - скопировать форматирование одновременно на все языки и на все статусы.


Оформление

ONI

Оформление

Вкладка "Оформление" позволяет настроить внешний вид элемента для каждого из возможных статусов.

Далее приведено описание полей настроек, представленных на рисунке.

1.Поле позволяет активировать либо деактивировать опцию использования графики для данного элемента.

2.Графическая библиотека текущего проекта. Для того чтобы выбрать вариант оформления просто выберите его курсором.

3.При необходимости можно добавить новую графику в библиотеку проекта. Сделать это можно либо из встроенной библиотеки программы "Импортировать", либо создав новый элемент библиотеки вручную "Добавить новую графику".

4.Поле для предварительного просмотра выбранного элемента, в котором одновременно отображается внешний вид элемента для каждого из статусов.

5.Выбранный графический элемент может быть изменен для адаптации к поставленной задаче, путем добавления новых статусов либо редактированием внешнего вида. Для этого воспользуйтесь кнопкой "Редактировать".

6.В данном поле содержатся дополнительные настройки визуальных эффектов, которые могут быть задействованы при использовании графики.


Анимация

ONI

Анимация

В случае если элемент экрана допускает применение анимации, то в окне его свойств доступна вкладка "Анимация". Опции которой позволяют привязать состояние элемента к данным в регистрах памяти, тем самым организовать управление положением и/или внешним видом элемента.

1.Для использования данной возможности активируйте опцию "Использовать анимацию" на вкладке "Анимация" в окне настроек элемента.

2.Выберите адрес регистра (стартовый адрес регистров) значение в котором, будет определять положение элемента.

3.Активируйте опцию управления позицией, при этом положение по оси X будет определяться значением в регистре адрес которого указав в п.2, положение по оси Y значением из регистра, следующего по порядку за указанным.


Отображение

ONI

Отображение

Данная вкладка используется для настройки положения и размеров элемента при отображении на экране, а также позволяет определить внешние условия, при выполнении которых элемент будет виден или скрыт.

1.Позиция и размер элемента в пикселах. Отсчет позиции ведется от верхнего левого угла экрана. Опция "Заблокировано" позволяет запретить изменение размера и положения элемента с помощью указателя мыши в редакторе окон.

2.Условия видимости элемента на экране. В случае если выбран вариант "Показывать всегда" элемент будет отображаться всегда, какие-либо условия проверяться не будут. Если выбирается вариант "Показывать если", то становятся доступными опции настройки условий видимости:

·Уровень доступа - минимальный уровень пользователя, которым должен обладать оператор для отображения элемента.

·Пользователь - имя пользователя, под которым должен быть выполнен вход в систему для отображения элемента.

·Логический контроль - логическое условие, состояние бита, значение в регистре и т.п, которое должно выполняться для отображения элемента.


Добавить элемент "Switch/Indicator"

ONI

Моделирование в симуляторе

Для первоначальной отладки проекта без использования реального оборудования в состав программы ONI Visual Studio включен симулятор. Он позволяет выполнить созданный проект, проверить функционал и наличие ошибок графического интерфейса.

Чтобы запустить симулятор перейдите в меню "Инструменты" и выберите пункт "Моделирование в симуляторе", либо нажмите "F5". Откроется меню загрузки с опциями предварительной очистки памяти.

Моделирование в симуляторе

Отметьте необходимое и нажмите "ОК" для продолжения, запустится симулятор. Нажатия сенсорной панели имитируются курсором и нажатием левой клавиши мыши, в остальном логика работы аналогична реальному оборудованию.

Моделирование в симуляторе


Создание архива проекта

ONI

Создание архива проекта

В некоторых случаях требуется сохранить HMI проект в виде архива, например, для передачи конечному заказчику в качестве резервной копии. При этом если в настройках проекта активна опция защиты от декомпиляции, разархивировать проект и получить исходный будет невозможно без заданного пароля.

Для создания архива выберите пункт меню "Инструменты > Архивировать на диск" или соответствующий значок на панели инструментов.

Укажите путь сохранения архива и нажмите "ОК" для запуска процесса и дождитесь сообщения об успешном завершении.

Примечание

Архивированный проект можно загрузить в панель без использования программы ONI Visual Studio. Для этого достаточно поместить архив на карту памяти (SD или USB) и запустить процесс загрузки проекта из системного меню панели. При этом карта памяти с архивом, должна быть установлена в соответствующий слот панели.


Извлечение проекта из архива

ONI

Извлечение проекта из архива

Извлечь исходный проект из архива возможно только в том случае, если известен пароль защиты от декомпиляции или она не была активирована.

Для извлечения проекта из архива выберите пункт меню "Инструменты > Декомпилировать" или соответствующий значок на панели инструментов. Запустится программа-загрузчик, внешний вид рабочего окна которой представлен на рисунке ниже.

В настройках необходимо указать расположение файла с архивом, место сохранения распакованного проекта, затем нажать кнопку "Декомпилировать" для начала процесса распаковки. Если проект защищен паролем, то будет выведено дополнительное окно для его ввода.

Введите пароль, затем нажмите "ОК" и дождитесь сообщения об успешном завершении процесса.


Загрузка данных в панель

ONI

Загрузка данных в панель

Для загрузки данных в панель выберите в меню пункт "Инструменты > Загрузить" или соответствующий значок на панели инструментов. Запустится программа-загрузчик, внешний вид рабочего окна которой представлен на рисунке.

Перед началом передачи данных, необходимо выполнить настройки подключения, выбрать тип и источник данных, а также отметить желаемые опции при необходимости.

1.Выберите способ подключения к панели посредством USB или Ethernet. Если выбрано подключение с использованием Ethernet, в данном поле необходимо также указать IP-адрес панели оператора.

2.Тип и путь-источник данных для загрузки.

·Проект - текущий проект

·Архив проекта - проект сохраненный ранее в виде архива

·Данные RW - данные энергонезависимой памяти панели

·Рецепты - данные рецептов

3.Опции очистки внутренней памяти панели при загрузке новых данных.

4.Дополнительные опции загрузки позволяют автоматически закрыть программу-загрузчик по окончании процесса загрузки данных или выполнить принудительную загрузку данных в независимости от выполняемого процесса.

5.По окончании настройки, начать процесс загрузки можно нажав кнопку "Загрузить".


Выгрузка данных из панели

ONI

Выгрузка данных из панели

ONI Visual Studio позволяет выгрузить данные из панели оператора для сохранения на ПК, в случае если это не запрещено в настройках загруженного проекта. Для выгрузки данных из панели выберите в меню пункт "Инструменты > Выгрузить" или соответствующий значок панели инструментов. Запустится программа-загрузчик, внешний вид рабочего окна которой представлен на рисунке ниже.

Перед началом передачи данных, необходимо выполнить настройки подключения, выбрать тип данных, а также отметить желаемые опции при необходимости.

1.Способ подключения к панели USB или Ethernet. Если выбрано подключение с использованием Ethernet, в данном поле необходимо указать IP-адрес панели оператора.

2.Тип данных для выгрузки.

·Проект - текущий проект

·История - журнал тревог и событий

·Данные RW - данные энергонезависимой памяти панели

·Рецепты - данные рецептов

·Журналы - журнал действий и событий

3.По окончании настройки, начать процесс выгрузки можно нажав кнопку "Выгрузить".