系统寄存器

地址 | 描述
SRB0 | 网络连接状态 SRB0=0：无连接；SRB0=1：网络连接正常
SRB1 | SRB1=1：立即重新设置IP地址/立即重新获取动态IP地址
SRB3 | SRB3=1：重启系统
SRB4 | SRB4=1：重启并进入BOOT状态（刷机状态）
SRB5 | SRB5=0：点亮背光，SRB5=1：熄灭背光
SRB6 | SRB6=0：无SD卡插入，SRB6=1：SD卡插入
SRB7 | SRB7~9=0：U盘未插入，SRB7~9=1：U盘插入，SRB7~9分别对应USB1~3插入的U盘
SRB10 | SRB10=0：功能键输入小写字符，SRB10=1功能键输入对应的大写字符
SRB11 | SRB11=0：USB下载线未连接，SRB11=1：USB下载线已经连接
SRB12 | SRB12=1：允许使用鼠标 SRB12=0：禁用鼠标
SRB13 | SRB13=0：字母键盘显示字母，SRB13=1字母键盘显示数字和符号
SRB14 | SRB14=0：使用英文输入，SRB14=1：使用拼音输入
SRB15 | SRB15=1：强制关闭报警蜂鸣声
SRB16 | 当触控按下时，SRB16置ON，同时触控位置的X，Y坐标值显示在SRW450和SRW451中
SRB17 | SRB17置ON时RW，配方等掉电保持数据会立即写入。默认为OFF，这时采用缓冲式写入，如果突然掉电，会丢失最近几秒到一分钟不等的数据
SRB18 | SRB18置1时系统会安全弹出SD卡，若要重新使用SD卡，请重新插拔SD卡或重启HMI。可以使用SRB6来查看SD卡是否已弹出
SRB19 | SRB19置1时系统会安全弹出U盘，若要重新使用U盘，请重新插拔U盘或重启HMI。可以使用SRB7来查看U盘是否已弹出
SRB20 | 改变COM1通讯方式设置之后，将此位置1会立即应用改变。不置位此位，就只有重启动后生效。
SRB21 | 改变COM2通讯方式设置之后，将此位置1会立即应用改变。不置位此位，就只有重启动后生效。
SRB22 | 改变COM3通讯方式设置之后，将此位置1会立即应用改变。不置位此位，就只有重启动后生效。
SRB23 | 改变COM4通讯方式设置之后，将此位置1会立即应用改变。不置位此位，就只有重启动后生效。
SRB30 | SRB30=1：用户权限登录
SRB31 | SRB31=1：用户权限注销
SRB32 | SRB32=1：增加用户权限
SRB33 | SRB33=1：删除用户权限
SRB34 | SRB34=1：修改当前用户的权限密码
SRB50 | 盒子输入IO点X0的变化会反映到这个值
SRB51 | 盒子输入IO点X1的变化会反映到这个值
SRB52 | 改变寄存器SRB52的值，将改变盒子Y0点的输出状态
SRB53 | 改变寄存器SRB53的值，将改变盒子Y1点的输出状态
SRB70 | SRB70=1:确认全部当前报警事件
SRB71 | SRB71=1:确认全部历史报警事件
SRB72 | SRB72=1:清除已确认的当前事件
SRB10000 | 掉电保持寄存器，SRB10000=0：自动获取IP地址(DHCP)；SRB10000=1：静态分配IP地址
SRB10010 | SRB10010=0：蜂鸣器使能，SRB10010=1：禁用蜂鸣器
SRB10011 | SRB10011=0：正常播放声音，SRB10011=1：静音
SRB10012 | SRB10012=0：启用五指抓屏返回主窗口烁，SRB10012=1：禁用五指抓屏返回主窗口
SRB10013 | SRB10013=0：允许修改系统时间 SRB10013=1：禁止修改系统时间
SRB10014 | SRB10014=1：键盘焦点左右移动按像素移动 SRB10014=0：键盘焦点左右移动按元件添加顺序移动
SRB10020 | SRB10020=0：禁用VNC, SRB10020=1：启用VNC；SRB10020=0：禁用VNC SRB10020=1：启用VNC；掉电保存
SRB10021 | SRB10021=0：远程VNC可控制界面； SRB10021=1：远程VNC为只显示，不能控制；掉电保存
SRB10031 | SRB10031=1 : 启动时不显示loading字符串,SRB10031=0 : 启动时显示loading字符串
SRW0 | 系统日期：年，格式为20xx
SRW1 | 系统日期：月
SRW2 | 系统日期：日
SRW3 | 系统时间：时
SRW4 | 系统时间：分
SRW5 | 系统时间：秒
SRW6 | 系统时间：毫秒
SRW7 | 系统日期：星期
SRW10 | HMI MAC地址，SRW10~15，每个WORD的低地址表示一个MAC段。只读，不可改写。
SRW20 | 产品型号ID，SRW20~21，产品型号的ID编号
SRW24 | 出厂日期，SRW24~26，产品出厂日期，依次对应：年：月：日
SRW27 | HMI当前色深，16-16位色，24-24位色，只读
SRW30 | 软件版本号，SRW30~36，依次为Boot,Kernel,Rootfs,Floader,Fgui,Fcs,Fds
SRW40 | 产品硬件序列号，SRW40~45，共96个位，全球唯一
SRW50 | 用于安全设置中的操作确认：1-确认执行操作，2-取消操作
SRW60 | 通讯信息代码，通讯超时，错误等，占用一个字寄存器
SRW61 | 通讯信息所在的设备号
SRW62 | 通讯信息所在的端口号
SRW63 | 通讯信息所在的PLC站号
SRW64 | 设置通讯超时或错误的弹出时间，单位秒（0表示默认3秒）
SRW70 | 系统信息代码：1：输入超限；2：正在处理；3：操作成功；4：数据传输越界；5：内存不足；6：宏执行错误；7：密码输入错误；8：连接服务器失败；9：操作失败；10：当前用户权限不符； 11：注销成功；12：用户重复登录；13：未检测到SD卡；14：未检测到U盘；115：未检测到U盘；216：数据库升级中，请稍后；17：正在查询中，请稍后；18：打印失败；19：打印忙；20：准备报表打印； 24：HMI剩余空间不足3M；25：SD卡剩余空间不足3M；26：USB1剩余空间不足3M；27：USB2剩余空间不足3M；128：操作成功；137：文件不存在；138：文件类型错误； 139：操作失败；140：文件已存在；141：用户密码错误；142：屏上内存不足；143：SD卡、U盘内存不足。
SRW76 | SRW76~77：双字类型，显示HMI磁盘的最大空间（单位字节）
SRW78 | SRW78~79：双字类型，显示HMI磁盘的已使用空间（单位字节
SRW80 | SRW80~81：双字类型，显示当前系统占用的RAM内存量
SRW84 | SRW84~85：双字类型，显示系统可用RAM内存量的上限值
SRW88 | 显示系统循环扫描的时间间隔（单位毫秒）
SRW100 | 输入用户登记密码供验证。占用SRW100~103，共4个字，请使用文本输入元件读取或显示密码值
SRW104 | 只读寄存器，显示当前基本窗口的密码等级。SRW104，占用1个字
SRW105 | 强制修改当前密码等级,注意只能由高等级切换到低等级。SRW105，占用1个字
SRW120 | SRW120~135;COM1所连接设备按站号通讯状态，占用16个字，每个字16个位，对应了站号0~255。例如SRW120的Bit3为1就代表串口所连接的站号3的设备通讯错误。
SRW140 | SRW140~155;COM2所连接设备按站号通讯状态，占用16个字，每个字16个位，对应了站号0~255。例如SRW140的Bit3为1就代表串口所连接的站号3的设备通讯错误。
SRW160 | SRW160~175;COM3所连接设备按站号通讯状态，占用16个字，每个字16个位，对应了站号0~255。例如SRW160的Bit3为1就代表串口所连接的站号3的设备通讯错误。
SRW180 | SRW180~195;COM4所连接设备按站号通讯状态，占用16个字，每个字16个位，对应了站号0~255。例如SRW180的Bit3为1就代表串口所连接的站号3的设备通讯错误。
SRW200 | SRW200~215，共16个字，一般用字符显示元件，当弹出键盘时，显示字符的输入过程
SRW220 | SRW220~235，共16个字，一般用字符显示元件，显示当前数值输入元件输入范围的最大值
SRW240 | SRW240~255，共16个字，一般用字符显示元件，显示当前数值输入元件输入范围的最小值
SRW260 | SRW260~275，共16个字，一般用字符显示元件，显示当前数值输入进入输入状态前的历史值
SRW280 | 输入键盘控制字，目前仅SRW280.0有效，SRW280.0为ON表示备选字窗口坐标(SRW281,SRW282)生效， SRW280.0为OFF表示备选字窗口坐标固定在页面坐标(0,0)。
SRW281 | 单字，输入法备选字窗口X坐标，相对于键盘窗口
SRW282 | 单字，输入法备选字窗口Y坐标，相对于键盘窗口
SRW300 | SRW300~349，共50个字，一般用字符元件，显示文件浏览元件当前选中的绝对路径字符串
SRW350 | SRW350~389，共40个字，一般用字符元件，显示或输入文件浏览元件的文件名，不包括路径
SRW390 | SRW390，文件 浏览元件确认后执行的操作： 0-取消或无操作； 1-导入工程到HMI； 2-从HMI导出到SD卡或U盘； 3-导入配方到HMI； 4-导出配方到SD卡或U盘； 5-其它文件操作
SRW391 | 导入工程到HMI之前做的清理操作： BIT0：清除RW, BIT1：清除配方 BIT2：清除数据采样记录和报警事件历史记录 BIT3：清除特殊寄存器值
SRW392 | 导入导出的操作结果： 9：文件不存在 10：文件类型错误 11：操作失败 12：文件已存在 13：用户密码错误 14：HMI存储空间不足 15：外置存储空间不足
SRW394 | 用户上传密码存储，占4个字，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。 占用SRW394~397，共4个字，请使用ASCII元件读取或显示密码值
SRW400 | 用户权限用户名字串，占用16个字，可以输入16个汉字或32个英文、数字字符
SRW416 | 用户权限设置密码，占用4个字，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。使用ASCII方式输入，请使用文本输入元件操作
SRW420 | 双字，显示当前用户权限，每个位对应一个BIT，BIT0对应权限1，BIT1对应权限2...
SRW422 | 双字，设置新增用户权限，每个位对应一个BIT，BIT0对应权限1，BIT1对应权限2...
SRW424 | 设置新增用户的自动注销时间（单位是分钟），占2个字
SRW426 | 设置新增用户的新密码或修改密码的新密码，占4个字，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。使用ASCII方式输入，请使用文本输入元件操作
SRW430 | 设置新增用户或修改密码的确认密码，占4个字
SRW434 | 显示当前登录的用户名，占16个字
SRW450 | SRW450：当触控按下时，SRB16置ON，SRW450为当前触控点的X坐标值
SRW451 | SRW451：当触控按下时，SRB16置ON，SRW451为当前触控点的Y坐标值
SRW456 | 当前按键的键码值，占2个字
SRW460 | 盒子/屏的序列号，占12个字符，共6个字
SRW466 | 盒子/屏的密码，占4个字符，2个字
SRW480 | 系统提示屏蔽位，共16个字。SRW480.x为ON屏蔽SRW70=x对应的提示。 如：SRW480.1屏蔽输入超限，SRW480.F屏蔽未检测到U盘2，SRW481.0屏蔽数据库升级中。
SRW496 | 通讯提示屏蔽位（SRW496.1为ON屏蔽通讯超时的提示， SRW496.2 屏蔽通讯错误的提示）
SRW630 | SRW630~633；网络PLC通讯状态位，4个单字最多表示63个远程PLC的状态，bit值是1表示对应的远程PLC通讯异常，值是0表示对应的远程PLC通讯正常或未使用。 例如：SRW630.1 为1，表示第1个远程PLC通讯异常，SRW630.2 为1，表示第2个远程PLC通讯异常。
SRW640 | SRW640~655,网络PLC通讯状态位,置1表示对应的网络PLC通讯异常，置0表示对应的网络PLC通讯正常或未使用。例如：SRW640.0为1，表示第1个网络PLC通讯异常，SRW640.1 为1，表示第2个网络PLC通讯异常。
SRW1020 | 盒子在线状态，1：盒子在线，0：盒子离线
SRW1021 | 盒子联网类型，1：以太网，2：GPRS，4：WIFI，5：4G
SRW1022 | 盒子无限信号强度：0最小，8最大
SRW1000 | SRW1000~1001，双字（单位百毫秒）。GUI正常运行开始每百毫秒累加1，GUI重启清零。
SRW10010 | HMI IP地址设置，掉电保持，SRW10010~13，每个WORD表示一个IP段。静态时可读写，动态时只读。
SRW10014 | HMI子网掩码设置，掉电保持，SRW10014~17，每个WORD表示一个IP段，静态时可读写，动态时只读。
SRW10018 | HMI网关设置，掉电保持，SRW10018~21，每个WORD表示一个IP段，静态时可读写，动态时只读。
SRW10022 | DNS1设置，掉电保持，SRW10022~25，每个WORD表示一个IP段，静态时可读写，动态时只读。
SRW10026 | DNS2设置，掉电保持，备用DNS，SRW10026~29，每个WORD表示一个IP段，静态时可读写，动态时只读。
SRW10040 | 屏保时间，SRW10040，产品经过一段时间无操作，跳转屏保画面，掉电保存
SRW10041 | 关闭背光时间，SRW10041，产品经过一段时间无操作，自动关闭背光，掉电保存
SRW10042 | 调低亮度时间，SRW10042，产品经过一段时间无操作，调低亮度，掉电保存
SRW10050 | 修改当前语种号，SRW10050，掉电保存。 0表示使用语种1, 1表示使用语种2, 以此类推
SRW10051 | SRW10051，旋转显示，掉电保存。 0：正常 1：90度垂直 2：270度垂直 3：颠倒 注意：不能自适应调整，旋转前需要调整窗口的宽高。
SRW10052 | 设定当前亮度百分比值1~100，SRW10052，掉电保存。
SRW10053 | 设定当前音量百分比值1~100，SRW10053，掉电保存。
SRW10080 | 设定宏指令最大执行时间，单位百毫秒，0-无限制，1-宏指令执行时间（不包括读写寄存器的通讯时间）超过100mS，强行终止宏指令。默认值为10即1S，掉电保存。
SRW10082 | 单字，拼音输入法的字号设置，12~32号。掉电保存
SRW10110 | 用户等级1级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10110~113，共4个字，请使用ASCII元件读取或显示密码值
SRW10114 | 用户等级2级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10114~117，共4个字，请使用ASCII元件读取或显示密码值
SRW10118 | 用户等级3级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10118~121，共4个字，请使用ASCII元件读取或显示密码值
SRW10122 | 用户等级4级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10122~125，共4个字，请使用ASCII元件读取或显示密码值
SRW10126 | 用户等级5级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10126~129，共4个字，请使用ASCII元件读取或显示密码值
SRW10130 | 用户等级6级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10130~133，共4个字，请使用ASCII元件读取或显示密码值
SRW10134 | 用户等级7级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10134~137，共4个字，请使用ASCII元件读取或显示密码值
SRW10138 | 用户等级8级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10138~141，共4个字，请使用ASCII元件读取或显示密码值
SRW10142 | 用户等级9级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10142~145，共4个字，请使用ASCII元件读取或显示密码值
SRW10146 | 用户等级10级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10146~149，共4个字，请使用ASCII元件读取或显示密码值
SRW10150 | 用户等级11级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10150~153，共4个字，请使用ASCII元件读取或显示密码值
SRW10154 | 用户等级12级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10154~157，共4个字，请使用ASCII元件读取或显示密码值
SRW10158 | 用户等级13级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10158~161，共4个字，请使用ASCII元件读取或显示密码值
SRW10162 | 用户等级14级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10162~165，共4个字，请使用ASCII元件读取或显示密码值
SRW10166 | 用户等级15级密码，密码可以为0~9任意组合，最大支持8个数字。注意，例如0123和00123是不同的密码。占用SRW10166~169，共4个字，请使用ASCII元件读取或显示密码值
SRW10180 | VNC操控密码，密码验证后具有操控权限，可远程操控。不使用密码，设置为空
SRW10184 | VNC监视密码，密码验证后具有监视权限，只能监视，不能操控。不使用密码，设置为空
SRW10200 | SRW10200~201;COM1通讯波特率设置，占用一个双字（32位无符号数）表示：取值范围：110~187500。掉电保存，重启生效。
SRW10202 | SRW10202;COM1通讯数据位，占用一个字（16位无符号数）表示：8 - 8数据位，7 - 7数据位，掉电保存，重启生效。
SRW10203 | SRW10203;COM1通讯停止位，占用一个字（16位无符号数）表示：1 - 1停止位，2 - 2停止位，掉电保存，重启生效。
SRW10204 | SRW10204;COM1通讯校验位，占用一个字（16位无符号数）表示：0--无校验，1--奇校验，2--偶校验，掉电保存，重启生效。
SRW10205 | SRW10205;COM1通讯方式，占用一个字（16位无符号数）表示：0-232,1-485-4w,2-485-2w，掉电保存，重启生效。
SRW10210 | SRW10210~225;COM1所连接设备按站号屏蔽通讯，占用16个字，每个字16个位，对应了站号0~255。例如SRW10211的Bit3置1就代表串口所连接的站号19的设备屏蔽，不再通讯。 相关元件数据不再刷新。配置掉电保存，立即生效。
SRW10250 | SRW10250~251;COM2通讯波特率设置，占用一个双字（32位无符号数）表示：取值范围：110~187500。掉电保存，重启生效。
SRW10252 | SRW10252;COM2通讯数据位，占用一个字（16位无符号数）表示：8 - 8数据位，7 - 7数据位，掉电保存，重启生效。
SRW10253 | SRW10253;COM2通讯停止位，占用一个字（16位无符号数）表示：1 - 1停止位，2 - 2停止位，掉电保存，重启生效。
SRW10254 | SRW10254;COM2通讯校验位，占用一个字（16位无符号数）表示：0--无校验，1--奇校验，2--偶校验，掉电保存，重启生效。
SRW10255 | SRW10255;COM2通讯方式，占用一个字（16位无符号数）表示：0-232,1-485-4w,2-485-2w，掉电保存，重启生效。
SRW10260 | SRW10260~275;COM2所连接设备按站号屏蔽通讯，占用16个字，每个字16个位，对应了站号0~255。 例如SRW10251的Bit3置1就代表串口所连接的站号19的设备屏蔽，不再通讯。相关元件数据不再刷新。配置掉电保存，立即生效。
SRW10300 | SRW10300~301;COM1通讯波特率设置，占用一个双字（32位无符号数）表示：取值范围：110~187500。掉电保存，重启生效。
SRW10302 | SRW10302;COM3通讯数据位，占用一个字（16位无符号数）表示：8 - 8数据位，7 - 7数据位，掉电保存，重启生效。
SRW10303 | SRW10303;COM3通讯停止位，占用一个字（16位无符号数）表示：1 - 1停止位，2 - 2停止位，掉电保存，重启生效。
SRW10304 | SRW10304;COM3通讯校验位，占用一个字（16位无符号数）表示：0--无校验，1--奇校验，2--偶校验，掉电保存，重启生效。
SRW10305 | SRW10305;COM3通讯方式，占用一个字（16位无符号数）表示：0-232,1-485-4w,2-485-2w，掉电保存，重启生效。
SRW10310 | SRW10310~325;COM3所连接设备按站号屏蔽通讯，占用16个字，每个字16个位，对应了站号0~255。 例如SRW10311的Bit3置1就代表串口所连接的站号19的设备屏蔽，不再通讯。相关元件数据不再刷新。配置掉电保存，立即生效。
SRW10350 | SRW10350~351;COM4通讯波特率设置，占用一个双字（32位无符号数）表示：取值范围：110~187500。掉电保存，重启生效。
SRW10352 | SRW10352;COM4通讯数据位，占用一个字（16位无符号数）表示：8 - 8数据位，7 - 7数据位，掉电保存，重启生效。
SRW10353 | SRW10353;COM4通讯停止位，占用一个字（16位无符号数）表示：1 - 1停止位，2 - 2停止位，掉电保存，重启生效。
SRW10354 | SRW10354;COM4通讯校验位，占用一个字（16位无符号数）表示：0--无校验，1--奇校验，2--偶校验，掉电保存，重启生效。
SRW10355 | SRW10355;COM4通讯方式，占用一个字（16位无符号数）表示：0-232,1-485-4w,2-485-2w，掉电保存，重启生效。
SRW10360 | SRW10360~375;COM4所连接设备按站号屏蔽通讯，占用16个字，每个字16个位，对应了站号0~255。 例如SRW10361的Bit3置1就代表串口所连接的站号19的设备屏蔽，不再通讯。相关元件数据不再刷新。配置掉电保存，立即生效。
SRW10500 | SRW10500~10515；网络PLC通讯屏蔽位，此屏蔽位是针对IP的，若同一个IP上同时连接多个PLC，则这些PLC的通讯都被屏蔽。 例如：SRW10500.0 置1屏蔽第一个网络PLC对应IP的通讯，SRW10500.1 置1屏蔽第二个网络PLC对应IP的通讯。
SRW10590 | SRW10590~10593；远程PLC通讯屏蔽位，用于设置远程PLC通讯是否屏蔽，4个单字最多屏蔽63个远程PLC，对应位置1表示屏蔽该远程PLC。 例如：SRW10590.1 置1，屏蔽所添加的第1个远程PLC，SRW10590.2 置1，屏蔽所添加的第2个远程PLC。 注意：SRW10590.0 无效
SRW10600 | SRW10600~10601，用户账户禁用位，用于设置用户账户是否禁用，2个单字最多禁用前面32个用户账户，对应位设置1表示禁用。 例如：SRW10600.0 置1，禁用账户1，SRW10600.1 置0，不禁用账户2。
SRW10610 | SRW10610~10641，用户登陆失败计数，共32个字，每个字表示1个账户的登陆失败次数。 例如：SRW10610 表示账户1登陆失败次数，SRW10641 表示账户32登陆失败次数。


自动恢复

用户在编辑组态时，出现异常，软件会自动备份工程，用户可以查看并使用备份工程。

设置菜单/选项下，用户可以修改“保存自动恢复信息的时间间隔”，点击“查看备份工程”，直接进入备份工程目录。

保存自动恢复信息的时间间隔：工程打开为起始时间，如下图所示，每隔1分钟，会检测工程是否改动过，如果改动过，系统会自动备份工程。


新建工程

快捷图标：

快捷键： <Ctrl>+<N>此命令创建一个新的工程

请点击下图设置参数了解详细信息

HMI属性/COM1/COM2/COM3/COM4

远程HMI/远程PLC/网络PLC

以上，确定前，可以点击上一步、下一步，重新设置，还可以通过，左边的树形条目，双击后直接进入相应内容进行设置，当点击确定后，新建工程完成，用户开始编辑组态画面


软件布局

新建工程后，将看到软件的编辑窗口，此为默认布局

PS:软件的布局如需恢复到默认状态，可以通过菜单栏的视图—恢复默认布局，进行重置

  • 菜单：

软件的所有功能在菜单里都能查询到，点击各个菜单名选择子功能

  • 浮动导航栏：

PS：一共有8组导航栏，此图为第一组

通过鼠标点击可移动导航栏的位置，当鼠标接触导航上的图标可查看图标说明

  • 浮动导航窗口：软件的左右边上均为浮动导航窗口，默认左边为隐藏，右边为固定展示

PS：可将浮动显示改为固定显示只需点击，即可，见下图：

  • 错误与输出：输出编译信息，如有错误，将在错误里提示


通讯连接

制造商 | 设备类型 （COM） | 制造商 | 设备类型（网络PLC）
繁易 | Flexem FL2N 、FLEXEM Modbus |  | FLEXEM HMI
AB | AB DF1、AB Micro850_CIPTAG（标签地址） |  | AB CompactLogix_EthIP、 AB EthernetIPSlave、 AB Micro850_EthTAG（标签地址）
ABB | ABB AC500_RTU |  | ABB AC500_TCP
MODBUS兼容设备 | Modbus RTU、Modbus ASCII 、 Modbus RTU Extend | MODBUS网络兼容设备 | Modbus TCP、Modbus UDP
西门子 | Siemens S7-200、 Siemens S7-300 MPI、 Siemens S7-300_PCAdapter 、 Siemens S7-200_PPI-M | 西门子网络设备 | Siemens S7-200 Network、 Siemens S7-200 Network Module、 Siemens S7-300 Network、 Siemens S7-1200 Network
松下 | Panasonic FP0、 Panasonic FPX、panasonic MINAS A5 |  |
三菱 | Mitsubishi FX0-FX1-FX2、 Mitsubishi FX2N、 Mitsubishi FX3U_FX3G、 Mitsubishi FX232-485BD、 Mitsubishi Melsec-Q、 Mitsubishi Q00J(CPU Port)、 Mitsubishi Q02 | 三菱网络设备 | Mitsubishi FX3U-ENET-ADP_MC_BIN、 Mitsubishi FX3U-ENET-L_Eth、 Mitsubishi_FX5U_Ethernet、 Mitsubishi MelsecR_EthBin、 Mitsubishi Melsec_EthASCII、 Mitsubishi Melsec_EthBin、 Mitsubishi QJ71E71
永宏 | FATEK Series |  | FATEK EthernetTCP
和利时 | HollySys LE(串口)、 HollySys LK_ModbusRTU、 HollySys LM |  | HollySys LE(以太网)、 HollySys LK210_ModbusTCP、 HollySys LK_ModbusTCP
台达 | DELTA AH500、 DELTA DVP、 DELTA DVP_ModbusTCP |  |
科威 | KEWEI LP1-EP-EC |  |
步科 | Kinco K3 、 Kinco K5、 Kinco SV100_Modbus、 Kinco Servo |  |
禾川 | HCFA HCA1-HCA2-LX1N-LX1S、HCFA HCA4 HCFA HCA8 、HCFA SV-X3_485-2W |  |
安川 | Yaskawa MP-SeriesSIO(Extension) 、 Yaskawa Sigma-5_MEMOBUS | 安川网络设备 | Yaskawa UDP Slave
欧姆龙 | OMRON CJ-CS、 OMRON CP1H_CP1L |  | OMRON CJ_CS_NJ Series EtherNet (UDPSlave)
汇川 | Inovance AM600_Serial 、 Inovance_H2u、 Inovance H3u |  | Inovance AM600_Ethernet、 Inovance H3u_Ethernet
麦格米特 | MEGMEET M280、 MEGMEET MCSeries_Port0、 MEGMEET MC Series、 MEGMEET SV-Master |  | MEGMEET U600
麦科 | MIKOM MX1H |  |
基恩士 | KEYENCE KV-1000-3000_Bin、 KEYENCE KV-1000_ASCII 、 KEYENCE KV-Series-nano_ASCI、 KEYENCE KV-Series_ASCII |  | KV5500_Ethernet、 KV7500_Ethernet
翠欧 | TRIO Serial、 TRIO Modbus、TRIO ModbusExtend |  |
日立 | EHV-CPU_APPLICATION |  |
LS | LS Master-K Cnet、 LS Master-K_Serial、 LS XEC Cnet、 LS XEC_Fenet、 LS XGB-XBCU_Fenet、 LS XGB_Cnet、 LS XGB_Fenet、 LS_XGT_Serial |  |
信捷 | THINGET Controller、THINGET XD3 Controller |  |
横河 | Yokogawa FA-M3 |  | Yokogawa FA-M3_Ethernet 、 Yokogawa FA-M3_UDP
海为 | Haiwell |  |
艾克威尔 | ANCHORWILL ModbusRTU |  |
安科瑞 | ANModbus RTU |  |
BACNET | FlexemBACnet(标签地址) |  |
德联 | Delian Boiler |  |
英维克 | Envicool EC |  |
GE | GE SNP-X |  | GE RX3i_SRTP
经纬 | Ginwave modbus |  |
GPS | GPS GPS_NMEA |  |
亿图 | HUST CNC_H6D HUST CNC_HalfDuplex |  |
和泉 | IDEC MicroSmart 、 IDEC Smart |  |
津职达 | JZD-300X 、 JZD-DL JZD-IO-1616 |  |
科创力源 | KCLY Modbus |  |
光洋 | Koyo SH-SH1-SH2 |  |
麦卓 | Metronix |  |
英威腾 | invt IVC_Serial |  |
赛亚 | Saia SBus |  |
施耐德 | Schneider-TM218、Schneider IMS SERVO |  |
TCL | TCL ModbusRTU |  |
东元 | TP03 Series |  |
东微智能 | TENDZONE CentralController |  |
天津成科 | tjck |  |
派克 | parker ACR9000_Serial |  |
兰普锋 | Runpower |  |
欧时 | OE MAX NX7、RS X8Series_Serial |  | RS X8Series_Ethernet
理化工业 | RKC CH402 |  |
南京牢固 | RIEVTECH FBD_Serial 、RIEVTECH LAD_Serial |  | RIEVTECH FBD_ETH 、RIEVTECH LAD_ETH
ONI | ONI PLR-S |  |
迈特 | MYITER EC_Series_Modbus |  |
默川 | MOCHUAN MU1H |  |
丰炜 | VIGOR VH、VIGOR VS |  |
VIPA | VIPA MPI |  |
串口服务 | Modbus RTU Server | 以太网服务 | Modbus TCP Server

HMI 串行通讯引脚定义

COM1/COM3（male） | 管脚 | RS232 |  | RS485-2 COM1/COM2 | RS485-4 COM1/COM2
COM2/COM4（male）或485端子（见HMI背面说明） |  | COM3/COM4 | COM1/COM2
 | 1 |  |  | RX-（B） | RX-（B）
 | 2 |  | RXD |  |
 | 3 |  | TXD |  |
 | 4 |  |  |  | TX-
 | 5 | GND | GND |  |
 | 6 |  |  | RX+（A） | RX+（A）
 | 7 | RXD |  |  |
 | 8 | TXD |  |  |
 | 9 |  |  |  | TX+


繁易

1.繁易 FLEXEM FL2N(MISTUBISHI FX2N COMPATIBLE)

>Flexem FL2N 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>FLEXEM FL2N 系列RS485电缆

>FLEXEM FL2N 系列设备类型

>FLEXEM FL2N 系列HMI设置

>FLEXEM FL2N 系列PLC设置

2.繁易 FLEXEM Modbus

>FLEXEM Modbus 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>FLEXEM Modbus 系列 RS485电缆

>FLEXEM Modbus 系列设备类型

>FLEXEM Modbus 系列HMI设置

>FLEXEM Modbus 系列PLC设置

请参考相关文档

3.繁易 FLEXEM HMI

>FLEXEM HMI 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>FLEXEM HMI 系列设备类型

>FLEXEM HMI 系列HMI设置

>FLEXEM HMI 系列PLC设置

请参考相关文档


AB

1.AB DF1

> AB DF1系列RS232电缆

使用AB公司生产的串口通讯电缆1761-CBL-PM02(AB编程口的8针圆头非标准）

接线图（以下图表示从连接线的接线端所视）

>AB DF1系列RS232电缆

通讯模块AIC+（部件号1761-NET-AIC） SLC5/03 RS232通讯电缆

接线图（以下图表示从连接线的接线端所视）

>AB DF1系列设备类型

注意： I/O地址格式为：I/O e.s/b 其中e为槽号，s为元素号，b为位号 举例：PLC中地址为O0 0.0/11，则HMI上地址应设置为O0 0.11；O0 0.1/8，在HMI上地址则应设置为O0 1.8； 不同CPU类型的AB使用输入输出模块时，I和O点的地址在HMI上都是连续排列的。 以Micrologix1400+输出模块1762-OW16为例，O0 1.0/3对应HMI上地址O0 6.3

>AB DF1系列HMI设置

>AB DF1系列PLC设置

RSLogix500软件设置如下

2.AB CompactLogix_EthIP

>AB CompactLogix_EthIP 系列接线图

接线图（以下图表示从连接线的接线端所视）

>AB CompactLogix_EthIP系列设备类型

>AB CompactLogix_EthIP系列HMI设置

>AB CompactLogix_EthIP系列PLC设置

RSLogix5000软件设置如下：

（1）定义标签并设置数据类型：在[Conrtoller Tags]上点击鼠标右键菜单后，选择[New Tag]建立标签；

注意： 1.HMI要访问的控制器内部寄存器，都需先在RSLogix5000软件中定义。 2.Controller Tags适用于控制器内全部例程，对控制器而言，这些标签是全局的，因此需在Controller Tags中建立标签。

（2）标签名（Name）与文件号（File Number）映射：选择[Logic]→[Map PLC/SLC Messages]:（注：软件状态需为离线状态）

设置举例： 1.新建一个Name为a的标签，Data Type为INT：

注意：修改Data Type数据类型，目前协议不支持多维数组，所以只能定义Dim0范围

2.另外又新建Name为b和c的两个标签，Data Type分别为REAL和BOOL：

3.定义完标签后，还要映射标签名（Name）到文件号（File Number）

注意：文件号具有唯一性，同一个文件号（File Number）不能映射给不同的标签名（Name）

3.AB EthernetIPSlave

>AB EthernetIPSlave 系列 接线图

接线图（以下图表示从连接线的接线端所视）

>AB EthernetIPSlave系列设备类型

注意： I/O地址格式为：I/O e.s/b 其中e为槽号，s为元素号，b为位号 举例：PLC中地址为O0 0.0/11，则HMI上地址应设置为O0 0.11；O0 0.1/8，在HMI上地址则应设置为O0 1.8； 不同CPU类型的AB使用输入输出模块时，I和O点的地址在HMI上都是连续排列的。以Micrologix1400+输出模块1762-OW16为例，O0 1.0/3对应HMI上地址O0 6.3

>AB EthernetIPSlave系列HMI设置

>AB EthernetIPSlave系列PLC设置

4.AB Micro850_CIPTAG（标签地址）

>AB Micro850_CIPTAG（标签地址）系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>AB Micro850_CIPTAG（标签地址）系列设备类型

地址标签，HMI在设备标签库里进行设置，名称及数据类型与PLC定义保持一致

>AB Micro850_CIPTAG（标签地址）系列HMI设置

>AB Micro850_CIPTAG（标签地址）系列PLC设置

RSLogix5000软件设置如下： （1）设置通讯参数：Controller Properties

（2）定义标签并设置数据类型：在[Conrtoller Tags]上点击鼠标右键菜单后，选择[New Tag]建立标签：

注意： 1.HMI要访问的控制器内部寄存器，都需先在RSLogix5000软件中定义。 2.Controller Tags适用于控制器内全部例程，对控制器而言，这些标签是全局的，因此需在Controller Tags中建立标签。

（3）标签名（Name）与文件号（File Number）映射：选择[Logic]→[Map PLC/SLC Messages]:（注：软件状态需为离线状态）

设置举例： 1.新建一个Name为a的标签，Data Type为INT：

注意：修改Data Type数据类型，目前协议不支持多维数组，所以只能定义Dim0范围 2.另外又新建Name为b和c的两个标签，Data Type分别为REAL和BOOL：

5.AB Micro850_EthTAG（标签地址）

>AB Micro850_EthTAG（标签地址）系列接线图

接线图（以下图表示从连接线的接线端所视）

>AB Micro850_EthTAG（标签地址）系列设备类型

地址标签，HMI在设备标签库里进行设置，名称及数据类型与PLC定义保持一致

>AB Micro850_EthTAG（标签地址）系列HMI设置

>AB Micro850_EthTAG（标签地址）系列PLC设置

RSLogix5000软件设置如下： （1）定义标签并设置数据类型：在[Conrtoller Tags]上点击鼠标右键菜单后，选择[New Tag]建立标签：

注意： 1.HMI要访问的控制器内部寄存器，都需先在RSLogix5000软件中定义。 2.Controller Tags适用于控制器内全部例程，对控制器而言，这些标签是全局的，因此需在Controller Tags中建立标签。

（2）标签名（Name）与文件号（File Number）映射：选择[Logic]→[Map PLC/SLC Messages]:（注：软件状态需为离线状态）

设置举例： 1.新建一个Name为a的标签，Data Type为INT：

注意：修改Data Type数据类型，目前协议不支持多维数组，所以只能定义Dim0范围

2.另外又新建Name为b和c的两个标签，Data Type分别为REAL和BOOL：


ABB

1.ABB AC500_RTU

>ABB AC500_RTU 系列 RS232 电缆(PORT1)

接线图（以下图表示从连接线的接线端所视）

>ABB AC500_RTU 系列 RS232 电缆(PORT2)

接线图（以下图表示从连接线的接线端所视）

>ABB AC500_RTU 系列 RS485 电缆

接线图（以下图表示从连接线的接线端所视）

>ABB AC500_RTU 系列支持的寄存器：

>ABB AC500_RTU 系列HMI设置

>ABB AC500_RTU 系列PLC设置

注意:1.在ABB AC500 PLC上位机软件串口设置中，需选择MODBUS； 2.假设选择COM1 MODBUS之后，串口通信参数设置需要注意第15项“Operation mode”设置成“SLAVE”，其他设置与HMI一致

2.ABB AC500_TCP

>ABB AC500_TCP 系列电缆接线图

>ABB AC500_TCP 系列支持的寄存器：

>ABB AC500_TCP 系列HMI设置

>ABB AC500_TCP 系列PLC设置

IP设置可通过control builder plus 软件或者是通过面板设置，具体可参考ABB软件帮助


MODBUS兼容设备

1.接线图

1.1Modbus RTU/Modbus ASCII/Modbus RTU Extend系列RS232电缆（以下图表示从连接线的接线端所视）

1.2Modbus RTU/Modbus ASCII/Modbus RTU Extend系列RS485-2电缆（以下图表示从连接线的接线端所视）

2.支持的寄存器

2.1Modbus ASCII 支持的寄存器：

2.2Modbus RTU 支持的寄存器：

2.3Modbus RTU Extend 支持的寄存器：

举例：Modbus RTUExtend功能码

(其他仅供参考，详见网站 : http://www.modbus.org)

3.HMI设置

备注：PLC通讯步骤，详见PLC相关文档

4.通讯测试

5.modbus 相关驱动通讯间隔说明

>modbus rtu的timeout2（超时时间2），单位是微秒，可设置范围是0~100000微秒，即 0微秒~100毫秒；

>modbus rtu extend的timeout2，单位是毫秒，可设置范围是0~10000毫秒，即 0毫秒~10秒；

>modbus tcp 不支持 timeout2 的设置，只能用时间间隔0~200 毫秒。

>modbus rtu extend 的timeout2 不能设置成 ”3“，3和0的效果一样的。

>其他的驱动，大部分都不支持timeout2的设置，只能使用“时间间隔”填写0~199，，最大200毫秒，如果填写超过199，就会变成跟0一样效果。


MODBUS网络兼容设备

1.Modbus TCP /Modbus UDP系列以太网电缆

2.支持的寄存器

2.1Modbus TCP支持的寄存器:

2.2Modbus UDP支持的寄存器:

3.HMI设置:

备注:PLC通讯步骤详见PLC通讯文档

4.通讯测试:


西门子

1.西门子 S7-200/S7-200_PPI-M

注意：S7-200_PPI-M支持多主

>Siemens S7-200 系列 RS232 电缆

使用 SIEMENS 公司生产的串口编程电缆与 HMI 通讯

>Siemens S7-200 系列 RS485-2 电缆

（以下图表示从连接线的接线端所视）

>Siemens S7-200 支持的寄存器：

>Siemens S7-200_PPI-M 支持的寄存器：

>与Siemens S7-200通讯设置

>STEP 7 MicroWin 设置（和HMI设置保持一致）

\

2.西门子 S7-300 MPI

>Siemens S7-300 MPI 系列 RS232 电缆

使用 SIEMENS 公司生产的串口编程电缆与 HMI 通讯

>Siemens S7-300 MPI 系列 RS485-2 电缆

（以下图表示从连接线的接线端所视）

>Siemens S7-300 MPI 支持的寄存器：

>与Siemens S7-300通过RS485通讯设置

>Step1：PLC站号可设为1~15

Step2：MPI通讯波特率可设为19.2Kbps或187.5Kbps

Step3：当PLC与4个或4个以上HMI通讯时，需要设置【属性】-【通讯】来更改PG通讯的参数

3.西门子 S7-300_PCAdapter

>Siemens S7-300_PCAdapter 系列 RS232 电缆

>Siemens S7-300_PCAdapter 支持的寄存器：

>HMI设置

>与Siemens S7-300_PCAdapter 通讯设置

>Step1：PLC MPI端的传输速率设置成187.5Kbps

Step2：MPI地址设置为2

Step3：设置完毕后将设好的参数下载到PLC。进入【SIMATIC Manager】菜单/【选项】/【设置PG/PC接口】，选择PC Adapter（MPI），将MPI端的传输速率改成187.5kbps。


西门子网络设备

1.Siemens S7-200 Network/Siemens S7-200 Network Module/Siemens S7-300 Network /Siemens S7-1200 Network 电缆

2.支持的寄存器

2.1Siemens S7-200 Network 支持的寄存器：

2.2Siemens S7-200 Network Module 支持的寄存器：

2.3Siemens S7-300 Network 支持的寄存器：

2.4Siemens S7-1200 支持的寄存器：

3.HMI设置

4.PLC设置

4.1Siemens S7-200 SMART设置

4.2Siemens S7-200 Network Module 设置

>Step1：在STEP 7-Micro/WIN中利用以太网向导组态CP243-1，启动以太网向导

>Step2：制定模块位置

>Step3：指派IP地址

>Step4：设置参数

> Step5：配置连接

>Step6：建议不使用CRC保护

>Step7：分配内存，推荐使用VB9000以后的寄存器地址

>Step8：完成

> Step9：确认消息

>Step10：调用ETH0_CTRL

4.3使用SIEMENS S7-300_Network协议，300网络模块

>Step1:硬件配置中，插入CP300的工业以太网模块

>Step2：打开CP343-1的属性，设置其IP地址

>Step3：完成硬件配置后，下载即可

4.4用SIEMENS S7-300_Network协议，400网络模块

>Step1：设置HMI的协议超时时间1

>Step2：在硬件配置中，插入CP400的工业以太网模块

>Step3：打开CP443-1的属性，设置IP地址，MAC地址可以不

>Step4：完成硬件配置后，下载

4.5西门子1200、1500使用SIEMENS S7-1200_Network 协议

>西门子1200、1500等PLC使用博途软件配置时，需要打开“允许从远程伙伴（PLC、HMI、OPC……）使用PUT/GET通信访问”，具体位置如下图所示：

>对于固件版本高于V4.1的西门子1200、1500等PLC，如果要访问DB数据块，需要对DB数据做做两处设置。

>固件版本查看：

>设置DB块属性，去掉“优化的块访问”选项的勾选

>建议变量时，勾选“设置值”选项


松下

1.Panasonic FP0

接线图（以下图表示从连接线的接线端所视）

> Panasonic FP0 系列RS232电缆

Tool port：

通信端口：

> Panasonic FP0 系列RS485电缆

>Panasonic FP0 系列RS422电缆

>Panasonic FP0 系列设备类型

>Panasonic FP0 系列HMI设置

>Panasonic FP0 系列PLC设置

请参考相关文档

2.Panasonic FPX

接线图（以下图表示从连接线的接线端所视）

>Panasonic FPX 系列RS232电缆

Tool port：

通信端口：

>Panasonic FPX 系列RS485电缆

>Panasonic FPX 系列RS422电缆

>Panasonic FPX 系列设备类型

>Panasonic FPX 系列HMI设置

>Panasonic FPX 系列PLC设置

请参考相关文档

3.panasonic MINAS A5

接线图（以下图表示从连接线的接线端所视）

>panasonic MINAS A5 系列RS232电缆

Tool port：

通信端口：

>panasonic MINAS A5 系列RS485电缆

>panasonic MINAS A5 系列RS422电缆

>panasonic MINAS A5 系列设备类型

>panasonic MINAS A5 系列HMI设置

>panasonic MINAS A5 系列PLC设置

请参考相关文档


三菱

1.Mitsubishi FX0-FX1-FX2

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi FX0-FX1-FX2 系列 RS232电缆

一般使用串口编程电缆

>Mitsubishi FX0-FX1-FX2 系列RS422电缆

>Mitsubishi FX0-FX1-FX2 系列设备类型

>Mitsubishi FX0-FX1-FX2 系列HMI设置

>Mitsubishi FX0-FX1-FX2 系列PLC设置

2.Mitsubishi FX2N

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi FX2N 系列 RS232电缆

一般使用串口编程电缆

>Mitsubishi FX2N 系列RS422电缆

>Mitsubishi FX2N 系列设备类型

>Mitsubishi FX2N 系列HMI设置

>Mitsubishi FX2N 系列PLC设置

3.Mitsubishi FX3U_FX3G

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi FX3U_FX3G 系列 RS232电缆

一般使用串口编程电缆

>Mitsubishi FX3U_FX3G 系列RS422电缆

>Mitsubishi FX3U_FX3G 系列设备类型

>Mitsubishi FX3U_FX3G 系列HMI设置

>Mitsubishi FX3U_FX3G 系列PLC设置

4.Mitsubishi FX232-485BD

接线图（以下图表示从连接线的接线端所视）

> Mitsubishi FX232-485BD 系列 RS232电缆

> Mitsubishi FX232-485BD 系列RS422电缆

>Mitsubishi FX232-485BD 系列RS485电缆

>Mitsubishi FX232-485BD 系列设备类型

> Mitsubishi FX232-485BD 系列HMI设置

>Mitsubishi FX232-485BD 系列PLC设置

>232

>485

5.Mitsubishi Melsec-Q

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi Melsec-Q 系列 RS232电缆

>Mitsubishi Melsec-Q 系列RS422电缆

>Mitsubishi Melsec-Q 系列设备类型

>Mitsubishi Melsec-Q 系列HMI设置

>Mitsubishi Melsec-Q 系列PLC设置

>cpu口的通讯设置

>qj71c24模块设置

6.Mitsubishi Q00J(CPU Port)

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi Q00J(CPU Port) 系列 RS232电缆

>Mitsubishi Q00J(CPU Port) 系列设备类型

>Mitsubishi Q00J(CPU Port) 系列HMI设置

>Mitsubishi Q00J(CPU Port) 系列PLC设置

PLC波特率可根据HMI设置的波特率自动改变，所以无需设置

7.Mitsubishi Q02

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi Q02 系列 RS232电缆

>Mitsubishi Q02 系列设备类型

>Mitsubishi Q02 系列HMI设置

>Mitsubishi Q02 系列PLC设置

PLC波特率可根据HMI设置的波特率自动改变，所以无需设置


三菱网络设备

1. Mitsubishi FX3U-ENET-ADP_MC_BIN

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi FX3U-ENET-ADP_MC_BIN 系列电缆

>Mitsubishi FX3U-ENET-ADP_MC_BIN 系列设备类型

>Mitsubishi FX3U-ENET-ADP_MC_BIN 系列HMI设置

>Mitsubishi FX3U-ENET-ADP_MC_BIN 系列PLC设置

2.Mitsubishi FX3U-ENET-L_Eth

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi FX3U-ENET-L_Eth 系列电缆

>Mitsubishi FX3U-ENET-L_Eth 系列设备类型

>Mitsubishi FX3U-ENET-L_Eth 系列HMI设置

>Mitsubishi FX3U-ENET-L_Eth 系列PLC设置

1.打开“FX3U-ENET-L Configuration Tool”，具体参数设置如下

2.点击“Operationalsettings”，设置参数

3.点击“Open settings”，设置参数

3.Mitsubishi_FX5U_Ethernet

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi_FX5U_Ethernet 系列电缆

>Mitsubishi_FX5U_Ethernet 系列设备类型

>Mitsubishi_FX5U_Ethernet 系列HMI设置

>Mitsubishi_FX5U_Ethernet 系列PLC设置

4.Mitsubishi MelsecR_EthBin

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi MelsecR_EthBin 系列电缆

>Mitsubishi MelsecR_EthBin 系列设备类型

>Mitsubishi MelsecR_EthBin 系列HMI设置

>Mitsubishi MelsecR_EthBin 系列PLC设置

5.Mitsubishi Melsec_EthASCII

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi Melsec_EthASCII 系列电缆

>Mitsubishi Melsec_EthASCII 系列设备类型

>Mitsubishi Melsec_EthASCII 系列HMI设置

>Mitsubishi Melsec_EthASCII 系列PLC设置

6.Mitsubishi Melsec_EthBin

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi Melsec_EthBin 系列电缆

>Mitsubishi Melsec_EthBin 系列设备类型

>Mitsubishi Melsec_EthBin 系列HMI设置

>Mitsubishi Melsec_EthBin 系列PLC设置

7.Mitsubishi QJ71E71

接线图（以下图表示从连接线的接线端所视）

>Mitsubishi QJ71E71 系列电缆

>Mitsubishi QJ71E71 系列设备类型

>Mitsubishi QJ71E71 系列HMI设置

>Mitsubishi QJ71E71 系列PLC设置


永宏

1.FATEK Series

>FATEK Series 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>使用FBS-CB25-3模块通讯，RS232通讯电缆

>使用FBS-CB25-3模块通讯，RS485通讯电缆

>FATEK Series 系列设备类型

>FATEK Series 系列HMI设置

>FATEK Series 系列PLC设置

相关参数设置请参阅设备相关说明书

2.FATEK EthernetTCP

>FATEK EthernetTCP 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>FATEK EthernetTCP 系列设备类型

>FATEK EthernetTCP 系列HMI设置

>FATEK EthernetTCP 系列PLC设置

1.在ether_cfg软件中，单击[scan]，即可搜索出当前局域网内的PLC信息

2.单击[properties]，即可在弹出的对话框中更改PLC的IP及端口号

3.单击[ok]，即完成对PLC的设定


和利时

1.HollySys LE(串口)

>HollySys LE(串口) 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>HollySys LE(串口) 系列RS485电缆

>HollySys LE(串口) 系列设备类型

>HollySys LE(串口) 系列HMI设置

>HollySys LE(串口) 系列PLC设置

请参考相关文档

2.HollySys LK_ModbusRTU

>HollySys LK_ModbusRTU 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>HollySys LK_ModbusRTU 系列RS485电缆

>HollySys LK_ModbusRTU 系列设备类型

>HollySys LK_ModbusRTU 系列HMI设置

>HollySys LK_ModbusRTU 系列PLC设置

请参考相关文档

3.HollySys LM

>HollySys LM 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>HollySys LM 系列RS485电缆

>HollySys LM 系列设备类型

>HollySys LM 系列HMI设置

>HollySys LM 系列PLC设置

请参考相关文档

4.HollySys LE(以太网)

>HollySys LE（以太网） 系列电缆

接线图（以下图表示从连接线的接线端所视）

>HollySys LE（以太网） 系列设备类型

>HollySys LE（以太网） 系列HMI设置

>HollySys LE（以太网） 系列PLC设置

请参考相关文档

5.HollySys LK210_ModbusTCP

> HollySys LK210_ModbusTCP 系列电缆

接线图（以下图表示从连接线的接线端所视）

>HollySys LK210_ModbusTCP 系列设备类型

>HollySys LK210_ModbusTCP 系列HMI设置

>HollySys LK210_ModbusTCP 系列PLC设置

请参考相关文档

6.HollySys LK_ModbusTCP

>HollySys LK_ModbusTCP 系列电缆

接线图（以下图表示从连接线的接线端所视）

>HollySys LK_ModbusTCP 系列设备类型

>HollySys LK_ModbusTCP 系列HMI设置

>HollySys LK_ModbusTCP 系列PLC设置

请参考相关文档


台达

1.DELTA AH500

>DELTA AH500 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>DELTA AH500 系列RS485电缆

>DELTA AH500 系列设备类型

>DELTA AH500 系列HMI设置

>DELTA AH500 系列PLC设置

1.使用RS485通讯时,通讯参数需修改D1120的值来设置 1.Wpl207软件说明辅助编程中可查看RS485串行设定不同波特率的D1120值

2.PLC与Wpl207连接上，监控修改D1120的值 例如，通讯参数为9600bps，7，偶校验，停止位1，需要设置D1120=H0086（十六进制） PLC程序，需要加一条语句：MOV H86 D1120

2.DELTA DVP

>DELTA DVP 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

> DELTA DVP 系列RS485电缆

> DELTA DVP 系列设备类型

>DELTA DVP 系列HMI设置

>DELTA DVP 系列PLC设置

1.使用RS485通讯时,通讯参数需修改D1120的值来设置 1.Wpl207软件说明辅助编程中可查看RS485串行设定不同波特率的D1120值

2.PLC与Wpl207连接上，监控修改D1120的值 例如，通讯参数为9600bps，7，偶校验，停止位1，需要设置D1120=H0086（十六进制） PLC程序，需要加一条语句：MOV H86 D1120

3.DELTA DVP_ModbusTCP

>DELTA DVP_ModbusTCP系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>DELTA DVP_ModbusTCP 系列设备类型

>DELTA DVP_ModbusTCP 系列HMI设置

>DELTA DVP_ModbusTCP 系列PLC设置

1.打开WPLSoft软件，新建项目。

2.修改IP地址


科威

1.KEWEI LP1-EP-EC

>KEWEI LP1-EP-EC 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>KEWEI LP1-EP-EC 系列RS485电缆

>KEWEI LP1-EP-EC 系列设备类型

>KEWEI LP1-EP-EC 系列HMI设置

>KEWEI LP1-EP-EC 系列PLC设置

请参考相关文档


步科

1.Kinco K3

>Kinco K3 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>Kinco K3 系列RS485电缆

>Kinco K3 系列设备类型

>Kinco K3 系列HMI设置

>Kinco K3 系列PLC设置

2.Kinco K5

>Kinco K5 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>Kinco K5 系列RS485电缆

>Kinco K5 系列设备类型

>Kinco K5 系列HMI设置

>Kinco K5 系列PLC设置

3.Kinco SV100_Modbus

>Kinco SV100_Modbus 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>Kinco SV100_Modbus 系列设备类型

>Kinco SV100_Modbus 系列HMI设置

>Kinco SV100_Modbus 系列PLC设置

请参考相关文档

4.Kinco Servo

>Kinco Servo 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>Kinco Servo CD 系列RS232电缆

>Kinco Servo 系列RS485电缆

>Kinco Servo 系列设备类型

>HMI的地址类型：根据伺服的位数来定，8代表一次读8位，10代表一次读16位，20代表一次读32位

>HMI的地址：前面4个H代表索引1，后面2个H代表索引2

>Kinco Servo 系列HMI设置

>Kinco Servo 系列PLC设置

使用HMI时,注意编址的规则,具体参照下面的说明

操作步骤：

通讯地址以及作用 打开软件

打开帮助中的对象词典

索引和子索引为地址 设备类型为

三个地址类型对应 字节 字 双字

前面四位为索引1，后面两位为索引2

其他参考相关文档，例如下面是FD2S 驱动器外部接线图


禾川

1.HCFA HCA1-HCA2-LX1N-LX1S

>HCFA HCA1-HCA2-LX1N-LX1S 系列RS232电缆

使用禾川公司生产的串口编程电缆与 HMI 通讯

>HCFA HCA1-HCA2-LX1N-LX1S 系列RS422电缆

接线图（以下图表示从连接线的接线端所视）

>HCFA HCA1-HCA2-LX1N-LX1S 系列RS485电缆

>HCFA HCA1-HCA2-LX1N-LX1S 系列设备类型

>HCFA HCA1-HCA2-LX1N-LX1S 系列HMI设置

>HCFA HCA1-HCA2-LX1N-LX1S 系列PLC设置

请参考相关文档

2.HCFA HCA4

>HCFA HCA4系列RS232电缆

使用禾川公司生产的串口编程电缆与 HMI 通讯

>HCFA HCA4系列RS422电缆

接线图（以下图表示从连接线的接线端所视）

>HCFA HCA4 系列RS485电缆

>HCFA HCA4 系列设备类型

>HCFA HCA4 系列HMI设置

>HCFA HCA4 系列PLC设置

请参考相关文档

3.HCFA HCA8

>HCFA HCA8系列RS232电缆

使用禾川公司生产的串口编程电缆与 HMI 通讯

>HCFA HCA8系列RS422电缆

接线图（以下图表示从连接线的接线端所视）

>HCFA HCA8 系列RS485电缆

>HCFA HCA8 系列设备类型

>HCFA HCA8 系列HMI设置

>HCFA HCA8 系列PLC设置

请参考相关文档

4.HCFA SV-X3_485-2W

>HCFA SV-X3_485-2W 系列RS485电缆

接线图（以下图表示从连接线的接线端所视）

>HCFA SV-X3_485-2W 系列设备类型

>HCFA SV-X3_485-2W 系列HMI设置

>HCFA SV-X3_485-2W 系列PLC设置

请参考相关文档

5.HCFA TX-485ADP_485BD

>HCFA TX-485ADP_485BD 系列RS485电缆

接线图（以下图表示从连接线的接线端所视）

>HCFA TX-485ADP_485BD 系列设备类型

>HCFA TX-485ADP_485BD 系列HMI设置

>HCFA TX-485ADP_485BD 系列PLC设置


安川

1.Yaskawa MP-SeriesSIO(Extension)

接线图（以下图表示从连接线的接线端所视）

>Yaskawa MP-SeriesSIO(Extension) 系列RS232电缆

>Yaskawa MP-SeriesSIO(Extension) 系列设备类型

>Yaskawa MP-SeriesSIO(Extension) 系列HMI设置

>Yaskawa MP-SeriesSIO(Extension) 系列PLC设置

请参考相关文档

2.Yaskawa Sigma-5_MEMOBUS

接线图（以下图表示从连接线的接线端所视）

>Yaskawa Sigma-5_MEMOBUS 系列RS232电缆

>Yaskawa Sigma-5_MEMOBUS 系列RS422电缆

>Yaskawa Sigma-5_MEMOBUS 系列设备类型

>Yaskawa Sigma-5_MEMOBUS 系列HMI设置

>Yaskawa Sigma-5_MEMOBUS 系列PLC设置

字类型寄存器，名称Pn，具体的可访问地址，需参考Σ-7S伺服单元+MECHATROLINK-II通讯指令型.pdf内的397页“13 参数一览”（仅针对Σ-7S）。字类型具体对应表格列内“大小”是“2”的寄存器。

双字字类型寄存器，名称Pn_32Bit，具体的可访问地址，需参考Σ-7S伺服单元+MECHATROLINK-II通讯指令型.pdf内的397页“13 参数一览”（仅针对Σ-7S）。

有部分寄存器的某些bit是不可访问的，因此对可操作的bit进行操作，需要用到“字寄存器的按位索引”，具体参考Σ-7S伺服单元+MECHATROLINK-II通讯指令型.pdf内的397页“13 参数一览”（仅针对Σ-7S）。


安川网络设备

1.Yaskawa UDPSlave

接线图（以下图表示从连接线的接线端所视）

>Yaskawa UDPSlave 系列电缆

>Yaskawa UDPSlave 系列设备类型

>Yaskawa UDPSlave 系列HMI设置

>Yaskawa UDPSlave 系列PLC设置


欧姆龙

1.欧姆龙 OMRON CJ-CS

> OMRON CJ-CS 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

> OMRON CJ-CS 系列RS422电缆/CJ1W-SCU41|CJ1W-SCB41等通讯模块

> OMRON CJ-CS 系列RS422电缆/CP1W-CIF11|CP1W-CIF12等通讯模块

注意： CP1W-CIF11不带光电隔离，允许最大通讯距离为50米； CP1W-CIF12带光电隔离，允许最大通讯距离为500米， 其他参数规格相同，拨码开关设定相同

>OMRON OMRON CJ-CS 系列RS485电缆/CP1W-CIF11|CP1W-CIF12等通讯模块

>OMRON CJ-CS 支持的寄存器：

>OMRON CJ-CS 系列HMI设置

>OMRON CJ-CS 系列PLC设置

2.欧姆龙 CP1H_CP1L

> OMRON CP1H_CP1L 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

> OMRON CP1H-CP1L系列RS422电缆/CJ1W-SCU41|CJ1W-SCB41等通讯模块

>OMRON CP1H-CP1L系列RS422电缆/CP1W-CIF11|CP1W-CIF12等通讯模块

注意： CP1W-CIF11不带光电隔离，允许最大通讯距离为50米； CP1W-CIF12带光电隔离，允许最大通讯距离为500米， 其他参数规格相同，拨码开关设定相同

>OMRON CP1H-CP1L系列RS485电缆/CP1W-CIF11|CP1W-CIF12等通讯模块

>OMRON CP1H_CP1L 支持的寄存器：

>OMRON CP1H_CP1L 系列HMI设置

>OMRON CP1H_CP1L 系列PLC设置

3.欧姆龙 CP1H_CP1L

> OMRON CJ_CS_NJ Series EtherNet(UDPSlave) 电缆

接线图（以下图表示从连接线的接线端所视）

>OMRON CJ_CS_NJ Series EtherNet(UDPSlave) 支持的寄存器：

>OMRON CJ_CS_NJ Series EtherNet(UDPSlave) 系列HMI设置

>OMRON CJ_CS_NJ Series EtherNet(UDPSlave) 系列PLC设置

使用CX-Integrator修改相关参数

1.选择相应型号，连接软件与PLC

2.将PLC设置在编程模式下进行操作

3.读取网络设备，右击显示网络号和节点的设备，选择连接，右侧显示网络上的设备

4.双击网络设备修改相应参数，如IP地址

5.设置网络号和节点号

a)网络号

b)节点号请在控制器旋钮上设置（NODE No.)


汇川

1.Inovance AM600_Serial

>Inovance AM600_Serial 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

请使用汇川编程电缆进行通讯

>Inovance AM600_Serial 系列RS485电缆

>Inovance AM600_Serial 系列RS485电缆（端子）

>Inovance AM600_Serial 系列RS422电缆

>Inovance AM600_Serial 系列设备类型

>Inovance AM600_Serial 系列HMI设置

>Inovance AM600_Serial 系列PLC设置

2.Inovance H2u

>Inovance H2u 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

请使用汇川编程电缆进行通讯

>Inovance H2u 系列RS485电缆

>Inovance H2u 系列RS485电缆（端子）

>Inovance H2u 系列RS422电缆

>Inovance H2u 系列设备类型

>Inovance H2u 系列HMI设置

>Inovance H2u 系列PLC设置

3.Inovance H3u

>Inovance H3u 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

请使用汇川编程电缆进行通讯

>Inovance H3u 系列RS485电缆

>Inovance H3u 系列RS485电缆（端子）

>Inovance H3u 系列RS422电缆

>Inovance H3u 系列设备类型

>Inovance H3u 系列HMI设置

>Inovance H3u 系列PLC设置

4.Inovance AM600_Ethernet

>Inovance AM600_Ethernet 系列电缆

接线图（以下图表示从连接线的接线端所视）

>Inovance AM600_Ethernet 系列设备类型

>Inovance AM600_Ethernet 系列HMI设置

>Inovance AM600_Ethernet 系列PLC设置

请参考相关文档

5.Inovance H3u_Ethernet

>Inovance H3u_Ethernet 系列电缆

接线图（以下图表示从连接线的接线端所视）

>Inovance H3u_Ethernet 系列设备类型

>Inovance H3u_Ethernet 系列HMI设置

>Inovance H3u_Ethernet 系列PLC设置

请参考相关文档


麦格米特

1.MEGMEET M280

>MEGMEET M280 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>MEGMEET M280 系列RS232电缆

>MEGMEET M280 系列RS485电缆

>MEGMEET M280 系列设备类型

>MEGMEET M280 系列HMI设置

>MEGMEET M280 系列PLC设置

1. 打开PLC软件X-builder，新建工程，选择正确的PLC类型（MC280）

2. 打开系统块→通讯口，对通讯口进行设置（支持modbus协议）

PORT0设置（RS232通讯）

PORT1和PORT2设置（RS485通讯）

注：使用软件时，MAIN：主程序不能为空

2.MEGMEET MCSeries_Port0

>MEGMEET MCSeries_Port0 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>MEGMEET MCSeries_Port0 系列RS232电缆

>MEGMEET MCSeries_Port0 系列RS485电缆

>MEGMEET MCSeries_Port0 系列设备类型

> MEGMEET MCSeries_Port0 系列HMI设置

>MEGMEET MCSeries_Port0 系列PLC设置

请参考相关文档

3.MEGMEET MC Series

>MEGMEET MC Series 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>MEGMEET MC Series 系列RS232电缆

>MEGMEET MC Series 系列RS485电缆

>MEGMEET MC Series 系列设备类型

>MEGMEET MC Series 系列HMI设置

>MEGMEET MC Series 系列PLC设置

请参考相关文档

4.MEGMEET SV-Master

> MEGMEET SV-Master 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

> MEGMEET SV-Master 系列RS232电缆

>MEGMEET SV-Master 系列RS485电缆

>MEGMEET SV-Master 系列设备类型

>MEGMEET SV-Master 系列HMI设置

>MEGMEET SV-Master 系列PLC设置

请参考相关文档

5.MEGMEET U600

> MEGMEET U600 系列电缆

接线图（以下图表示从连接线的接线端所视）

>MEGMEET U600 系列设备类型

>MEGMEET U600 系列HMI设置

>MEGMEET U600 系列PLC设置

请参考相关文档


麦科

1.MIKOM MX1H

>MIKOM MX1H 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>MIKOM MX1H 系列RS232电缆

>MIKOM MX1H 系列RS485电缆

>MIKOM MX1H 系列设备类型

>MIKOM MX1H 系列HMI设置

>MIKOM MX1H 系列PLC设置

和HMI通讯的PLC,通讯口需设置为Modbus协议,如下图所示:


基恩士

1.KEYENCE KV-1000-3000_Bin

>KEYENCE KV-1000-3000_Bin 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>KEYENCE KV-1000-3000_Bin 系列设备类型

>KEYENCE KV-1000-3000_Bin 系列HMI设置

>KEYENCE KV-1000-3000_Bin 系列PLC设置

点击“单元配置”,在“单元编辑器”中,[设置内置串行端口(Port0)],动作模式-KV模式（上位链路），波特率为9600，参考下图进行设置

注意：

1.PLC中的计数器C和定时器T，需要在PLC软件中进行编程后，才能在HMI中使用写入功能，读取功能不需要针对每个寄存器编程。

2.若是HMI中的PLC地址显示时间长，可以修改协议超时时间1（毫秒），改小。

2.KEYENCE KV-1000_ASCII

>KEYENCE KV-1000_ASCII 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>KEYENCE KV-1000_ASCII 系列设备类型

>KEYENCE KV-1000_ASCII 系列HMI设置

>KEYENCE KV-1000_ASCII 系列PLC设置

点击“单元配置”,在“单元编辑器”中,[设置内置串行端口(Port0)],动作模式-KV模式（上位链路），波特率为9600，参考下图进行设置

注意：

1.PLC中的计数器C和定时器T，需要在PLC软件中进行编程后，才能在HMI中使用写入功能，读取功能不需要针对每个寄存器编程。

2.若是HMI中的PLC地址显示时间长，可以修改协议超时时间1（毫秒），改小。

3.KEYENCE KV-Series-nano_ASCII

>KEYENCE KV-Series-nano_ASCII 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>KEYENCE KV-Series-nano_ASCII 系列设备类型

>KEYENCE KV-Series-nano_ASCII 系列HMI设置

>KEYENCE KV-Series-nano_ASCII 系列PLC设置

点击“单元配置”,在“单元编辑器”中,[设置内置串行端口(Port0)],动作模式-KV模式（上位链路），波特率为9600，参考下图进行设置

注意：

1.PLC中的计数器C和定时器T，需要在PLC软件中进行编程后，才能在HMI中使用写入功能，读取功能不需要针对每个寄存器编程。

2.若是HMI中的PLC地址显示时间长，可以修改协议超时时间1（毫秒），改小。

4.KEYENCE KV-Series_ASCII

>KEYENCE KV-Series_ASCII 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>KEYENCE KV-Series_ASCII 系列设备类型

>KEYENCE KV-Series_ASCII 系列HMI设置

>KEYENCE KV-Series_ASCII 系列PLC设置

点击“单元配置”,在“单元编辑器”中,[设置内置串行端口(Port0)],动作模式-KV模式（上位链路），波特率为9600，参考下图进行设置

注意：

1.PLC中的计数器C和定时器T，需要在PLC软件中进行编程后，才能在HMI中使用写入功能，读取功能不需要针对每个寄存器编程。

2.若是HMI中的PLC地址显示时间长，可以修改协议超时时间1（毫秒），改小。

5.KV5500_Ethernet

>KV5500_Ethernet 系列电缆

接线图（以下图表示从连接线的接线端所视）

>KV5500_Ethernet 系列设备类型

>KV5500_Ethernet 系列HMI设置

>KV5500_Ethernet 系列PLC设置

1.“编辑器”窗口，点击[单元配置]中的“[0]KV-5000 R30000”以修改PLC的IP地址使PLC与PC处于同一网段中，例如下图所示，并点击[确认]以保存修改内容：

2.切换到“监控器”窗口以查看修改的内容，会弹出如图窗口，点击[PLC传送-〉监控模式（T）]，弹出“传输程序[通讯目标：KV-5000路经：USB]”，点击[执行]，内容写入后，再次查看“监控器”窗口下的[单元配置]中的“[0]KV-5000 R30000”中PLC的IP地址，如可见该地址已经修改过来即可。

6.KV7500_Ethernet

>KV7500_Ethernet 系列电缆

接线图（以下图表示从连接线的接线端所视）

>KV7500_Ethernet 系列设备类型

>KV7500_Ethernet 系列HMI设置

>KV7500_Ethernet 系列PLC设置

1.“编辑器”窗口，点击[单元配置]中的“[0]KV-5000 R30000”以修改PLC的IP地址使PLC与PC处于同一网段中，例如下图所示，并点击[确认]以保存修改内容：

2.切换到“监控器”窗口以查看修改的内容，会弹出如图窗口，点击[PLC传送-〉监控模式（T）]，弹出“传输程序[通讯目标：KV-5000路经：USB]”，点击[执行]，内容写入后，再次查看“监控器”窗口下的[单元配置]中的“[0]KV-5000 R30000”中PLC的IP地址，如可见该地址已经修改过来即可。


翠欧

1.TRIO Serial

接线图（以下图表示从连接线的接线端所视）

>TRIO Serial 系列RS232电缆

>TRIO Serial 系列设备类型

>TRIO Serial 系列HMI设置

>TRIO Serial 系列PLC设置

请参考相关文档

2.TRIO Modbus

接线图（以下图表示从连接线的接线端所视）

>TRIO Modbus 系列RS232电缆

>TRIO Modbus 系列设备类型

>TRIO Modbus 系列HMI设置

>TRIO Modbus 系列PLC设置

请参考相关文档

3.TRIO ModbusExtend

接线图（以下图表示从连接线的接线端所视）

>TRIO ModbusExtend 系列RS232电缆

>TRIO ModbusExtend 系列设备类型

>TRIO ModbusExtend 系列HMI设置

>TRIO ModbusExtend 系列PLC设置

请参考相关文档

TRIO_modbus/TRIO_modbus_extend的区别

TRIO_modbus_extend在TRIO_modbus基础上，增加了模拟输入数据位、数据寄存器位、05功能码数据寄存器、 06功能码数据寄存器、03功能码字节交换数据寄存器（03功能码的高低字节交换）、 04功能码字节交换数据寄存器（04功能码的高低字节交换）


日立

日立（Hitachi）

> Hitachi EHV-CPU 系列RS232编程电缆

接线图（以下图表示从连接线的接线端所视）

> Hitachi EHV-CPU 系列RS232通讯电缆

>Hitachi EHV-CPU 系列RS485通讯电缆

> Hitachi EHV-CPU 系列设备类型

>Hitachi EHV-CPU 系列HMI设置

> Hitachi EHV-CPU 系列PLC设置

请参考相关文档


LS

1.LS Master-K Cnet

>LS Master-K Cnet 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>LS Master-K Cnet 系列RS485电缆

>LS Master-K Cnet 系列设备类型

>LS Master-K Cnet 系列HMI设置

>LS Master-K Cnet 系列PLC设置

2.LS Master-K_Serial

>LS Master-K_Serial 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>LS Master-K_Serial 系列RS485电缆

>LS Master-K_Serial 系列设备类型

>LS Master-K_Serial 系列HMI设置

>LS Master-K_Serial 系列PLC设置

3.LS XEC Cnet

>LS XEC Cnet 系列RS232(编程)电缆

接线图（以下图表示从连接线的接线端所视）

>LS XEC Cnet 系列RS232电缆

>LS XEC Cnet 系列RS485电缆

>LS XEC Cnet 系列设备类型

>LS XEC Cnet 系列HMI设置

>LS XEC Cnet 系列PLC设置

CPU选型

LS XGB系列分不同的CPU类型，如下图粉红色方框位置，它的选择可在PLC软件“XG5000”中进行添加PLC的时候，可以点开PDF文件进行搜索查询，如下图红色圆圈的地方点开。比如：XBC-DR10E需要选择XGB-XBCE，XBC-DR40SU需要选择XGB-XBCS，XEC-DN32UP需要选择XGB-XBCH，XEC-DP32H需要选择XGB-XECH

示例1—— 如XEC-DN32UP和XBC-DR40SU的Cnet通信设置如下：两个通道可以选择使用4中不同的通信协议，但是硬件连接方式在通道1和通道2中是固定不能变更的。 FS选用了“LS XGB_Cnet”设备类型，则PLC中使用XGT Server。如果FS选用modbus rtu或者modbus ascii，则需要对应在PLC中设置。

示例2—— 如XBC-DR10E的Cnet通信设置如下：只有通道1可以使用，并且可以选择使用232还是485，通信协议也是4种可选。 FS选用了LS XGB_Cnet 设备类型，则PLC中使用XGT Server。如果FS选用modbus rtu或者modbus ascii，则需要对应在PLC中设置。

4.LS XEC_Fenet

>LS XEC_FEnet 系列电缆

接线图（以下图表示从连接线的接线端所视）

>LS XEC_FEnet 系列设备类型

>LS XEC_FEnet 系列HMI设置

>LS XEC_FEnet 系列PLC设置

以太网连接就是常规的网口连接方式，当网口连线后，选择对应的协议。若通过查找出来的CPU型号是XGB-XBCU，则使用“LS XGB-XBCU_FEnet”，如果是其他型号，可以使用“LS XGB_FEnet”，若不是XGB系列，而是XEC系列，则使用“LS XEC_FEnet”。

注意:当在XG5000中网络设置成“modbus TCP/IP server”，则FS中网络PLC选择的设备就是modbus TCP。

5.LS XGB-XBCU_Fenet

>LS XGB-XBCU_Fenet 系列电缆

接线图（以下图表示从连接线的接线端所视）

>LS XGB-XBCU_Fenet 系列设备类型

>LS XGB-XBCU_Fenet 系列HMI设置

>LS XGB-XBCU_Fenet 系列PLC设置

以太网连接就是常规的网口连接方式，当网口连线后，选择对应的协议。若通过查找出来的CPU型号是XGB-XBCU，则使用“LS XGB-XBCU_FEnet”，如果是其他型号，可以使用“LS XGB_FEnet”，若不是XGB系列，而是XEC系列，则使用“LS XEC_FEnet”。

注意:当在XG5000中网络设置成“modbus TCP/IP server”，则FS中网络PLC选择的设备就是modbus TCP。

6.LS XGB_Cnet

>LS XGB_Cnet 系列RS232(编程)电缆

接线图（以下图表示从连接线的接线端所视）

>LS XGB_Cnet 系列RS232电缆

>LS XGB_Cnet 系列RS485电缆

>LS XGB_Cnet 系列设备类型

>LS XGB_Cnet 系列HMI设置

>LS XGB_Cnet 系列PLC设置

CPU选型

LS XGB系列分不同的CPU类型，如下图粉红色方框位置，它的选择可在PLC软件“XG5000”中进行添加PLC的时候，可以点开PDF文件进行搜索查询，如下图红色圆圈的地方点开。比如：XBC-DR10E需要选择XGB-XBCE，XBC-DR40SU需要选择XGB-XBCS，XEC-DN32UP需要选择XGB-XBCH，XEC-DP32H需要选择XGB-XECH

示例1—— 如XEC-DN32UP和XBC-DR40SU的Cnet通信设置如下：两个通道可以选择使用4中不同的通信协议，但是硬件连接方式在通道1和通道2中是固定不能变更的。 FS选用了“LS XGB_Cnet”设备类型，则PLC中使用XGT Server。如果FS选用modbus rtu或者modbus ascii，则需要对应在PLC中设置。

示例2—— 如XBC-DR10E的Cnet通信设置如下：只有通道1可以使用，并且可以选择使用232还是485，通信协议也是4种可选。 FS选用了LS XGB_Cnet 设备类型，则PLC中使用XGT Server。如果FS选用modbus rtu或者modbus ascii，则需要对应在PLC中设置。

7.LS XGB_Fenet

>LS XGB_Fenet 系列电缆

接线图（以下图表示从连接线的接线端所视）

>LS XGB_Fenet 系列设备类型

>LS XGB_Fenet 系列HMI设置

>LS XGB_Fenet 系列PLC设置

以太网连接就是常规的网口连接方式，当网口连线后，选择对应的协议。若通过查找出来的CPU型号是XGB-XBCU，则使用“LS XGB-XBCU_FEnet”，如果是其他型号，可以使用“LS XGB_FEnet”，若不是XGB系列，而是XEC系列，则使用“LS XEC_FEnet”。

注意:当在XG5000中网络设置成“modbus TCP/IP server”，则FS中网络PLC选择的设备就是modbus TCP。

8.LS_XGT_Serial

>LS_XGT_Serial 系列RS232(编程)电缆

接线图（以下图表示从连接线的接线端所视）

>LS_XGT_Serial 系列RS232电缆

>LS_XGT_Serial 系列RS485电缆

>LS_XGT_Serial 系列设备类型

>LS_XGT_Serial 系列HMI设置

>LS_XGT_Serial 系列PLC设置

CPU选型

LS XGB系列分不同的CPU类型，如下图粉红色方框位置，它的选择可在PLC软件“XG5000”中进行添加PLC的时候，可以点开PDF文件进行搜索查询，如下图红色圆圈的地方点开。比如：XBC-DR10E需要选择XGB-XBCE，XBC-DR40SU需要选择XGB-XBCS，XEC-DN32UP需要选择XGB-XBCH，XEC-DP32H需要选择XGB-XECH

示例1—— 如XEC-DN32UP和XBC-DR40SU的Cnet通信设置如下：两个通道可以选择使用4中不同的通信协议，但是硬件连接方式在通道1和通道2中是固定不能变更的。 FS选用了“LS XGB_Cnet”设备类型，则PLC中使用XGT Server。如果FS选用modbus rtu或者modbus ascii，则需要对应在PLC中设置。

示例2—— 如XBC-DR10E的Cnet通信设置如下：只有通道1可以使用，并且可以选择使用232还是485，通信协议也是4种可选。 FS选用了LS XGB_Cnet 设备类型，则PLC中使用XGT Server。如果FS选用modbus rtu或者modbus ascii，则需要对应在PLC中设置。


信捷

1.THINGET Controller

接线图（以下图表示从连接线的接线端所视）

>THINGET Controller 系列RS232电缆

>THINGET Controller 系列设备类型

>THINGET Controller 系列HMI设置

>THINGET Controller 系列PLC设置

请参考相关文档

2.THINGET XD3 Controller

接线图（以下图表示从连接线的接线端所视）

>THINGET XD3 Controller 系列RS232电缆

>THINGET XD3 Controller 系列设备类型

>THINGET XD3 Controller 系列HMI设置

>THINGET XD3 Controller 系列PLC设置

请参考相关文档


横河

1.Yokogawa FA-M3

接线图（以下图表示从连接线的接线端所视）

>Yokogawa FA-M3 系列RS232电缆

>Yokogawa FA-M3 系列RS422电缆

>Yokogawa FA-M3 系列RS485电缆

>Yokogawa FA-M3 系列设备类型

>Yokogawa FA-M3 系列HMI设置

>Yokogawa FA-M3 系列PLC设置

2.Yokogawa FA-M3_Ethernet

接线图（以下图表示从连接线的接线端所视）

>Yokogawa FA-M3_Ethernet 系列电缆

>Yokogawa FA-M3_Ethernet 系列设备类型

>Yokogawa FA-M3_Ethernet 系列HMI设置

>Yokogawa FA-M3_Ethernet 系列PLC设置

3.Yokogawa FA-M3_UDP

接线图（以下图表示从连接线的接线端所视）

>Yokogawa FA-M3_UDP 系列电缆

>Yokogawa FA-M3_UDP 系列设备类型

>Yokogawa FA-M3_UDP 系列HMI设置

>Yokogawa FA-M3_UDP 系列PLC设置


海为

Haiwell（海为）

>Haiwell 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>Haiwell 系列RS485电缆

>Haiwell 系列设备类型

>Haiwell 系列HMI设置

>Haiwell 系列PLC设置

请参考相关文档


艾克威尔

ANCHORWILL ModbusRTU

>ANCHORWILL ModbusRTU 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>ANCHORWILL ModbusRTU 系列RS485电缆

>ANCHORWILL ModbusRTU 系列设备类型

> ANCHORWILL ModbusRTU 系列HMI设置

>ANCHORWILL ModbusRTU 系列PLC设置

请登陆http://www.anchorwill.com/官方网站,进行查看


安科瑞

ANModbus RTU

> ANModbus RTU 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>ANModbus RTU 系列RS485电缆

> ANModbus RTU 系列设备类型

>ANModbus RTU 系列HMI设置

>ANModbus RTU 系列PLC设置

请登陆http://www.acrel.cn/官方网站,进行查看


BACNET

FlexemBACnet(标签地址)

> FlexemBACnet 系列电缆

接线图（以下图表示从连接线的接线端所视）

> FlexemBACnet 系列设备类型

> FlexemBACnet 系列HMI设置

>FlexemBACnet 系列PLC设置

下面介绍辅助软件的使用方法，可以用来仿真测试，正式的软件请参考相关说明文档

1.使用的辅助软件

bacnetdevicesimulator_3.0.32为BACnet设备仿真软件

2.软件功能

BacnetIP设备扫描，并导出在线设备的部分基本属性

3.软件运行

解压安装包BACnetScaner.zip

右击以管理员身份运行“BACnetScaner”文件夹下的“BACnetScaner.exe”运行程序

4.软件功能操作说明

在simulator上添加仿真设备

点击“设置”可设置通信参数，“IP”设置为本机IP，“端口”默认设置为BACnetIP默认端口47808

设置要扫描的设备号范围，勾选“All”表示搜索所有设备

点击“Search”开始扫描在线设备

设备列表中出现扫描到的在线设备

导出在线设备的属性点 点击“Generate”可将扫描到的设备部分基本属性点导出到.txt文件

导出文件保存在软件目录下的“BACnetTag.txt”

由软件导出的BACnetTag.txt里内容格式为：

“设备号 对象类型-对象实例号 属性点，属性数据类型”

例如Device-1 AnalogValue-0 units,DWord，表示：该属性属于在线设备Device1，对象类型为AnalogValue，实例1中的units属性，其数据类型是DWord（双字类型）。


德联

Delian Boiler

>Delian Boiler 系列电缆

接线图（以下图表示从连接线的接线端所视）

> Delian Boiler 系列设备类型

> Delian Boiler 系列HMI设置

>Delian Boiler 系列PLC设置

请参考相关文档


英维克

Envicool EC

>Envicool EC 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>Envicool EC 系列 RS485电缆

>Envicool EC 系列设备类型

>Envicool EC 系列 HMI设置

>Envicool EC 系列 PLC设置

英维克ERG控制板是RS485连接方式，本驱动默认使用RS485_2连接，工程建立时可根据实际情况采用外接转换设备，或者使用HMI或Fbox自带的RS485端口。在区分设备地址（站号）的情况下，可以多设备同时接入同一路RS485通道。

>寄存器对应关系

Description—指地址类型描述

Name—cfg文件中对寄存器的命名，在FS和客户端中显示为“地址类型”

reg_id—指cfg对应的类型码值，其值与协议文档的CID2相等

reg_addr—指“地址类型”下的地址值，ERG与EC略有不同，使用时需特别注意

Parameter—指不同地址值对应的参数内容，下分ERG和EC。

Width—指参数内容占用的字节数

特别指出的是，所有地址类型都是“只读”或“只写”属性，“遥控”和“设定系统参数”是“只写”，其余为“只读”。


GE

1.GE SNP-X

>GE SNP-X 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>GE SNP-X 系列RS232(RJ-45)电缆

>GE SNP-X 系列RS422电缆

>GE SNP-X 系列设备类型

>GE SNP-X 系列HMI设置

>GE SNP-X 系列PLC设置

2.GE RX3i_SRTP

>GE RX3i_SRTP 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>GE RX3i_SRTP 系列设备类型

>GE RX3i_SRTP 系列HMI设置

>GE RX3i_SRTP 系列PLC设置

>如果使用Modbus_TCP协议,可以参考对应表


经纬

Ginwave modbus

>Ginwave modbus 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

>Ginwave modbus 系列电源口

>Ginwave modbus 系列设备类型

>Ginwave modbus 系列HMI设置

>Ginwave modbus 系列PLC设置

请参考相关文档


GPS

GPS

>GPS GPS_NMEA 系列 RS232 电缆

接线图（以下图表示从连接线的接线端所视）

说明:该驱动所有寄存器均为只读

调试驱动使用的GPS模块型号：UB-355 RS232

>GPS GPS_NMEA 系列设备类型

>GPS GPS_NMEA 系列HMI设置

>GPS GPS_NMEA 系列PLC设置

寄存器对应GPS数据说明


亿图

1.HUST CNC_H6D

>HUST CNC_H6D 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>HUST CNC_H6D 系列设备类型

>HUST CNC_H6D 系列HMI设置

>HUST CNC_H6D 系列PLC设置

请参考相关文档

2.HUST CNC_HalfDuplex

>HUST CNC_HalfDuplex 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>HUST CNC_HalfDuplex 系列设备类型

>HUST CNC_HalfDuplex 系列HMI设置

> HUST CNC_HalfDuplex 系列PLC设置

请参考相关文档


和泉

1.IDEC MicroSmart

>IDEC MicroSmart 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>IDEC MicroSmart 系列设备类型

>IDEC MicroSmart 系列HMI设置

>IDEC MicroSmart 系列PLC设置

请参考相关文档

2.IDEC Smart

>IDEC Smart 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>IDEC Smart 系列RS485电缆

>IDEC Smart 系列设备类型

>IDEC Smart 系列HMI设置

>IDEC Smart 系列PLC设置

请参考相关文档


津职达

1.JZD-300X

>JZD-300X 系列RS485电缆

接线图（以下图表示从连接线的接线端所视）

>JZD-300X 系列设备类型

>JZD-300X 系列HMI设置

>JZD-300X 系列PLC设置

请参考相关文档

2.JZD-DL

>JZD-DL 系列RS485电缆

接线图（以下图表示从连接线的接线端所视）

>JZD-DL 系列设备类型

>JZD-DL 系列HMI设置

>JZD-DL 系列PLC设置

请参考相关文档

3.JZD-IO-1616

>JZD-IO-1616 系列RS485电缆

接线图（以下图表示从连接线的接线端所视）

>JZD-IO-1616 系列设备类型

>JZD-IO-1616 系列HMI设置

>JZD-IO-1616 系列PLC设置

请参考相关文档


科创力源

1.KCLY Modbus

>KCLY Modbus 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>KCLY Modbus 系列RS485电缆

>KCLY Modbus 系列设备类型

>KCLY Modbus 系列HMI设置

>KCLY Modbus 系列PLC设置

请参考相关文档


光洋

1.Koyo SH-SH1-SH2

>Koyo SH-SH1-SH2 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>Koyo SH-SH1-SH2 系列RS485电缆

>Koyo SH-SH1-SH2 系列设备类型

>Koyo SH-SH1-SH2 系列HMI设置

>Koyo SH-SH1-SH2 系列PLC设置


麦卓

1.Metronix

>Metronix 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>Metronix 系列RS485电缆

>Metronix 系列设备类型

>Metronix 系列HMI设置

>Metronix 系列PLC设置

请参考相关文档


英威腾

1.invt IVC_Serial

>invt IVC_Serial 系列RS232电缆

接线图（以下图表示从连接线的接线端所视）

>invt IVC_Serial 系列RS232电缆(端子)

>invt IVC_Serial 系列RS485电缆

>invt IVC_Serial 系列设备类型

>invt IVC_Serial 系列HMI设置

>invt IVC_Serial 系列PLC设置

此系列PLC有Port0和Port1,其中Port1口支持RS232和RS485

>Port0口设置如下:

>Port1口设置如下:


赛亚

1.Saia SBus

接线图（以下图表示从连接线的接线端所视）

>Saia SBus 系列RS485电缆

>Saia SBus 系列设备类型

>Saia SBus 系列HMI设置

>Saia SBus 系列PLC设置

请参考相关文档


施耐德

1.Schneider-TM218

接线图（以下图表示从连接线的接线端所视）

>Schneider-TM218 系列RS485电缆

>Schneider-TM218 系列设备类型

>Schneider-TM218 系列HMI设置

>Schneider-TM218 系列PLC设置

请参考相关文档

2.Schneider IMS SERVO

接线图（以下图表示从连接线的接线端所视）

>Schneider IMS SERVO 系列RS485电缆

>Schneider IMS SERVO 系列设备类型

>Schneider IMS SERVO 系列HMI设置

>Schneider IMS SERVO 系列PLC设置

请参考相关文档


TCL

1.TCL ModbusRTU

接线图（以下图表示从连接线的接线端所视）

>TCL ModbusRTU 系列RS485电缆

'

>TCL ModbusRTU 系列设备类型

>TCL ModbusRTU 系列HMI设置

>TCL ModbusRTU 系列PLC设置

因为协议转换器的连接为484，我们必须选择为RS485-2，其他设置为默认值

协议转换器的站号地址为0x10~0x2F，对应我公司驱动上的站号为16~47

站号一定要和客户的协议转换器的地址账户对应，经测试客户协议转换器地址设置为打开外壳后有一个圆形带0~F刻度的旋钮

当内部箭头指向那个位，地址站号对应站号。一圈可选择16个站号，它边上的拨码开关靠近它这边为高进位。上图地址站号为0x11，对应软件里为17。

当需要读取协议转换器地址时，请将对应地址值设置到我们的寄存器地址，只读空机为0x400~0x17DD。

当需要写协议转换器地址，请将对应地址值设置到我们的寄存器地址，只写空机为0x1BDE~0x265B。

'

注意：因为只写寄存器无法读取数值，所以显示值一直为零。但不影响写入的数值。

接线见


东元

1.TP03 Series

接线图（以下图表示从连接线的接线端所视）

>TP03 Series 系列RS232电缆

>TP03 Series 系列设备类型

>TP03 Series 系列HMI设置

>TP03 Series 系列PLC设置

请参考相关文档


东微智能

1.TENDZONE CentralController

接线图（以下图表示从连接线的接线端所视）

>TENDZONE CentralController 系列RS232电缆

>TENDZONE CentralController 系列设备类型

>TENDZONE CentralController 系列HMI设置

>TENDZONE CentralController 系列PLC设置

请参考相关文档


天津成科

1.tjck

接线图（以下图表示从连接线的接线端所视）

>tjck 系列RS232电缆

>tjck 系列设备类型

>tjck 系列HMI设置

>tjck 系列PLC设置

请参考相关文档


派克

1.parker ACR9000_Serial

接线图（以下图表示从连接线的接线端所视）

>parker ACR9000_Serial 系列RS232电缆

>parker ACR9000_Serial 系列设备类型

>parker ACR9000_Serial 系列HMI设置

>parker ACR9000_Serial 系列PLC设置

请参考相关文档


兰普锋

1.Runpower

接线图（以下图表示从连接线的接线端所视）

>Runpower 系列RS232电缆

>Runpower 系列设备类型

>Runpower 系列HMI设置

>Runpower 系列PLC设置

请参考相关文档


欧时

1.OE MAX NX7

接线图（以下图表示从连接线的接线端所视）

>OE MAX NX7 系列RS232电缆

>OE MAX NX7 系列设备类型

>OE MAX NX7 系列HMI设置

>OE MAX NX7 系列PLC设置

请参考相关文档

2.RS X8Series_Serial

接线图（以下图表示从连接线的接线端所视）

>RS X8Series_Serial 系列RS232电缆

>RS X8Series_Serial 系列设备类型

>RS X8Series_Serial 系列HMI设置

>RS X8Series_Serial 系列PLC设置

请参考相关文档

3.RS X8Series_Ethernet

接线图（以下图表示从连接线的接线端所视）

>RS X8Series_Ethernet 系列RS232电缆

>RS X8Series_Ethernet 系列设备类型

>RS X8Series_Ethernet 系列HMI设置

>RS X8Series_Ethernet 系列PLC设置

请参考相关文档


理化工业

1.RKC CH402

接线图（以下图表示从连接线的接线端所视）

>RKC CH402 系列RS232电缆

>RKC CH402 系列设备类型

>RKC CH402 系列HMI设置

>RKC CH402 系列PLC设置

请参考相关文档


南京牢固

1.RIEVTECH FBD_Serial

接线图（以下图表示从连接线的接线端所视）

>RIEVTECH FBD_Serial 系列RS232电缆

>RIEVTECH FBD_Serial 系列设备类型

>RIEVTECH FBD_Serial 系列HMI设置

>RIEVTECH FBD_Serial 系列PLC设置

请参考相关文档

2.RIEVTECH LAD_Serial

接线图（以下图表示从连接线的接线端所视）

>RIEVTECH LAD_Serial 系列RS232电缆

>RIEVTECH LAD_Serial 系列设备类型

>RIEVTECH LAD_Serial 系列HMI设置

>RIEVTECH LAD_Serial 系列PLC设置

请参考相关文档

3.RIEVTECH FBD_ETH

接线图（以下图表示从连接线的接线端所视）

>RIEVTECH FBD_ETH 系列电缆

>RIEVTECH FBD_ETH 系列设备类型

>RIEVTECH FBD_ETH 系列HMI设置

>RIEVTECH FBD_ETH 系列PLC设置

请参考相关文档

4.RIEVTECH LAD_ETH

接线图（以下图表示从连接线的接线端所视）

>RIEVTECH LAD_ETH 系列电缆

>RIEVTECH LAD_ETH 系列设备类型

>RIEVTECH LAD_ETH 系列HMI设置

>RIEVTECH LAD_ETH 系列PLC设置

请参考相关文档


ONI

1.ONI PLR-S

接线图（以下图表示从连接线的接线端所视）

>ONI PLR-S 系列RS232电缆

>ONI PLR-S 系列设备类型

>ONI PLR-S 系列HMI设置

>ONI PLR-S 系列PLC设置

请参考相关文档


迈特

1.MYITER EC_Series_Modbus

接线图（以下图表示从连接线的接线端所视）

>MYITER EC_Series_Modbus 系列RS232电缆

>MYITER EC_Series_Modbus 系列设备类型

>MYITER EC_Series_Modbus 系列HMI设置

>MYITER EC_Series_Modbus 系列PLC设置

请参考相关文档


默川

1.MOCHUAN MU1H

接线图（以下图表示从连接线的接线端所视）

>MOCHUAN MU1H 系列RS232电缆

>MOCHUAN MU1H 系列设备类型

>MOCHUAN MU1H 系列HMI设置

>MOCHUAN MU1H 系列PLC设置

请参考相关文档


丰炜

1.VIGOR VH

接线图（以下图表示从连接线的接线端所视）

>VIGOR VH 系列RS232编程电缆

>VIGOR VH 系列RS232通讯电缆

>VIGOR VH 系列RS485电缆

>VIGOR VH 系列设备类型

>VIGOR VH 系列HMI设置

>VIGOR VH 系列PLC设置

请参考相关文档

2.VIGOR VS

接线图（以下图表示从连接线的接线端所视）

>VIGOR VS 系列RS232编程电缆

>VIGOR VS 系列RS232通讯电缆

>VIGOR VS 系列RS485电缆

>VIGOR VS 系列设备类型

>VIGOR VS 系列HMI设置

>VIGOR VS 系列PLC设置

请参考相关文档


VIPA

1.VIPA MPI

接线图（以下图表示从连接线的接线端所视）

>VIPA MPI 系列RS485电缆

> VIPA MPI 系列设备类型

>VIPA MPI 系列HMI设置

>VIPA MPI 系列PLC设置

请参考相关文档


串口服务

Modbus RTU系列RS232电缆

Modbus RTU系列RS485-2电缆

Modbus RTU系列RS485-4电缆

Modbus RTU支持的寄存器：

Device | Bit Address | Word Address | Format | Notes
系统内部/外部输出节点 | LB0-65535 | ------ | DDDDD | LBn对应0X（n+1） n的范围0-65535 举例：LB0对应0X1
系统内部/外部输入节点 | LB0-65535 | ------ | DDDDD | LBn对应1X（n+1） n的范围0-65535 举例：LB0对应1X1
模拟输入数据寄存器 | ------ | LW0-9998 | DDDDD | LWn对应3X（n+1） n的范围0-9998 举例：LW0对应3X1
模拟输入数据寄存器 | ------ | RW0-55535 | DDDDD | RWn对应3X（n+10000） n的范围0-55535 举例：RW0对应3X10000
数据寄存器 | ------ | LW0-9998 | DDDDD | LWn对应4X（n+1） n的范围0-9998 举例：LW0对应4X1
数据寄存器 | ------ | RW0-55535 | DDDDD | RWn对应4X（n+10000） n的范围0-55535 举例：RW0对应4X10000


以太网服务

Modbus TCP Server系列以太网电缆

交叉网线接线图：

直连网线接线图：

Modbus TCP Server支持的寄存器：

Device | Bit Address | Word Address | Format | Notes
系统内部/外部输出节点 | LB0-65535 | ------ | DDDDD | LBn对应0X（n+1） n的范围0-65535 举例：LB0对应0X1
系统内部/外部输入节点 | LB0-65535 | ------ | DDDDD | LBn对应1X（n+1） n的范围0-65535 举例：LB0对应1X1
模拟输入数据寄存器 | ------ | LW0-9998 | DDDDD | LWn对应3X（n+1） n的范围0-9998 举例：LW0对应3X1
模拟输入数据寄存器 | ------ | RW0-55535 | DDDDD | RWn对应3X（n+10000） n的范围0-55535 举例：RW0对应3X10000
数据寄存器 | ------ | LW0-9998 | DDDDD | LWn对应4X（n+1） n的范围0-9998 举例：LW0对应4X1
数据寄存器 | ------ | RW0-55535 | DDDDD | RWn对应4X（n+10000） n的范围0-55535 举例：RW0对应4X10000


元件

元件 | 图示 | 简介
位设定 |  | 改变指定位地址的状态，或者使用特定的条件（定时器或宏等）执行元件定义的功能
字设定 |  | 改变指定字地址的状态，或者使用特定的条件（定时器或宏等）执行元件定义的功能
窗口操作 |  | 改变窗口的状态，包括关闭、切换、移动等
功能键 |  | 用来设计键盘按键、键盘映射、清除事件、校准触控、保存屏幕截屏、执行宏代码、导入导出等功能
数据传输 |  | 从源地址向目标地址批量传输字地址或者位地址的值
配方传输 |  | 从HMI下载配方到PLC或者从PLC上传配方至HMI
位状态指示灯 |  | 根据指定位地址的状态来显示图片或文字内容
字状态指示灯 |  | 根据指定字地址的数值来显示图片或文字内容
数值显示 |  | 将数据以数值的形式从指定寄存器地址读取并以数值的形式显示出来
数值输入 |  | 将数据以数值的形式写入到指定寄存器地址并以数值的形式显示出来
字符显示 |  | 将数据以字符的形式从指定寄存器地址读取并以字符的形式显示出来
字符输入 |  | 将数据以字符的形式写入到指定寄存器地址并以字符的形式显示出来
位切换 |  | 结合位设定和位状态指示灯的功能，改变位状态的同时改变元件的图形和文字
字切换 |  | 结合位设定和字状态指示灯的功能，改变字状态的同时改变元件的图形和文字
清单与选框 |  | 将设定的状态数以清单的形式全部显示出来，并将当前所选择的状态由选择颜色标示出来
下拉清单 |  | 将设定的状态数以下拉清单形式显示出来，但只显示当前所选的状态，只有当使用者点选下拉清单时，才列出所有状态
文件浏览框 |  | 文件浏览框用来显示内部和外部存储设备的文件信息内容
定时器 |  | 此元件可以根据设置条件周期执行宏或者字状态或者位状态设置
定时数据传输 |  | 定时批量传输数据的功能，即当设定的定时时间到后，源地址传输相应长度的数据到目的地址
棒图 |  | 以柱状图百分比的方式显示指定字地址寄存器的数据
扇形图 |  | 以圆形柱状图百分比的方式显示指定字地址寄存器的数据
仪表 |  | 以仪表图的方式，显示字符地址中的数值
趋势图 |  | 使用连续线段的方式，显示数据采样所记录的数据
XY图 |  | 使用曲线的方式来显示多个连续地址的数据，每个数据包含 X 和 Y 的数值
数据块显示 |  | 使用折线图的方式，显示特定群组地址的数据
水平刻度 |  | 水平方向显示刻度
垂直刻度 |  | 垂直方向显示刻度
弧形刻度 |  | 以弧形显示刻度
圆形刻度 |  | 以圆形显示刻度
等宽表格 |  | 每个表格大小一样，表格可以按行，按列，按单元格选择，并改变指定字地址的值
非等宽表格 |  | 根据用户需要设定每个表格的大小，表格可以按行，按列，按单元格选择，并改变指定字地址的值
滑动块 |  | 通过按压滑块移动的方式来改变指定字地址的值
移动元件 |  | 根据指定的字地址的值来改变其显示的状态及左上角顶点在屏幕上的位置
位控制窗口 |  | 根据读取的位地址状态，在当前窗口特定的区域内，弹出指定的窗口
字控制窗口 |  | 在当前窗口特定的区域内，弹出窗口编号等于字地址值的窗口
报警与事件显示 |  | 当报警事件满足指定的条件，则显示用户报警或用户事件信息
历史数据显示 |  | 按周期时间读取指定的连续字地址值并且以表格的形式显示出来
触控触发 |  | 设定条件，按条件模拟手势触控屏
画布 |  | 分为单色和多色，单色对应本地位类型地址（画笔颜色反应位地址的ON状态），多色对应本地字类型地址（画笔颜色由字地址的值决定）
管道 |  | 模拟流动的管道，管壁和流动块有多种填充方式，流动速度和方向可按需求设定


位设定

 位设定/指示灯/标签/图形/控制设置/显示设置

当按下或弹起元件时，将改变指定位地址的状态。或者使用特定的条件（定时器或宏）执行元件定义的功能。

请点击下图设置参数了解详细信息

当设置好开关确定后，可与其他开关元件叠加使用详细请参考：开关元件叠加


字设定

 字设定/指示灯/标签/图形/控制设置/显示设置

当按下或弹起元件时，将改变指定字地址的状态。或者使用特定的条件（定时器或宏）执行元件定义的功能。

请点击下图设置参数了解详细信息。

当设置好开关确定后，可与其他开关元件叠加使用详细请参考：开关元件叠加


窗口操作

 窗口操作/指示灯/标签/图形/控制设置/显示设置

改变窗口的状态，包括关闭、切换、移动等

请点击下图设置参数了解详细信息

当设置好开关确定后，可与其他开关元件叠加使用详细请参考：开关元件叠加


功能键

 功能键/指示灯/标签/图形/控制设置/显示设置

用来设计键盘按键、键盘映射、清除数据、校准触控、保存屏幕截屏、执行宏代码、导入导出等功能

请点击下图设置参数了解详细信息。

当设置好开关确定后，可与其他开关元件叠加使用详细请参考：开关元件叠加


数据传输

 数据传输/指示灯/标签/图形/控制设置/显示设置

从源地址向目标地址批量传输字地址或者位地址的值

请点击下图设置参数了解详细信息。

当设置好开关确定后，可与其他开关元件叠加使用详细请参考：开关元件叠加


配方传输

 配方传输/指示灯/标签/图形/控制设置/显示设置

从HMI下载配方到PLC或者从PLC上传配方至HMI

PS:进行配方的传输需先建立好配方

请点击下图设置参数了解详细信息。

当设置好开关确定后，可与其他开关元件叠加使用详细请参考：开关元件叠加


位状态指示灯

 位状态指示灯/标签/图形/控制设置/显示设置

根据指定地址的状态来显示图片或文字内容。

请点击下图设置参数了解详细信息。

PS：位状态指示灯只能显示位的状态，不能改变位的状态。


字状态指示灯

 字状态指示灯/标签/图形/控制设置/显示设置

根据指定地址的状态来显示图片或文字内容。

请点击下图设置参数了解详细信息。

PS：字状态指示灯只能显示字地址的状态，不能改变字地址的状态。


数值显示

 数值显示/数字格式/字体/图形/显示设置

将数据从指定寄存器地址读取并以数值的形式显示出来

请点击下图设置参数了解详细信息


数值输入

数值输入/数字格式/键盘设置/字体/图形/控制设置/显示设置

将数据以数值的形式写入到指定寄存器地址并以数值的形式显示出来

请点击下图设置参数了解详细信息

PS：此图勾选了读写地址不同，默认是不勾选的。


字符显示

 字符显示/字符格式/字体/图形/显示设置

将数据以字符的形式从指定寄存器地址读取并以字符的形式显示出来

请点击下图设置参数了解详细信息


字符输入

 字符输入/字符格式/键盘设置/字体/图形/控制设置/显示设置

将数据以字符的形式写入到指定寄存器地址并以字符的形式显示出来

请点击下图设置参数了解详细信息

PS：此图勾选了读写地址不同，默认是不勾选的。


位切换

 位切换/切换开关/图形/控制设置/显示设置

结合位设定和位状态指示灯的功能，改变位状态的同时改变元件的图形和文字

请点击下图设置参数了解详细信息

PS：此图勾选了读写地址不同，默认是不勾选的。


字切换

 字切换/切换开关/图形/控制设置/显示设置

结合字设定和字状态指示灯的功能，改变字状态的同时改变元件的图形和文字

请点击下图设置参数了解详细信息

PS：此图勾选了读写地址不同，默认是不勾选的。


清单与选框

清单与选框/选单设置/图形/控制设置/ 显示设置

将设定的状态数以清单的形式全部显示出来，并将当前所选择的状态由选择颜色标示出来。

请点击下图设置参数了解详细信息

PS：此图勾选了读写地址不同，默认是不勾选的。


下拉清单

下拉清单/选单设置/图形/控制设置/ 显示设置

将设定的状态数以下拉清单形式显示出来，但只显示当前所选的状态，只有当使用者点选下拉清单时，才列出所有状态

请点击下图设置参数了解详细信息

PS：此图勾选了读写地址不同，默认是不勾选的。


文件浏览框

文件浏览框 / 显示设置

文件浏览框用来显示内部和外部存储设备的文件信息内容

请点击下图设置参数了解详细信息


定时器

定时器/定时器功能

执行定时功能的元件，当设定的定时时间到后可执行相应的功能如执行宏指令，设置参数，数据传输等

请点击下图设置参数了解详细信息

PS：定时器属于窗口属性，当窗口切换或者关闭时，定时器也将停止。


定时数据传输

定时数据传输/数据传输 /通知

定时批量传输数据的功能，即当设定的定时时间到后，源地址传输相应长度的数据到目的地址

请点击下图设置参数了解详细信息


棒图

棒图/扩展属性/刻度与标记/显示设置

棒图是以柱状图百分比的方式显示指定字地址寄存器的数据

请点击下图设置参数了解详细信息


扇形图

扇形图/扩展属性/刻度与标记/显示设置

扇形图是以圆形柱状图百分比的方式显示指定字地址寄存器的数据

请点击下图设置参数了解详细信息


仪表

仪表/表针与刻度/显示设置

以仪表图的方式，显示字地址中的数值

请点击下图设置参数了解详细信息

PS:显示范围标尺默认不勾选


趋势图

趋势图/通道/查询/刻度/显示设置

使用连续线段的方式，显示数据采样所记录的数据

请点击下图设置参数了解详细信息

PS：此图使用游标是勾选的，默认是不勾选的


XY图

XY图/通道/刻度/显示设置

使用曲线的方式来显示两个坐标的数据，每个数据包含 X 和 Y 的数值

请点击下图设置参数了解详细信息

PS：此图为了方便展示勾选了所有选项


数据块显示

数据块显示/通道/刻度/显示设置

使用折线图的方式，显示特定群组地址的数据

请点击下图设置参数了解详细信息


水平刻度

水平刻度/显示设置

水平方向显示刻度

请点击下图设置参数了解详细信息


垂直刻度

垂直刻度/显示设置

垂直方向显示刻度

请点击下图设置参数了解详细信息


弧形刻度

弧形刻度/显示设置

以弧形显示刻度

请点击下图设置参数了解详细信息


圆形刻度

圆形刻度/显示设置

以圆形显示刻度

请点击下图设置参数了解详细信息


等宽表格

等宽表格/控制设置/显示设置

每个表格大小一样，表格可以按行，按列，按单元格选择，并改变指定字地址的值

请点击下图设置参数了解详细信息

PS:当勾选“选中”选框后，才有“控制设置”的属性


非等宽表格

非等宽表格/控制设置/显示设置

根据用户需要设定每个表格的大小，表格可以按行，按列，按单元格选择，并改变指定字地址的值

请点击下图设置参数了解详细信息

PS:当勾选“选中”选框后，才有“控制设置”的属性


滑动块

滑动块/刻度/背景图形/滑块图形/控制设置/显示设置

通过按压滑块移动的方式来改变指定字地址的值

请点击下图设置参数了解详细信息


移动元件

移动元件/指示灯/标签/图形/显示设置

根据指定字地址的值来改变其显示的状态及左上角顶点在屏幕上的位置

请点击下图设置参数了解详细信息

PS：此图为了方便说明，勾选了所有选项


位控制窗口

位控制窗口/显示设置

根据读取的位地址状态，在当前窗口特定的区域内，弹出指定的窗口

请点击下图设置参数了解详细信息


字控制窗口

字控制窗口/显示设置

在当前窗口特定的区域内，弹出窗口编号等于字地址值的窗口

请点击下图设置参数了解详细信息


报警与事件显示

报警与事件显示/表格绘制/查询与控制/显示设置

当报警事件满足指定的条件，则显示用户报警或用户事件信息

请点击下图设置参数了解详细信息


历史数据显示

历史数据显示/表格绘制/查询/显示设置

按周期时间读取指定的连续字地址值并且以表格的形式显示出来

请点击下图设置参数了解详细信息


触控触发

触控触发/显示设置

设定条件后，按条件模拟手势触控屏

请点击下图设置参数了解详细信息


画布

画布/显示设置

分为单色和多色，单色对应本地位类型地址（画笔颜色反应位地址的ON状态），多色对应本地字类型地址（画笔颜色由字地址的值决定）

请点击下图设置参数了解详细信息


管道

管道/流动块属性/流动块图形属性/显示设置

模拟流动的管道，管壁和流动块有多种填充方式，流动速度和方向可按需求设定

请点击下图设置参数了解详细信息


工程

项目 | 图示 | 简介
HMI设置 |  | 双击弹出HMI设置窗口
窗口 |  | 双击焦点跳转到窗口（视图）且窗口标题栏变成蓝色高亮显示 [image] --〉
COM1/COM2/COM3/COM4 |  | 设置本地连接的COM口
交换串口 |  | 在不改变设备名和地址关系的前提下，通过改变端口号的映射，可以方便的将PLC设备切换到另外的串口上连接
远程HMI |  | 通过以太网，可以将本地HMI可以通过设备别名访问远程HMI内部的本地寄存器数据
远程PLC |  | 远程PLC指连接在远程HMI的COM口上的设备
网络PLC |  | 网络PLC指通过自身的网络协议直接连接到网络的PLC设备
服务 |  | 通过串口提供的服务在相应的COM口设置中添加，网络服务可以点击“新增网络服务”添加，HMI做从设备
全局设置 |  | 设置工程属性、背光与屏保、初始化、主窗口、控制音等相关属性
扩展属性 |  | 设置公共窗口位置，设置性能“禁用矢量字体边缘模糊处理”
语种设置 |  | 添加删除语种，设置下载组态工程后默认显示的语种，设置语种默认使用字体
常用字体模块 |  | 用户自定义一些常用字体模板，组态时候直接调用，方便操作
用户等级 |  | 用户设置安全等级，以及等级密码，针对整个HMI系统有效，级别越高可以操作的范围越大
任务计划 |  | 用户设置任务计划，时间到了，执行一些操作
数据采样 |  | 设置数据采样的采样方式、采样地址、数据记录等相关属性
PLC控制 |  | 切换基本窗口、报告当前窗口号、背光灯控制、执行宏指令相关的控制
报警与事件 |  | 用户预先设置报警与事件的条件、内容等相关属性
新增图形 |  | 用户可以新增图形，可以设置多个状态，不同的状态，都可以设置不同的图形
浏览图形库 |  | 打开浏览图库窗口，可以浏览当前工程图库、收藏夹、系统图库
文本库 |  | 用户定义文本库条目，分语种设置文本内容，编程时使用文本库，下拉勾选对应的文本条目，方便识别
地址标签库 |  | 用户定义地址标签库，让位地址、字地址使用用户容易识别的标签名称，编程时直接调用地址标签
声音库 |  | 用户在声音库里导入声音文件，报警等可以使用指定的声音文件
新建宏代码 |  | 新建宏指令（全面兼容标准C语言ANSIC89）满足用户执行复杂的运算、字符串处理、HMI与设备之间的数据处理等功能
新建配方 |  | 新建配方完成后，得到配方文件，跟组态工程文件一起存在HMI的Flash内部，大小跟创建的数据项有关，数据多文件大


HMI设置

通过此窗口可以查看HMI的相关信息，并可更换HMI

请点击下图设置参数了解详细信息


窗口（视图）

注意：单击选中窗口，双击打开对应的窗口；右键可查看窗口属性、新建基本窗口、删除窗口

项目 | 图示 | 简介
启动画面 |  | HMI启动时显示的画面，用户可以放公司的logo等用户期望的图片，显示一会后自动消失，然后进入组态画面
公共窗口 |  | 无论组态画面处于哪个基本窗口或弹出窗口，公共窗口都存在，公共窗口的属性均有效
新建基本窗口 |  | 新建一个组态画面中最常用的基本窗口
基本窗口 |  | 查看或修改基本窗口的属性
新建键盘窗口 |  | 新建一个组态画面中自定义的键盘窗口，类似新建基本窗口，窗口编号从30001开始
DEC数值键盘（3D） |  | 查看或修改DEC数值键盘（3D）
HEX数值键盘 |  | 查看或修改HEX数值键盘
ascii字母键盘 |  | 查看或修改ascii字母键盘
系统窗口 |  | 查看系统窗口（用户可以在指导下修改），比如，报“通讯错误”的系统窗口


COM属性

COM1/COM2/COM3/COM4

设置本地连接的COM口，可根据需要选择PLC制造商

请点击下图设置参数了解详细信息


交换串口

在不改变设备名和地址对应关系的前提下，通过端口号映射，可方便的将PLC设备切换到另外的串口上连接

请点击下图设置参数了解详细信息


远程HMI

通过以太网，可以将本地HMI可以通过设备别名访问远程HMI内部的本地寄存器数据

请点击下图设置参数了解详细信息


远程PLC

通过以太网，本地HMI可以通过IP、设备别名和端口号连接到远程HMI从而间接访问到远程PLC

请点击下图设置参数了解详细信息


网络PLC

本地HMI可以通过IP地址和端口直接访问网络PLC（网络PLC是指通过网络协议连接到网络的PLC设备）的寄存器数据

请点击下图设置参数了解详细信息


服务

服务/网络服务

可以通过串口和网络来添加服务

请点击下图设置参数了解详细信息


全局设置

通过工程-系统设置下的全局设置来设置工程属性、背光与屏保、初始化、主窗口、控制音等相关属性

请点击下图设置参数了解详细信息


扩展属性

设置公共窗口位置，设置性能“禁用矢量字体边缘模糊处理”

请点击下图设置参数了解详细信息


语种设置

添加删除语种，设置下载组态工程后默认显示的语种，设置语种默认使用字体

请点击下图设置参数了解详细信息


常用字体模块

用户自定义一些常用字体模板，组态时候直接调用，方便操作

请点击下图设置参数了解详细信息


用户等级

用户设置安全等级，以及等级密码，针对整个HMI系统有效，级别越高可以操作的范围越大

请点击下图设置参数了解详细信息


任务计划

指定星期/隔日/地址变量

用户设置任务计划，时间到了，执行一些操作

请点击下图设置参数了解详细信息


数据采样

设置数据采样的采样方式、采样地址、数据记录等相关属性（趋势图和历史数据的采样必须在这里设置）

请点击下图设置参数了解详细信息


PLC控制

切换基本窗口、报告当前窗口号、背光灯控制、执行宏指令相关的控制

请点击下图设置参数了解详细信息


报警与事件

用户预先设置报警与事件的条件、内容等相关属性

请点击下图设置参数了解详细信息


新增图形


浏览图形库


文本库


地址标签库


声音库


新建宏代码

宏

宏的典型用例（红色代表用例中使用过，每个函数都能点进去，进行查看）

用例标题 | 简介
宏_读写函数的调用 | 读写函数：读取位地址、读取字地址、读取双字地址、读取浮点数、读取连续地址、设定位地址、设定字地址、设定双字地址、设定浮点数、设定连续地址
宏的串口读写函数 | 系统函数：调用宏、获取错误码、延时函数、通讯参数设置、通讯数据输出、通讯数据输入、调试函数
宏的系统函数 | 读写函数及系统函数的运用：调用宏、读取位地址、设定位地址、取反运算、读取字地址、获取错误码、设定字地址、延时函数
宏使用随机数 | 用户可以使用系统函数和其他标准的c语言函数：延时函数、随机数函数
调用宏 | 系统函数：调用宏、设定连续地址
正弦曲线 | 读取字地址、角度弧度运算、正弦函数、设定浮点数、设定字地址

宏窗口的简单介绍


新建配方

配方的索引可以看成是门牌号。从PLC上传配方，下载配方到PLC，都是通过索引实现的。索引变了，值也跟着改变。

通过索引，可以使用少数地址，处理一大片地址区域的数据。用户只需要改变索引，简单操作，就可以把有效的数据，

保存到配方，等需要的时候，又可以把配方的数据，传输到指定的寄存器。配方是一种方便用户处理大量数据的方式。

用例标题 | 简介
配方模板 | 简单介绍配方的基本要素，索引改变了，配方的数据也跟着改变
蛋糕配方 | 以配方模板作为参考，按照蛋糕的配方，举例说明怎样使用配方
清除配方 | 宏实现赋初值，配方传输，详细说明清除当前配方、清除全部配方

一般属性/数据项


文件

项目 | 图示 | 简介
新建工程 |  | 建立新的工程并选择适合的 HMI 、设置相应的通讯连接
打开工程 |  | 打开现有的工程
关闭工程 |  | 关闭当前的工程
保存工程 |  | 保存当前的工程
工程另存为... |  | 使用新的路径、新的名称另存当前的工程（之前的工程还是存在）
工程密码保护 |  | 给工程加密且设置过密码的工程下次打开时必须输入正确的密码才能打开工程
最近工程(10个) |  | 显示最近打开的10个工程路径且允许点击后直接打开相应的工程
退出 |  | 退出当前的软件


视图

项目 | 简介
工程 | 打开 /关闭工程视图（树型结构且方便修改HMI设置、窗口、通讯连接、系统设定、库、宏、配方）
窗口 | 打开/关闭窗口视图（树型结构且方便修改启动画面、公共窗口、基本窗口、键盘窗口、系统窗口）
错误 | 打开/关闭错误视图（收集错误信息并显示于此）
引用 | 打开/关闭引用视图（收集引用信息并显示于此）
大纲 | 打开/关闭大纲视图（详细列出了窗口上所有的元件）
输出 | 打开/关闭输出视图（输出编译信息并显示于此）
恢复默认视图 | 重新调整软件的视图布局且恢复成默认状态
当前显示语种 | 选择当前显示语种且前面打勾的语种为当前显示的语种
当前状态 | 选择当前状态且前面打勾的状态为当前状态


编辑

项目 | 图示 | 简介
撤销 |  | 撤销本次的动作且回到上一次
恢复 |  | 恢复最近一次撤销的动作
查找/替换 |  | 设置指定的查找范围去查找位地址/字地址/文本或替换成新的位地址/字地址/文本
剪切 |  | 移除所选取的元件并暂时存放于剪切板
复制 |  | 复制所选取的元件并暂时存放于剪切板
多重复制 |  | 设置复制范围、数量、间隔、方向并按照规律让地址自动变换从而得到多个元件（支持多个元件作为整体进行复制粘贴且地址依次改变）
粘贴 |  | 将剪切板的内容粘贴到工程上
删除 |  | 从工程里删除所选取的元件
微调 |  | 向左/右/上/下移一格
对齐 |  | 多个元件选中才有效且让其他元件与元件周边8个实心圆圈的元件左对齐/垂直中线对齐/右对齐/上对齐/水平中线对齐/下对齐
尺寸 |  | 多个元件选中才有效且让其他元件与元件周边8个实心圆圈的元件等宽/等高/相同尺寸
层次 |  | 多个元件选中才有效且让元件周边8个实心圆圈的元件置顶/置底/向前一层/向后一层或让多个元件水平间距相同/垂直间距相同
颜色相同 |  |
组合 |  | 将多个元件组合成一个整体
取消组合 |  | 将组合成整体的元件打散，恢复成个别元件
水平居中 |  | 让选中的元件处于窗口水平方向的中心位置
垂直居中 |  | 让选中的元件处于窗口垂直方向的中心位置
锁定 |  | 锁定元件的位置且使其不能被改变尺寸或拖拽位置
解锁 |  | 让锁定的元件解锁且恢复到可以被改变尺寸或拖拽位置


窗口

项目 | 图示 | 简介
新建窗口 |  | 建立新的窗口且允许用户设置窗口编号/宽高等基本属性以及其他功能
删除窗口 |  | 删除选择的窗口
当前窗口属性 |  | 设置当前窗口属性且允许用户设置窗口编号/宽高等基本属性以及其他功能
编辑启动LOGO画面 |  | 用户可以设置HMI上电后工程的启动LOGO画面（进入启动画面后双击窗口）
显示公共窗口 |  | 显示/隐藏公共窗口且方便用户查看基本窗口上显示/隐藏公共窗口的效果
显示底层窗口 |  | 显示/隐藏底层窗口（3个底层窗口同时有效）且方便用户查看基本窗口上显示/隐藏底层窗口的效果
跳转到目标窗口 |  | 当选择的元件有换页功能时（开关元件的窗口操作选择了弹出窗口或切换基本窗口功能时/位控制弹出窗口元件）跳转到目标画面可用
显示网格 |  | 显示网格且方便用户查看元件是否对齐
网格对齐 |  | 使用网格对齐属性可使元件绘制更加容易
对齐线对齐 |  | 勾选后元件支持对齐线对齐方式
网格设置 |  | 网格属性设置且用户可以自定义网格颜色及间隔
窗口缩放 |  | 窗口按比例缩放且缩放比例支持50%、75%、100%、125%、150%、175%、200%


绘图

项目 | 图示 | 简介
直线 |  | 画直线
折线 |  | 画折线
矩形 |  | 画矩形（正方形）
多边形 |  | 画多边形
椭圆 |  | 画椭圆（圆）
弧 |  | 画弧
扇形 |  | 画扇形
扇环 |  | 画扇环
静态图片 |  | 选择图片放置到窗口上
静态文本 |  | 在窗口上加入文字且用户可以设置字体、颜色、尺寸等相关属性


库

项目 | 图示 | 简介
地址标签库 |  | 允许用户在地址标签库里预先定义常用的地址且增加地址的可读性同时减少反复操作
文本库 |  | 允许用户在文本库里预先定义文本（多语种）条目且增加文本的可读性同时减少反复操作
声音库 |  | 用户使用声音文件时需要在这里导入并显示声音文件的相关信息
新增图形 |  | 新增图形（多状态）并保存到图形库中
浏览图形库 |  | 浏览图形库并能在当前工程图库/收藏夹/系统图库之间进行相关操作


宏指令

宏

项目 | 图示 | 简介
新建宏指令 |  | 新建宏指令（全面兼容标准C语言ANSI C89）满足用户执行复杂的运算、字符串处理、HMI与设备之间的数据处理等功能
编辑宏指令 |  | 用户可以新增地址并借助系统提供的读写函数/系统函数/运算符编辑宏指令得到期望的结果


设置

项目 | 图示 | 简介
HMI设置 |  | 用户查看 HMI型号及屏幕尺寸、分辨率等HMI相关描述同时允许修改以太网设置
通讯设置 |  | 用户设置本地连接/远程连接/服务同时HMI具有通讯设置的属性并能与设备进行通讯产生数据交互
系统设置 |  | 用户进行全局设置、（设置）扩展属性、语种设置、常用字体模板、用户等级、任务计划、数据采样、PLC控制、报警与事件
选项 |  | 提供一些特殊的选项如自动加载上次关闭的工程等


工具

项目 | 图示 | 简介
编译 |  | 编译工程首先自动保存并确定是否存在错误同时在工程的文件夹中生成bin目录及相关文件以备模拟或下载使用
全部编译 |  | 全部编译首先自动保存当前工程改动并全部强制重新编译（不管文件是否改动）
清除编译结果 |  | 清除会导致bin目录被强制删除同时temp目录也将被强制删除（这样模拟阶段生成的配方和数据记录等文件都将被清除）
下载 |  | 首先自动调用一次编译过程接着生成upload目录及相关文件以备反编译使用然后打包相关文件并调用FSTools工具下载工程（支持USB及网络下载）
打包到磁盘 |  | 首先自动调用一次编译过程接着调用打包到磁盘工具并把打包的文件放到指定目录
上传 |  | 直接调用FSTools工具上传工程（支持USB及网络上传）
反编译 |  | 直接调用FSTools工具将指定文件反编译成工程文件
离线模拟 |  | 离线模拟首先自动保存当前工程并调用FSGui模拟器同时生成bin目录用来存储配方和数据记录等文件


帮助

项目 | 图示 | 简介
检查更新 |  | 软件支持自动升级且检查更新会自动比对当前的软件版本若是旧版本则提示升级
联系我们 |  | 检测用户操作系统上是否安装了qq应用且自动弹出qq聊天对话框方便用户联系我们
关于 |  | 显示当前软件的版本信息及公司名称等


周期式

定时采集数据


暂停控制

通过设定位地址控制暂停采样，位地址为1时暂停，为0时继续采样


清除控制

通过设定位地址控制清除采样数据，位地址为ON时清除，清除后自动复位


游标

通过移动游标可以查看每个采样点的详细信息

PS：通过点击XY图来移动游标的位置


触发式

  • 位：以位地址为判断条件，触发采样

  1. ON<—>OFF：当指定位寄存器地址状态变化时，触发采样

  2. ON—>OFF:当指定位寄存器地址状态由ON 变为OFF 时，触发采样

  3. OFF—>ON:当指定位寄存器地址状态由OFF 变为ON 时，触发采样

  4. ON—>OFF&自动复位:当指定位寄存器地址状态由ON 变为OFF 时，触发采样，触发后自动将指定位寄存器状态置为OFF。

  5. OFF—>ON&自动复位:当指定位寄存器地址状态由OFF 变为ON 时，触发采样，触发后自动将指定位寄存器状态置为ON。

  • 字：以字地址为判断条件，触发采样

通过读取值与A(1)、B（1）的比较，作为判断条件，当满足判断条件时触发采样

判断方式有：>、<、>=、<=、==、!=，同时可以通过AND、OR增加判断条件。

例：读取值>A(1) AND 读取值<B(1)时触发。


数据点数

设置需要采样的点数


X轴刻度

设置X轴的主刻度、次刻度、轴、网格和标记的显示


Y轴刻度

设置Y轴的主刻度、次刻度、轴、网格和标记的显示


刻度

设置XY图的刻度显示

请点击下图设置参数了解详细信息


背景色

设置背景色和刻度区颜色


画面

  • 画点：设置画点颜色、画点大小、画点类型

  • 连接线：设置连接线的颜色、线条宽度、线条类型

  • 向X轴方向投影：按照线条的颜色，向X轴方向投影

  • 向Y轴方向投影：按照线条的颜色，向Y轴方向投影

  • X轴最小值：可通过常量或者变量来设置。如通道地址值低于最小值，按最小值显示

  • X轴最大值：可通过常量或者变量来设置。如通道地址值高于最大值，按最大值显示

  • Y轴最小值：可通过常量或者变量来设置。如通道地址值低于最小值，按最小值显示

  • Y轴最大值：可通过常量或者变量来设置。如通道地址值高于最大值，按最大值显示


通道

设置要显示的XY图曲线的数据

请点击下图设置参数了解详细信息


通道数

范围1~16，可以同时采样多个通道的数据


通道设置

选择X地址和Y地址

例：采样点数为10，当X地址选为LW0后，Y地址会自动变为LW1。并且最下方会出现注释，见下图：

当勾选Y地址前面的选框 [image] 时，可根据需要设置相应的地址

例：采样点数为10，如X地址选为LW0，Y地址选为LW10，那么下方出现注释：


显示范围标尺

  • 上下限：通过变量和常量两种形式设置，下限设置比上限设置小

  • 颜色：表针将利用下限与上限设定的值和一般属性页签的指定字符地址内所读取的数值，按照颜色设定显示正常区的颜色、朝下限的颜色、超上限的颜色

  • 宽度：内环与外环之间的距离

  • 自定义扇环外半径：设置外环的半径

总体实例：当最小值为0，最大值为100。下限为20，上限为80.扇环宽度为10，扇环外半径为40。正常区颜色为绿色，超下限颜色为蓝色，超上限颜色为红色

如下图所示


最大最小值

最大值和最小值用来设定表针欲显示的数值范围

表针将利用最小值 与最大值设定的值和一般属性页签中指定字符地址内所读取的数值，换算指针的指示位置

例：读取地址为LW0=20，表盘为上半圆，最大值为100，最小值为0.此时显示

下图：


表盘

  • 圆形（表针向上）：圆的0刻度在上，起始指针的位置在上

  • 圆形（表针向下）：圆的0刻度在下，起始指针的位置在下

  • 上半圆：顺时针0~180度的圆，0度对应最小值，180度对应最大值

  • 下半圆：顺时针180~360度的圆，180度对应最小值，360对应最大值

  • 弧形（自设定）：可根据需要，选择弧形，按顺时针方向从起始角到终止角


位置

可以有内侧、居中、外侧


刻度

设置主刻度、次刻度、轴、标记的显示


表针与刻度

设置仪表元件的表针显示与刻度显示

请点击下图设置参数了解详细信息


刻度排序反向

默认刻度值为顺时针从小到大，选择此项后改为顺时针从大到小


显示刻度

设置刻度的颜色、线条宽度、线型


表针设置

设置表针颜色、长度、宽度


表针轴心

设置表针轴心的颜色、半径


位切换开关

 切换开关

设置切换开关的动作、开关类型、和文字显示。

请点击下图设置参数了解详细信息


执行设置

  • 开：指定位地址的状态为ON

  • 关：指定位地址的状态为OFF

  • 取反：指定位地址的状态为反向

  • 复位：按下动作，将指定位地址的状态置ON，但松开按钮后，状态恢复为OFF


读写地址不同

读取和写入的地址不一样

例：读取地址为LB0，写入地址为LB10

当LB0为ON时，此元件将读取LB0的值显示为ON。当改变此元件状态为OFF时，LB10的状态变为OFF，此元件的状态还是ON。


使用变量窗口号

设置字地址，弹出窗口号等于字地址值的窗口


弹出窗口编号

选择需要弹出的窗口


触发位

设置位地址，当位地址为ON或者OFF时触发弹出窗口


附带窗口控制条

设置弹出窗口的控制条，可以有关闭按钮和标题，点击 [image] 输入标题内容


正逻辑

正逻辑：状态0为OFF，状态1为ON


负逻辑

负逻辑：状态0为ON，状态1为OFF


闪烁方式

  • 文字闪烁：对应标签属性里设置的文字，文字按照闪烁的频率从无到有，按照闪烁频率不断闪烁

  • 图片闪烁：对应图形属性里设置的图片，图片按照闪烁的频率从无到有，按照闪烁频率不断闪烁


闪烁频率

以0.1S为单位，不断闪烁图片和文字


使用地址索引

用数值输入元件，选择字地址，控制此元件的地址改变。

例：地址设为LB0，索引地址LW0。那么元件地址为LB(0+LW0)


使用字寄存器的按位索引

PS：1个字寄存器可以有16个位地址


使用标签

通过下拉框可以选择地址标签库里的地址，或可以通过点击 [image] 设置地址标签。


动作

  • 按下：当按钮按下时发出指令

  • 弹起：当按钮弹起时发出指令


执行设置

  • 开：指定位地址的状态为ON

  • 关：指定位地址的状态为OFF

  • 取反：指定位地址的状态为反向

  • 复位：按下动作，将指定位地址的状态置ON，但松开按钮后，状态恢复为OFF

  • 设ON脉冲：指定位地址的状态置ON，待脉冲过后为OFF

  • 设OFF脉冲：指定位地址的状态置OFF，待脉冲过后为ON


特殊寄存器

特殊寄存器地址，用来设置网络、硬件、键盘相关的设置。

PS：通过软件点击此按钮可以查看各个特殊地址的功能。


设备

根据连接的PLC选择设备类型


开关元件叠加

开关元件叠加使用

叠加元件有两种方式：

1、通过建立开关时的通用窗口：

可以通过下面的追加功能，选择：位、字、窗口操作、功能键、数据传输、配方传输。当选择多个元件时，

说明：列表中的元件会 从上到下依次触发，但完成时间没有确定的先后关系

2、用户可自己组放多个开关元件进行叠加使用，只要把所建立好的开关元件，在窗口布局上叠放在一起即可

说明： 叠加的元件会 从上到下依次触发，但完成时间没有确定的先后关系


语种无关

当改变语种时，标签内容将不受影响


使用图形

不勾选此图形时，元件将无背景图片


图形

按照状态给每个元件加上图片背景

请点击下图设置参数了解详细信息


导入

点击“导入”后，将可以通过图库选择图片进行导入到“当前工程图库”。图库内容详见：图库模块


收藏

收藏当前选择的图形，可在工程-浏览图库里看到


新增图形

点击新增图形后，弹出新建图形的窗口


用户可改

通过图库-新增图形，用绘图元件绘制图形时，如果勾上用户可改后，这里可以对图形进行边框和填充的更改


编辑图形

点击编辑图形后，将在窗口画布位置弹出编辑图形的窗口，如下图：

PS：点击编辑图形后，关闭图形窗口，即可看见


位寄存器|字寄存器

位寄存器：请点击参考位状态指示灯

字寄存器：请点击参考字状态指示灯


位数

范围2~32，根据需要选择


指示灯

根据指定地址的状态来显示图片或文字内容。

请点击下图设置参数了解详细信息。


数据格式

  • 多位组合：使用多位组合的方式，通过条件判断显示相应的状态

  • 无符号数：位数为n,那么组合值为

  • 有符号数：位数为n,那么组合值将根据补码为

  • 起始地址：起始地址与位数密不可分，如起始地址为LB0，位数为2，那么通过从高位到低位LB1，LB0，将形成组合

实例：位数为2，通过公式计算得出组合值的范围为0~3，有符号数范围为-2~1

位数：2 | 起始地址LB0那么 LB1、LB0，那么组合就有：00,01,10,11 | 无符号数 | 有符号数
 |  | 0 ： 00 | -2 ： 10
 |  | 1 ： 01 | -1 ： 11
 |  | 2 ： 10 | 0 ： 00
 |  | 3 ： 11 | 1 ： 01


显示模式

  • 寄存器模式：包括位寄存器、字寄存器、多位组合

  • 自动循环：如选择自动循环，则按照频率设置，以毫秒为单位不断切换状态，见下图


始终有效

元件始终保持有效功能


安全设置

  • 最少按压时间：需要按下元件不松，等待设定的时间到，元件才执行所设的功能

  • 操作前确认：点击元件后，弹出下图，是否确定执行

  • 操作最小时间间隔：两次操作的中间间隔时间，设定时间未到，执行无效


控制设置

控制元件的写入安全，增加写入通知

请点击下图设置参数了解详细信息


条件使能

条件使能：满足条件时元件功能正常使用，可以通过设置等级控制、逻辑控制设置条件

  • 等级控制：当用户等级高于或等于指定等级后，元件可使用

  • 逻辑控制：设定逻辑，如LB0=ON，满足时可使用


通知设置

设置写入前、写入后执行通知操作

  • 通知位地址：改变位地址状态，如让LB0为ON

  • 通知字地址：改变字地址的值，如让LW0的值为1

  • 触发宏指令：执行宏指令，选择设置好的宏，或通过 [image] 来修改或编辑宏


 显示设置

设置元件的位置，即条件显示元件

请点击下图设置参数了解详细信息


一直显示

元件始终可见


条件显示

满足条件显示，可以通过设置等级控制、逻辑控制、或者同时满足等级和逻辑控制时可见

等级控制：当用户等级高于或等于指定等级后，元件可见

逻辑控制：设定逻辑，如LB0=ON，满足时可见


使用文本库

可以通过 [image] 按钮来设置文本库的内容，勾选使用文本库后，标签内容根据语种将已经设置好的文本库里的条目填入标签

PS：一般常用的词条，可以通过文本库，编辑好备用


使用标签

通过输入框，输入每个状态对应的文本


保存标签内容到文本库

点击此按钮后，将弹出输入窗口，要求文本库词条名称，确定后把该元件编辑好的标签内容按照语种、状态对应保存到文本库里


全部

点击此按钮后，所有标签内容都变成当前输入的内容


当前显示语种

可通过 [image] 来设置需要的语种，通过下拉框，可以选择需要编辑的语言


所有属性

文字的所有属性可以选择应用到所有状态、语种


所有状态

点击此按钮后，所有状态的标签内容将改为当前输入的标签内容


所有语种

点击此按钮后，所有语种的标签内容将改为当前输入的标签内容


标签

设置每个状态的文字显示，切换状态时文字也跟着变化

请点击下图设置参数了解详细信息


走马灯

文字可以通过走马灯的方式，按设置的方向，在元件范围内进行移动，移动的步长和速度可自由设置


保存屏幕截图到扩展内存

  • 保存屏幕截图到扩展内存：当按下功能键时，可将当前画面的内容以.bmp 的图片格式保存到外部存储设备中，以便于打印或查看 HMI 的运行画面情况。（且仅支持带 USB HOST 或 SD 卡槽的 HMI。）


导入/导出

  • 导入/导出：当按下功能键时，可实现工程或配方数据的导入导出。

PS：此功能需配合文件列表框元件一起使用，且仅支持带 USB HOST 或 SD 卡槽的 HMI。


执行宏指令

选择此项功能，当按下功能键时，可执行指定的已建立的宏指令。

或者通过 [image] 进入宏设置，重行编辑宏。


清除

  • 清除事件：当按下功能键时，可按事件组别清除报警事件

  • 清除全部配方：当按下功能键时，将清除所有配方

  • 清除RW：当按下功能键时，清除所有掉电保存的RW地址

  • 清除全部历史数据：当按下功能键时，清除全部历史数据


触控校准

  • 触控校准：当按下功能键时，系统可进入屏幕触控校准画面，用户可对 HMI 进行屏幕触控校准。

PS：通过功能键“校准触控”功能来校准 HMI 屏幕触控的精准度，无需设置 HMI 拨码开关。


键盘功能

  • 回车：与键盘的输入(Enter)功能相同

  • 退格：与键盘的后退删除(Backspace)功能相同

  • 清除：清除目前对“数值输入”与“文字输入”元件已输入的内容

  • 取消：取消输入操作，与键盘的 Esc 功能相同

  • UNICODE：设定对“字符显示”与“字符输入”元件的输入字符，可选择 0，1，2，……数字键或 a，b，c，……等 ASCII 码或 Unicode 字符

  • 移动光标：按设定方式移动光标，包括上移、下移、左移、右移、行首、行尾、首位、尾位。该功能只对记输入元件有效。

  • 选定文本：设置文本内容选定的操作，包括开始选定、结束选定。此功能只对输入元件有效

  • 文本操作：设置对文本内容的操作，包括复制、剪切、粘贴。此功能只对输入元件有效

  • 映射键盘：选择此功能，可为 HMI 自带按键 F1~F8 映射对应的功能，包括向前、向后、ESC、Enter 等。此功能只对某些特定 HMI有效


寄存器控制查询方式

选择寄存器控制查询方式，设置地址后见下图：


查询

设置历史数据显示的查询方式

请点击下图设置参数了解详细信息


刻度

设置主刻度、次刻度、刻度的显示位置、轴、标记

位置：

刻度反向排序：


不循环

加或者减到最后一个状态后，将不会回到第一个状态重新循环加或减


字切换开关

切换开关

设置切换开关的动作、开关类型、和文字显示。

请点击下图设置参数了解详细信息


开关类型

  • 加：按照状态的索引号递加,同时每个状态对应的值写入到一般属性里设置的字地址里

  • 减：按照状态的索引号递减,同时每个状态对应的值写入到一般属性里设置的字地址里

PS：加、减到最后一个状态，会重新从第一个状态重新开始


索引对应值

每个状态对应一个索引号和值，这个值将根据状态写入到一般属性里设置的字地址里

PS：每个状态都可以设定一个标签


显示错误状态

当字地址的值不满足条件判断的值时，指示灯的状态显示为错误的状态。


保持当前状态

当字地址的值不满足条件判断的值时，指示灯的状态不变，保持当前的状态。


条件位

用作显示字地址的每个位的状态

例：字地址为LW0，那么LW0.1，LW0.2，那么可以通过条件判断，来显示每个位地址的状态

PS：其他设置和位状态指示灯一样，每个字地址可以有16个位


条件范围

根据字地址值的范围，显示状态的内容。

通过读取值与A(1)、B（1）的比较的结果作为判断条件，当满足判断条件时触发采样。

判断方式有：>、<、>=、<=、==、!=同时可以通过AND、OR增加判断条件。

例：读取值 >A(1) AND 读取值 <B(1) 时触发。


状态数

范围1~254，每一个状态对应一个字地址的值，字地址的值不能重复。


错误通知

当选择的字地址为错误状态时，设置位地址为ON，否则为OFF。


仅ASCII字符

若勾选，将以 ASCII格式显示数据


使用UNICODE

若勾选，将以 UNICODE 格式显示数据


高低字节互换

单字组成双字时，高低字节排序测试，低位在前（小端）高位在前（大端）

例：见表格

双字LW0 | 0x12345678
高低端 | 低位在前（小端） | 高位在前（大端）
前 字 LW0 | 0x5678 | 0x1234
后 字 LW1 | 0x1234 | 0x5678

PS：只有勾选ASCII码时才有高低字节互换


字符格式

设定字符显示的总行数、显示行数、每行显示的个数、以及字符设定的高级设置。

请点击下图设置参数了解详细信息


字符设定

可以设置更高级的字符显示


读写地址不同

读取和写入的地址不一样

例：读取地址为LW0，写入地址为LW10

当LW0为A时，此元件将读取LW0的值显示为A。当向此元件输入B时，LW10的值变为B，此元件的显示值还是A


启用循环

  • 启用循环：重复之前的执行设置。

  • 启用到限转向：执行加运算时，到达最大数后变为减运算。执行减运算时，到达最小数后变加运算


执行设置

  • 加：指定字地址内的数值将加上 [加数] 中的设定值，但加的结果将不超过 [上限] 中的设定值。

  • 减：指定字地址内的数值将减去 [减数] 中的设定值，但减的结果将不超过 [下限] 中的设定值。

  • 递加：当按压元件时，指定字地址内的数值将加上 [递加] 中的设定值，但递增的结果将不超过 [上限] 中的设定值。

  • 递减：当按压元件时，指定字地址内的数值将减去 [递减] 中的设定值，但递减的结果将不超过 [下限值] 中的设定值。

  • 设置常数：设定的常数将写入指定字地址中。

  • 设置字符串：设定的字符串将写入指定字地址中。

  • 按位设置数值：按照设定好的数字位数加或减。

  • 逻辑操作：将设定好的字地址的值与操作数与、或、异或、非运算。


特殊寄存器

特殊寄存器地址，用来设置网络、系统、用户等级密码、输入键盘、文件浏览相关的设置

PS：通过软件点击此按钮可以查看各个特殊地址的功能


位状态改变

设定位地址与触发方式，当条件符合触发

  • ON<—>OFF：当指定位寄存器地址状态变化时，触发

  • ON—>OFF:当指定位寄存器地址状态由ON 变为OFF 时，触发

  • OFF—>ON:当指定位寄存器地址状态由OFF 变为ON 时，触发

  • ON>OFF& “自动复位”当指定位寄存器地址状态由ON 变为OFF 时，触发，触发后自动将指定位寄存器状态置为OFF

  • OFF>ON& “自动复位”当指定位寄存器地址状态由OFF 变为ON 时，触发，触发后自动将指定位寄存器状态置为ON


关闭条件判断

见下图，可自由发挥，增加条件。如：当LB0为ON时停止执行定时器功能


到达指定次数停止

可设置1~65535次。前提是当前窗口不关闭，当前窗口关闭，将提前结束

PS：一种情况例外：定时器的触发条件为关闭时必须执行一次


字值改变

字值改变：设定字地址，当字地址的值发生改变时执行


定时器在窗口关闭时停止

此为默认选项，当前窗口一旦关闭，定时器就停止

PS：选择其他两个关闭条件时，当窗口关闭时，定时期就停止


延迟

默认不勾选，勾选后可设置延迟N个周期（毫秒）执行


执行周期

可设置N(1~65535) x0.1S，表示每N毫秒执行一次


条件判断

见下图，可自由发挥，增加条件。如：当LB0为ON时执行定时器功能


窗口关闭时触发

当定时器元件所在的窗口关闭时触发执行，并且只能执行一次


窗口打开时触发

此触发方式，定时器在窗口初始化就触发执行


定时器功能

设定定时器的执行功能如执行宏指令，设置参数，数据传输等

请点击下图设置参数了解详细信息

PS：定时数据传输属于窗口属性，当窗口切换或者关闭时，数据传输也将停止。


状态设置位

将设置好的位地址置ON或OFF，或者周期切换


状态设置字

可将设置好的字地址执行：加、减、设置常数运算

  • 加：指定字符地址内的数值将加上 [加数] 中的设定值，但加的结果将不超过 [上限] 中的设定值

  • 减：指定字符地址内的数值将减去 [减数] 中的设定值，但减的结果将不超过 [下限] 中的设定值

  • 设置常数：设定的常数将写入指定字符地址中

启动循环：重复之前的执行设置

启动到限转向：执行加运算时，到达最大数后变为减运算。执行减运算时，到达最小数后变


数据传输

从源地址向目标地址批量传输字地址或者位地址的值

请点击下图设置参数了解详细信息


通知

当状态改变时，设置位地址置ON或OFF，也可设置字地址值或触发宏指令。


角度

默认左边起始角为0度，右边终止角为180度，顺时针绘制弧形刻度。也可按需要设置起始角和终止角

例：起始角30度，终止角270度，见下图


方向

  • 顺时针：扇形的延伸方向为顺时针

  • 逆时针：扇形的延伸方向为逆时针


角度

  • 内外环比例：内外环比例越大，内环就越靠近外环，反之比例越小，内环就越远离外环

  • 起始角：按顺时针的角度绘制扇形图至“终止角”


上移下移

当选择标题栏条目后，这两个选项为可选，可以改变标题栏的排序


使用标签

  • 勾选使用标签后，用户可以点击标题栏设置框进行输入

  • 如不勾选使用标签则可以选择使用文本库条目


列表字体

勾选“列表字体与标题一致”后，列表字体将于标题栏字体一致

不勾选“列表字体与标题一致”，可通过点击 [image] 设置


当前报警事件

只显示当前触发的报警事件，不显示恢复和确认状态

PS：计数只针对“当前报警与事件”的显示


报警与事件登陆

点击可设置报警与事件，具体参见：系统设定-报警与事件


报警与历史事件显示

用表格的形式同时多行显示报警与事件，包括当前事件与历史事件，每个状态的信息都将保留


报警条（走马灯）

以条状表格的形式，将报警内容以单行走马灯的方式滚动显示：

当选择走马灯时，一般属性里将会有以下设置，可以控制走马灯的方向、步长、速度


报警状态

此设置只对“报警与事件历史”有效


排序方式

按日期：最新的事件显示在最上面

按级别：高等级的事件显示在最上面


日期时间

设置日期和时间的格式


显示分组

用户可根据需要按组显示报警与事件

PS：新建报警与事件时，用户可将报警与事件分组，一共有32个组可供选择


显示语言

通过下拉框，选择需要编辑的语言，增加语种可通过点击 [image] ，具体参考系统设定-语种设置

PS：此语种设置是对标题栏的设置


浏览方式

滚动：显示滚动条，可以通过拖动滚动条来控制数据的显示

划屏：通过在元件数据区域滑动来控制数据的显示


行列间距

设置报警与事件表格的行和列的间距，这里的间距是除了文字的距离

PS：间距为0时代表正好显示文字的宽度


超出内容

内容超出表格的宽度时，可以截断或者滚动。如果设置为滚动可以设置滚动的步长和速度


选中

  • 可设定单击选中、或双击选中

  • 选中报警与事件条目后，条目的背景颜色为此设定的颜色


寄存器控制查询方式

选择寄存器控制查询方式，设置地址后见下图解释


按分组

选择按分组，设置地址后见下图解释


按时间段

选择按时间段，设置地址后见下图解释


按级别

选择按级别，设置地址后见下图解释


按编号

选择按编号，设置地址后见下图解释


按顺序查询

选择按顺序查询后，设置地址后见下图解释


查询与控制

设置报警与事件显示的查询方式

请点击下图设置参数了解详细信息

PS:只有报警与事件历史由此设置


表格绘制

设置报警与事件显示、历史数据显示的表格样式

请点击下图设置参数了解详细信息


表格设置

设置表格的背景色、标题栏的背景色、外框、分割线


密码

以密码*号显示数值


小数位

根据数据类型的不同，小数位的位数限制也会不同

PS：整数位+小数位=数据类型最大值的位数


 数字格式

可以设置字地址数值显示、数值输入的数值状态。

请点击下图设置参数了解详细信息


数据上下限

最小值：根据数据类型与整数位数来决定，同时可以设置小于下限时设置不同颜色闪烁。

最大值：根据数据类型与整数位数来决定，同时可以设置大于上限时设置不同颜色闪烁。


数据类型

数据类型：16位无符号数、16位有符号数、32位无符号数、32位有符号数、16位BCD、32位BCD、单精度浮点数、16位16进制数、32位16进制数、16位2进制数、32位2进制数、单精度浮点数


整数位

根据数据类型的不同，整数位的位数限制也会不同。

PS：整数位+小数位=数据类型最大值的位数。


比例转换

点击说明按钮即可查看

PS：比例最小值必须小于比例值最大值，可以通常量或者变量来设定，同时最大、最小值的范围与数值上下限保持一致。


缩放

点击说明按钮即可查看

增益：可以通过常量和变量的方式设定，最小为1，最大值字符地址的最大值保持一致。

偏移量：可以通过常量和变量的方式设定，最大最小值与字符地址的最大最小值保持一致。


读写地址不同

读取和写入的地址不一样

例：读取地址为LW0，写入地址为LW10

当LW0为1时，此元件将读取LW0的值显示为1。当向此元件输入2时，LW10的值变为2，此元件的显示值还是1


从常用字体模板导入

通过常用字体模板可以预设常用字体样式，通过此按钮选择使用


图形字体

图形字体：将整个字符串当做一个整体，然后截取成为一个位图，保存到工程中

缺点：占用内存容量大。PS：由于字符串使用位图来保存，因此会占用较大的空间

优点：1、支持使用当前操作系统安装的所有字体

2、显示效果佳


大小

设置字体的当前大小，可以选择8—72。 支持粗体、斜体。


 字体

可以设置字地址数值显示字体样式

请点击下图设置参数了解详细信息


字体位置

可以对每个标签内容分别进行文本的位置设置


对齐方式

文字在元件中的位置，可以设置：靠左，居中，靠右


矢量字体

  • 矢量字体的缺点：仅支持当前操作系统安装的 TrueType 类型字体（ttf 格式）

禁用“矢量字体边缘模糊处理”时字体显示会有些许毛刺，对比效果如下图所示：

PS：禁用“矢量字体边缘模糊处理”，在工程树/扩展属性下设置

  • 矢量字体的优点：

  1. 占用内存容量较小。通过在字体文件中截取字模的方法，可以充分减少字体文件的大小。同一文字的在同字体中不论大小、颜色、粗斜体只用截取一个字模信息

  2. 字号齐全且可自由设置不变形

  3. 支持多行文本对齐

  4. 文本库支持使用矢量字体


等宽

无论是数字、字母、汉字等，每个文字宽度都相等


设置字体

设置字体，支持当前操作系统安装的所有字体类型，比如微软雅黑。


颜色

可以通过下拉框选择，也可以通过吸管获取颜色


高级

通过高级可以设置更详细的文字格式，点击高级后弹出下图：

允许按语种和状态分别设置标签位置：可以对每个标签内容分别进行文本的位置设置


位控制

设定位地址控制输入状态


使用弹出键盘

选择弹出的键盘类型，默认软件自带四种，用户也可根据需要，通过功能键-键盘功能，自己设置键盘样式


使用输入次序功能

一般多个输入元件时，才设置此选项，此选项可以按照设定的输入顺序依次不间断地对输入元件进行输入

  • 输入完成后不再按次序输入：勾选此选项的输入元件，输入完成后，将停止依次输入功能

  • 输入次序：根据群组里的设置，每组的数值输入元件，按从小到大的次序，进行依次不间断的输入

  • 群组：可以对输入元件进行分组，每组按照从小到大的次序依次输入


触控

点击输入元件即弹出键盘窗口


键盘弹出位置

  • 自动调整位置：根据触控点的位置弹出键盘

  • 弹出键盘位置：选择弹出键盘的位置

  • 指定位置：指定弹出键盘在窗口上的X轴、Y轴的位置


键盘设置

设置输入元件的键盘

请点击下图设置参数了解详细信息


传输字数

传输字数：通过常量或变量设定需要传输的字数位数。

  • 字传输，LW0~LW9传到LW20~LW29，则可以设置传输字数位数为10

  • 位传输，LB0~LB19传到LB20~LB29，则可以设置传输字数位数为20


数据类型

  • 字：传输地址类型为字

  • 位：传输地址类型为位


刻度

设置数据块的刻度显示

请点击下图设置参数了解详细信息


游标

Type topic text here.


通道

设置数据块要显示的数据

请点击下图设置参数了解详细信息


通道设置

当勾选起始地址与采样地址连续时，如果采样点数地址为LW0，则起始地址自动为LW1

取消勾选后，用户可自设定起始地址


后缀名

后缀默认为空，代表全部显示，可以根据需要选择想要的文件类型。

例：如果想仅显示CSV格式的内容，可以通过 [image] 输入字母“CSV”来过滤文件。当不想仅显示CSV格式的文件时，可以选中项目，点击 [image] 即可


字号

可以选择8~16的字号


日期格式？？？


颜色

字体的颜色，当文字被选中，选中背景色为字体颜色的反色调


偏差型

设定一个数值作为棒图延伸的起始点

PS 当类型 被设为 [偏差型] 时，才可设定此功能


方向

设定棒图延伸的方向，向上、向下、向左、向右


最大值

字地址中的数值相对应至一个完全填满的棒图

可通过常量或者变量来设置，选择变量时配合数值输入元件


最小值

字地址中的数值相对应一个完全空白的棒图

可通过常量或者变量来设置，选择变量时配合数值输入元件


标准型

棒图的显示将依据指定字地址中的数值


显示刻度

设置刻度的线条宽度、线型、显示位置


刻度与标记

设置百分比显示、刻度显示

请点击下图设置参数了解详细信息


显示百分比

设置百分比文字的大小、字体、颜色


扩展属性

设置显示的边框色、背景色、棒颜色和报警上下限

请点击下图设置参数了解详细信息


报警上下限

  • 当设定的字地址中的数值小于去“下限值”中设定的值时，棒图的填色区域会变成下限设置的颜色，同时可以设置闪烁效果

  • 当设定的字地址中的数值大于去“上限值”中设定的值时，棒图的填色区域会变成上限设置的颜色，同时可以设置闪烁效果


识别目标区域

当字地址中的值到达目标值后（误差范围包含在目标值）颜色将变为目标区间所设置的颜色

例：目标值为20，误差范围为2，目标颜色为黄色，那么到达字符地址的值为18~22时，目标区间的颜色变为黄色


边框色

设定外框色、背景色、棒色、填充样式（可以用纯色、图案、渐变色来填充）等


位置

设置刻度在窗口上的显示位置和大小

勾选锁定后，将不能在窗口随意拖动改变刻度的显示位置和大小


线条

设置刻度线条的颜色、线条宽度、线型


使能控制地址

设定字地址为LW0，那么从位LW0.0开始控制索引0，当LW0.0位ON时，索引0选项不能被选中。

PS：LW0.1对应控制索引1，,当到达LW0.15后，将使用LW1.0、LW1.1......,以此类推


保持当前状态

当字地址的值不在对应值的范围内，保持当前标签内容不变


对应值

当点击选择选单项目时，将对应的值填入预设地址中


弹出方式

  • 向下弹出：当点击下拉清单时，向下弹出选单

  • 向上弹出：当点击下拉清单时，向上弹出选单

PS：只有下拉清单有，清单与选框不存在弹出


显示错误状态

当字地址的值不在对应值的范围内，即显示错误标签的内容状态


背景颜色

设置未被选取项目的背景区域之颜色


行间距

两个项目之间的距离


边框颜色

设置选单的外边框颜色


选中颜色

设置被选取项目的背景区域之颜色


选单设置

设置选单的项目数、颜色、对应值和内容

请点击下图设置参数了解详细信息


错误通知

设定位地址，当有错误输入值时，将所设位地址置ON


项目数

设定欲检视的项目数量，每一个项目表示一个状态并会显示在列表上

当选择某一项目时，会将其对应的数值写入至预设地址中


方向

最小值到最大值的方向


最小值最大值

最小值：滑动块的最小值，同时控制字地址寄存器的最小值

最大值：滑动块的最大值，同时控制字地址寄存器的最大值


最小刻度

滑动块的步长，按住滑块拖动后的增减量


滑动过程中改变

在滑动的过程中实时的改变字地址的值

PS：不勾选，则在松开滑块后才改变字地址的值


点击增减量

点击滑块元件中除了滑块的地方，字地址每次增减的值，这里设置为最小刻度的倍数

PS：不勾选，则默认按照最小刻度值为点击的增减量


主次刻度

设置滑动块主刻度、次刻度、轴、标记的显示


刻度

设置滑动块刻度的显示

请点击下图设置参数了解详细信息


刻度位置

设置滑动块刻度的显示位置


线条

设置滑动块刻度的线条显示


单色画笔

当选择单色画笔时，设定画布的颜色，及背景色；再设定画笔的颜色，即为位地址ON的状态颜色，当位地址为OFF时，无色

例：选择单色画笔，设定本地位地址LB0，画布的大小为100*100，一个位地址画笔占一个像素。那么此画布反应的是LB0~LB9999的地址状态

当画布为黑色、画笔为红色，LB0、LB99、LB9900、LB9999为ON时，如下图所示


占用地址长度

占用地址的长度根据“显示设置”属性里的“宽”、“高”相乘得来的，一个像素对应一个地址

如：宽为100，高为100，那么占用地址为10000，设定位地址为LB0，那么占用地址为LB0~LB9999


多色画笔

当选择多色画布时，画布色即为透明色，画笔的颜色根据本地字地址的值通过RGB565的格式，自动绘制颜色

例：选择多色画笔，设定本地字地址LW0，画布的大小为100*100，一个字地址画笔占一个像素。那么此画布反应的是LW0~LW9999的地址值的状态


定时刷新

设定间隔时间，定时刷新画布上的画笔颜色，并可设定延迟刷新


触发刷新

设定位地址，根据条件刷新画布上的画笔颜色

  • ON<—>OFF：当指定位寄存器地址状态变化时，触发

  • ON—>OFF:当指定位寄存器地址状态由ON 变为OFF 时，触发

  • OFF—>ON:当指定位寄存器地址状态由OFF 变为ON 时，触发

  • ON—>OFF& “自动复位”当指定位寄存器地址状态由ON 变为OFF 时，触发，触发后自动将指定位寄存器状态置为OFF

  • OFF—>ON& “自动复位”当指定位寄存器地址状态由OFF 变为ON 时，触发，触发后自动将指定位寄存器状态置为ON


X轴方向移动

沿X轴方向移动，及水平方向移动

PS：可以同时勾选“X轴方向移动”和“Y轴方向移动”，即按斜线方向移动，斜线的角度根据X轴、Y轴的移动距离计算


Y轴方向移动

沿Y轴方向移动，及垂直方向移动

PS：可以同时勾选“X轴方向移动”和“Y轴方向移动”，即按斜线方向移动，斜线的角度根据X轴、Y轴的移动距离计算


反比例

当勾选按比例移动时，才有此选项，勾选此选项后，设定的坐标下限对应输入上限，坐标上限对应输入下限，按照反比例移动


屏幕移动范围

设定移动元件在屏幕上的移动范围

PS：移动元件会从绘制的初始位置开始移动


按比例移动

按照屏幕移动范围，坐标下限对应输入下限，坐标上限对应输入上限，进行比例换算移动

例：坐标下限为0、坐标上限为799。输入下限为0、输入上限为7990，那么当设定的字地址的值为0时对应在坐标下限0的位置，字地址的值为7990时，对应屏幕坐标为799.

PS：元件的位置以左上角顶点为准


读取值

移动元件将根据此字地址的值变化进行移动


执行设置

  • 切换窗口：关闭本窗口，切换到指定窗口

  • 关闭弹出窗口：按钮放在弹出窗口上，点击关闭弹出窗口。

  • 弹出窗口：弹出指定窗口

  • 返回上一窗口：关闭本窗口，返回上一次打开的窗口

  • 窗口控制条：按钮放在弹出窗口上，按住不放拖动弹出窗口的位置

  • 返回主窗口：关闭本窗口，返回预先设置好的主窗口。可以通过 [image] 去设置主窗口，或者通过全局设置里的主窗口设置。


表格背景色

设置表格的背景色、外框线、分割线的显示


选中

选择方式：三种选择方式

  • 按行选中：被选择的行颜色为蓝色

栅格位置：地址LW0的值为行号

  • 按列选中：被选择的列颜色为蓝色

栅格位置：地址LW0的值为列号

  • 按单元格选中：被选中的单元格颜色为蓝色

栅格地址：LW0的值为行号，LW1的值为列号


填充

设定管道内径的填充，多种填充方式：纯色、图案、渐变


流动区域设置

  • 宽度：设置所有流动块的宽度，流动块的宽度小于等于管径的高度

  • 长度：总体流动块的长度，流动块的长度小于等于管径的长度


流动块图形属性

设置流动块图形显示

请点击下图设置参数了解详细信息


流动块属性

设置流动块的宽度、长度、间距、流动方向和速度

请点击下图设置参数了解详细信息


流动块设置

  • 块长度：每个流动块个体的长度

  • 块间距：块与块之间的距离

  • 流动方向：设置流动方向

  • 流动速度：设置字地址寄存器用于动态控制流动的速度和方向，字地址的值在-10~10之间，具体含义见下：

  • PS：字地址的值小于-10，速度等同于-10；字地址的值大于10，速度等同于10。


管道设置

管径：管道横切面圆直径的长度

管壁厚度：管道外壁的厚度

管壁颜色：设置管壁的颜色


倒角

设置正方形和多边形的倒角，倒角可为直角和圆角


填充

为图形填充背景，颜色可设定，有三种填充方式：


弧

弧/动态图形/指示灯/显示设置

选择弧后，在窗口任意位置点击鼠标开始绘制，松开鼠标结束绘制

双击绘制好的弧，可查看并设定属性

请点击下图设置参数了解详细信息


扇形

扇形/动态图形/指示灯/显示设置

选择扇形后，在窗口任意位置点击鼠标开始绘制，松开鼠标结束绘制

双击绘制好的扇形，可查看并设定属性

请点击下图设置参数了解详细信息


扇形起始终止角

可设置扇形的起始角和终止角，按顺时针的方向绘制扇形

下图为默认的起始角0度和终止角180度：


扇环

扇环/动态图形/指示灯/显示设置

选择扇环后，在窗口任意位置点击鼠标开始绘制，松开鼠标结束绘制

双击绘制好的扇环，可查看并设定属性

请点击下图设置参数了解详细信息


扇环内外环比例

内外环比例：1~99，数值越大内环与外环的距离越近

可设置扇环的起始角和终止角，按顺时针的方向绘制扇环

下图为默认的起始角0度和终止角180度：


旋转

每个图形都有9个控制点，可更改控制点，并设置选择角度来旋转图形


正方形

矩形/多边形/椭圆/动态图形/指示灯/显示设置

选择正方形/多边形/椭圆后，在窗口任意位置点击鼠标开始绘制，松开鼠标结束绘制

双击绘制好的正方形/多边形/椭圆，可查看并设定属性

请点击下图设置参数了解详细信息

PS：也可通过点击图形的控制点来设置属性


直线

直线/折线//动态图形/指示灯/显示设置

选择直线/折线后，在窗口任意位置点击鼠标开始绘制，松开鼠标结束绘制

双击绘制好的直线或者折线，可查看并设定属性

请点击下图设置参数了解详细信息

PS：也可通过点击图形的控制点来设置属性


箭头

可以给直线或者折线加一下几种箭头


起始终止角

可设置弧形的起始角和终止角，按顺时针的方向绘制弧形

下图为默认的起始角和终止角：


阴影效果

设置图形的阴影效果，阴影颜色可自选，阴影的偏移位置也可设定

PS：只有选择填充色后，才有阴影效果可选


使用动态图形

通过字地址的值，随机控制图片的位置、大小和旋转（此设置与一般属性里的控制点密切相关，见下图）

PS：当控制大小的地址的值为0时，图片将不显示


动态图形

动态图形为绘图的公共属性，用来控制图形

请点击下图设置参数了解详细信息


指示灯

指示灯为绘图的公共属性，图形可以用作指示灯显示

请点击下图设置参数了解详细信息


 显示设置

请点击下图设置参数了解详细信息

PS：此图勾选了条件显示，默认是不勾选的。


用作指示灯

用绘制的图形作为位地址的指示灯，当位地址为ON时，改变图形的颜色，同时可以设置图形闪烁或给图形填充颜色


从图库导入

选择图库的文件导入到当前窗口


从文件导入

选择本地电脑的图片导入到当前窗口


尺寸缩放

固定纵横比：放大或缩小尺寸时，保持长宽的比例

使用原始尺寸：不允许修改图片的大小


透明色

  • 使用PNG图片透明通道：当使用PNG图片时，此选项为勾选

  • 使用指定颜色：用 [image] 来选择预览图片上的颜色，对应的颜色即为透明


静态图片

静态图片/动态图形/显示设置

选择静态图片，在窗口任意位置点击鼠标开始绘制，松开鼠标结束绘制

请点击下图设置参数了解详细信息


静态文本

静态文本/显示设置

选择静态文本，弹出输入框，输入文字好文字放入窗口即可

请点击下图设置参数了解详细信息


仅显示可修改颜色图形

勾选后，所列图形，按照“仅显示可修改颜色图形”过滤，特殊的矢量图，该矢量图勾选了填充/用户可改填充，元件的图形选项卡使用该图形时，可以更改边框颜色、更改填充


仅显示矢量图

勾选后，所列图形，按照“仅显示矢量图”过滤，均为矢量图，也就是直线等绘制而成的图形


删除图形

选择当前工程图库或收藏夹下的子分类，选择某个图形时有效，可以删除图形


图形的宽高

新增图形的宽度和高度，默认300


在现有图库图形基础上修改

勾选，选择图形有效，可以选择图库图形，然后在其基础上修改


导入

选择收藏夹的子分类或系统图库下的子分类，选择某个图形时有效，点击，把收藏夹或系统图库的图形，导入到当前工程图库


收藏

选择当前工程图库或系统图库下的子分类，选择某个图形时有效，点击，把当前工程图库或系统图库下的图形，收藏到收藏夹，用户在创建其他工程的时候，可以在收藏夹里找到之前工程收藏的图形


收起所有分支

点击后，收起/展开，所有分支


新增图形名称

输入图形的名称


新增图形按钮

仅当前工程图库下有效，点击可以新增图形


新建分类

仅当选择收藏夹才有效，可以新建分类、重命名分类、删除分类


状态数

支持2~256个状态


编辑图形

图形预览区，图形旁的空白处，右键可以添加状态

图形预览区，图形处右键：可以添加状态、删除状态

图形编辑区，图形旁的空白处，右键可以全选、添加矢量图形、设置网格


编辑图形按钮

仅当前工程图库下有效，点击可以编辑图形


选择图形

进入浏览图库窗口，用户可以选择图库图形


重命名图形

选择当前工程图库或收藏夹下的子分类，选择某个图形时有效，可以重命名图形


标签名称

用户使用容易识别的名称作为标签名称


从系统目录导入

软件提供部分文件，供用户导入


删除声音

选择删除的声音条目进行删除


导入声音

点击，进入浏览窗口，用户可以找到需要的声音文件


导出声音

该工程里使用的声音文件可以导出，供其他工程使用


播放声音

点击播放声音，即可播放选择的声音文件，且标签立即变成“停止播放”，点击停止播放，则立即停止播放声音文件


清空

清空所有的声音条目


取反运算

与运算：&

两者都为1为1，否则为0

1&1=1, 1&0=0, 0&1=0, 0&0=0

或运算：|

两者都为0为0，否则为1

1|1 = 1, 1|0 = 1, 0|1 = 1, 0|0 = 0

非运算：~

1取0，0取1

~1 = 0, ~0 = 1

~(10001) = 01110

异或运算

两者相等为0,不等为1

1^1=0, 1^0=1, 0^1=1, 0^0=0


地址别名

用户定义宏代码中读写的地址的名称，方便识别


宏_读写函数的调用

用户可以通过"输入辅助"，设置读取字地址GetWord的函数

例如--------------------------------------------------------------------------------------------------------------------------------------------------------------

unsigned short GetWord( @地址别名@, 地址偏移 ):

从指定寄存器地址读取一个字。

@地址别名@：选定一个字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

返回值：unsigned short型，读取的字地址的值

错误信息：

使用GetError函数获得错误码。

int error=GetError();

使用示例：

unsigned short speed=GetWord( @速度@,3 ):

@速度@地址设定为LW0，则本例表示从LW3读取位状态，返回到unsigned short型变量speed

short speed = （short）GetWord(@速度@,3): //如果使用有符号数，可以使用强制转换

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

使用说明，已经进行了详细说明，其他函数类似，均可以点击进行查看

代码的详细说明（注意地址声明："字"对应的地址是4X4，"0x20"对应的地址是0X20）

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

#include <macro.h>

int MacroMain()

{

// 这里添加代码

unsigned short k = GetWord(@字@,0); //读取字地址4X4，把值赋给变量k

SetBit(@0x20@,0,1); //设定位地址0X20写1

k++; //让k递加

SetWord(@字@,0,k); //设定字地址4X4为变量k的值

SetBit(@0x20@,0,0); //设定位地址0X20写0

return 0;

}

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

代码的执行结果（窗口上摆放指示灯0X20、数值显示4X4，窗口属性中增加定时器执行宏）


宏使用随机数

用户可以通过"输入辅助"，设置延时函数Delay

例如--------------------------------------------------------------------------------------------------------------------------------------------------------------

Delay( 毫秒 ):

延迟函数，输入参数值为毫秒，unsigned int型

返回值：无返回值

使用示例：

Delay(1000)://延迟等待1000mS

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

使用说明，已经进行了详细说明，其他函数类似，均可以点击进行查看

代码的详细说明（注意地址声明："data"是别名，对应字地址LW100）

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

#include <macro.h>

#include <stdio.h>

#include <time.h>

int MacroMain()

{

// 这里添加代码

int i,Count=0;

srand((unsigned)time(NULL)); //srand函数是随机数发生器的初始化函数，拿系统时间作为种子，由于时间是变化的，种子变化，可以产生不相同的随机数

while(Count<10) //while循环

{

i = rand(); //函数rand()是真正的随机数生成器，随机数，赋值i

SetWord(@data@,0,i); //设定LW100（别名是data）的值为随机数

SetWord(@count@,0,Count+1); //计数，while循环控制执行10次

Delay(1000); //延时等待1000ms

Count++;

}

return 0;

}

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

代码的执行结果（窗口上摆放，数值显示LW100，LW101，功能键执行宏）


延时函数

Delay( 毫秒 ):

延迟函数，输入参数值为毫秒，unsigned int型

返回值：无返回值

使用示例：

Delay(1000)://延迟等待1000mS


引用关系

宏被引用后，此处下拉，可以查看引用关系


当前编辑宏

查找范围处于当前正在编辑的宏


所有宏

查找范围处于所有宏


新增地址

用户新增输入输出地址，定义地址别名，可以为位地址或字地址


新建宏

点击，输入宏名，输入描述，帮助用户识别


方向

查找的方向，向上/向下


替换

替换指定范围的代码内容，选择替换时，在查找下面增加下图内容


替换内容输入框

输入替换的内容


查找

查找指定范围的代码内容


查找内容输入框

输入查找的内容


正弦函数

sin() 函数用来求给定值的正弦值，其原型为：

double sin(double x);

【参数】给定的值（弧度）。

【返回值】返回-1 至1 之间的计算结果。

弧度与角度的关系为：

弧度＝角度×π/180

角度 = 弧度×180°/π

比如：

int angle; //定义角度变量angle

float radian,Y; //定义浮点数变量弧度，Y

radian=angle*3.1415926/180; //弧度＝角度×π/180

Y=sin(radian);


正弦曲线

宏使用随机数

用户可以通过"输入辅助"，设定浮点数SetFloat

例如--------------------------------------------------------------------------------------------------------------------------------------------------------------

int SetFloat( @地址别名@,地址偏移,设定值 ):

设置一个单精度浮点数到指定寄存器。

@地址别名@：选定一个字或双字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

设定值：浮点型数（float），要设定到寄存器的浮点型数

返回值：int型，返回值 0-失败，1-成功

使用示例：

float speed=3.14;

int error=SetFloat(@速度@,3,speed):

@速度@地址设定为LW0，则本例表示将speed的值设定到LW3和LW4组成的双字

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

使用说明，已经进行了详细说明，其他函数类似，均可以点击进行查看

代码的详细说明（注意地址声明："y"和"a"是别名，分别对应字地址LW0和LW10）

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

#include <macro.h>

#include<math.h>

int MacroMain()

{

// 这里添加代码

int angle; //定义角度变量angle

float radian,Y; //定义浮点数变量弧度，Y

angle=GetWord(@a@,0); //读取LW10（别名a），值赋给angle

if(angle<=360) //角度判断

angle+=1;

else

angle=0;

radian=angle*3.1415926/180; //角度弧度运算

Y=sin(radian)*100; //正弦函数，Y值放大100倍

SetFloat(@y@,0,Y); //设定Y值

SetWord(@a@,0,angle); //设定角度值

return 0;

}

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

代码的执行结果（窗口上摆放趋势图，数值显示，LW0（浮点数），LW100，窗口属性中增加定时器执行宏）


确定并在当前光标位置插入

点击后，该地址声明完成，并在宏代码的当前光标位置，插入该地址，比如，@变量@


系统函数

高级函数，点击后，用户可以根据“输入辅助”说明，填写宏代码，比如，调用宏CallMacro


编译

利用编译器将代码编译成可执行的程序，供HMI调用


获取错误码

int GetError( ):

获取错误码。

无输入参数。

返回值：int型，返回的错误码：

0-未执行

1-成功

2-超时

3-错误

4-套接字错误

16-通讯未完成

使用示例：

int error =GetError():


角度弧度运算

圆的周长是半径的 2π倍，所以一个周角（360度）是 2π弧度

半圆的长度是半径的 π倍，所以一个平角（180度）是 π弧度

1度＝π/180 弧度 ( ≈0.017453弧度 )

角度化成弧度的公式： 弧度＝角度×π/180

因为 π弧度＝180°

所以 1弧度＝180°/π （≈57.3°）

因此，可得到 把弧度化成角度的公式： 角度＝弧度×180°/π


设定位地址

int SetBit( @地址别名@,地址偏移,设定值 ):

设定指定寄存器地址位。

@地址别名@：选定一个位地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

设定值：布尔型（bool），设定位状态，0或1

返回值：int型，返回值 0-失败，1-成功

使用示例：

int error=SetBit(@power@,2,1):

power地址设定为LB0，则本例表示设定LB2状态


设定双字地址

bool SetDWord( @地址别名@,地址偏移,设定值 ):

设定一个32BIT数到指定寄存器地址，地址可以是一个双字寄存器或两个连续的单字寄存器。

@地址别名@：选定一个字或双字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

设定值：int型数，要设定到指定寄存器的值

返回值：int型，返回值 0-失败，1-成功

使用示例：

unsigned int speed

int error=SetDWord(@速度@,3,speed):

@速度@地址设定为LW0，则本例表示将speed的值设定到LW3和LW4组成的双字


设定字地址

int SetWord( @地址别名@,地址偏移,设定值 ):

设定一个16BIT数到指定寄存器字地址。

@地址别名@：选定一个字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

设定值：short型数，要设定到指定寄存器地址的值

返回值：int型，返回值 0-失败，1-成功

使用示例：

short speed;

int error=SetWord(@速度@,3,speed):

@速度@地址设定为LW0，则本例表示将speed的值设定到LW3


设定浮点数

int SetFloat( @地址别名@,地址偏移,设定值 ):

设置一个单精度浮点数到指定寄存器。

@地址别名@：选定一个字或双字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

设定值：浮点型数（float），要设定到寄存器的浮点型数

返回值：int型，返回值 0-失败，1-成功

使用示例：

float speed=3.14;

int error=SetFloat(@速度@,3,speed):

@速度@地址设定为LW0，则本例表示将speed的值设定到LW3和LW4组成的双字


设定连续地址

int SetMem( 数组指针,@地址别名@,地址偏移,字节数 ):

将数组数据设定到指定起始地址的连续寄存器。

数组指针：指针类型，指向预先声明的数组。

@地址别名@：选定一个寄存器类型的起始地址，可以是位类型也可以是字类型

地址偏移：正整数（unsigned int），读取的起始地址=@地址别名@声明的地址+地址偏移

字节数：正整数（unsigned int），要读取的字节数。特别注意需要根据数据类型换算。

字节数应该是sizeof(数组声明的数据类型)*要读取的数组个数

返回值：int型，返回值 0-失败，1-成功

使用示例：

unsigned short data[10];

int error = SetMem(data,@数组数据@,2,10*sizeof（unsigned short）):

@数组数据@地址设定为LW0，则本例表示将数组data中的数据复制到LW2起始的10个字寄存器中。

char data[5];

int error = SetMem(data,@数组数据@,2,5):

@数组数据@地址设定为LW0，则本例表示将data中5个字节的数据复制到从LW2起的3个字中(每个字包含两个char型数据，最后一个字的高位无效)


读写函数

常用的读写函数，点击后，用户可以根据“输入辅助”说明，填写宏代码，比如，读取位地址GetBit


读取位地址

bool GetBit( @地址别名@,地址偏移 ):

从指定寄存器地址读取一个位。

@地址别名@：选定一个位地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

返回值：布尔型，读取的位地址的值

错误信息：

使用GetError函数获得错误码。

int error=GetError();

使用示例：

bool power=GetBit( @power_on@,2 ):

power_on地址设定为LB0，则本例表示从LB2读取位状态，返回到布尔型变量power


读取双字地址

unsigned int GetDWord( @地址别名@,地址偏移 ):

从指定寄存器地址读取一个双字。

@地址别名@：选定一个字或双字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

返回值：unsigned int型，读取的双字地址的值。如果是字类型，读取连续的两个字，小端序，低位在前

错误信息：

使用GetError函数获得错误码。

int error=GetError();

使用示例：

unsigned int speed=GetDWord( @速度@,3 ):

@速度@地址设定为LW0，则本例表示从LW3和LW4读取双字，返回到unsigned int型变量speed

//如果使用其它类型数，可以使用强制转换

int speed = （int）GetDWord(@速度@,3):


读取字地址

unsigned short GetWord( @地址别名@, 地址偏移 ):

从指定寄存器地址读取一个字。

@地址别名@：选定一个字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

返回值：unsigned short型，读取的字地址的值

错误信息：

使用GetError函数获得错误码。

int error=GetError();

使用示例：

unsigned short speed=GetWord( @速度@,3 ):

@速度@地址设定为LW0，则本例表示从LW3读取位状态，返回到unsigned short型变量speed

short speed = （short）GetWord(@速度@,3): //如果使用有符号数，可以使用强制转换


读取浮点数

float GetFloat( @地址别名@,地址偏移 ):

从指定寄存器地址读取一个单精度浮点数。

@地址别名@：选定一个字或双字地址类型

地址偏移：正整数（unsigned int），读取地址=@地址别名@声明的地址+地址偏移

返回值：浮点型，读取的保存于双字地址或两个连续字地址的浮点数值

错误信息：

使用GetError函数获得错误码。

int error=GetError();

使用示例：

float speed=GetFloat( @速度@,3 ):

@速度@地址设定为LW0，则本例表示从LW3和LW4读取双字，返回到float型变量speed


读取连续地址

int GetMem( 数组指针,@地址别名@,地址偏移,字节数 ):

从指定寄存器地址读取连续字。

数组指针：指针类型，预先声明的数组。

@地址别名@：选定一个寄存器类型的起始地址，可以是位类型也可以是字类型的寄存器

地址偏移：正整数（unsigned int），读取的起始地址=@地址别名@声明的地址+地址偏移

字节数：正整数（unsigned int），要读取的字节数。特别注意需要根据数据类型换算。

字节数应该是sizeof(数组声明的数据类型)*要读取的数组个数

返回值：int型，返回值 0-失败，1-成功

使用示例：

unsigned short data[10];

int error = GetMem(data,@数组数据@,2,10*sizeof（unsigned short）):

@数组数据@地址设定为LW0，则本例表示从LW2读取10个字，sizeof

char data[5];

int error = GetMem(data,@数组数据@,2,5):

@数组数据@地址设定为LW0，则本例表示从LW2读取3个字(每个字包含连个char型数据，最后一个字的高位无效)，复制到数组data


调用宏

用户可以通过"输入辅助"，设置连续地址SetMem

例如--------------------------------------------------------------------------------------------------------------------------------------------------------------

int SetMem( 数组指针,@地址别名@,地址偏移,字节数 ):

将数组数据设定到指定起始地址的连续寄存器。

数组指针：指针类型，指向预先声明的数组。

@地址别名@：选定一个寄存器类型的起始地址，可以是位类型也可以是字类型

地址偏移：正整数（unsigned int），读取的起始地址=@地址别名@声明的地址+地址偏移

字节数：正整数（unsigned int），要读取的字节数。特别注意需要根据数据类型换算。

字节数应该是sizeof(数组声明的数据类型)*要读取的数组个数

返回值：int型，返回值 0-失败，1-成功

使用示例：

unsigned short data[10];

int error = SetMem(data,@数组数据@,2,10*sizeof（unsigned short）):

@数组数据@地址设定为LW0，则本例表示将数组data中的数据复制到LW2起始的10个字寄存器中。

char data[5];

int error = SetMem(data,@数组数据@,2,5):

@数组数据@地址设定为LW0，则本例表示将data中5个字节的数据复制到从LW2起的3个字中(每个字包含两个char型数据，最后一个字的高位无效)

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

使用说明，已经进行了详细说明，其他函数类似，均可以点击进行查看

代码的详细说明（注意地址声明："data"是别名，对应字地址4X1或4Xn，其中n=2~10）

复位，设定连续地址，值为0-----------------------------------------------------------------------------------------------------------------

#include <macro.h>

int MacroMain()

{

// 这里添加代码

short data[10]={0};

SetMem(data,@d@,0,20); //设定4X1~10的值为0

return 0;

}

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

子宏1~10，代码一样，只是地址变量（4X1~10）不一样-------------------------------------------------------------------

#include <macro.h>

int MacroMain()

{

// 这里添加代码

short buf=GetWord(@data@,0);

int i;

for(i=0;i<10;i++)

{

buf++;

SetWord(@data@,0,buf); //设定4X1（或4Xn，其中n=2~10），for循环，值从0加到10

Delay(1000); //延时等待1000ms

}

return 0;

}

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

宏，调用11个宏----------------------------------------------------------------------------------------------------------------------------------------

#include <macro.h>

int MacroMain()

{

// 这里添加代码

CallMacro("复位");

CallMacro("子宏1");

CallMacro("子宏2");

CallMacro("子宏3");

CallMacro("子宏4");

CallMacro("子宏5");

CallMacro("子宏6");

CallMacro("子宏7");

CallMacro("子宏8");

CallMacro("子宏9");

CallMacro("子宏10");

return 0;

}

----------------------------------------------------------------------------------------------------------------------------------------------------------------------

代码的执行结果（窗口上摆放，12个功能键执行宏，10个数值输入4X1~10）


调用宏1

调用宏（说明）

int CallMem( "宏名" ):

调用指定宏。

宏名：双引号中是要引用的宏的名称，不要加文件名后缀

返回值：int型，返回子宏主函数的返回值

使用示例：

int error = CallMacro("Macro_1"):


调试函数

void Debug( 端口号,格式字串,变量1,变量2...):

注意！使用前应该调用通讯参数设置: SetComParam初始化串口

如果只是在模拟窗口调试，也可以不用初始化串口。

端口号：通讯端口编号，unsigned int型。0-COM1,1-COM2,2-COM3...

格式字串：输出格式字串，与C语言printf

变量：与输出格式字串对应的变量名，用法与printf相同

格式的规格如下所示。[]中的部分是可选的。

%[指定参数][标识符][宽度][.精度]指示符

若想输出'%'本身时, 请使用'%%'处理。

1. 处理字符方向。负号时表示从后向前处理。

2. 填空字元。 0 的话表示空格填 0；空格是内定值，表示空格就放着。

3. 字符总宽度。为最小宽度。

4. 精确度。指在小数点后的浮点数位数。

转换字符

%% 印出百分比符号，不转换。

%c 整数转成对应的 ASCII 字元。

%d 整数转成十进位。

%f 倍精确度数字转成浮点数。

%o 整数转成八进位。

%s 整数转成字符串。

%x 整数转成小写十六进位。

%X 整数转成大写十六进位。

使用示例：

int itest=12;

float ftest=65.4321;

Debug(0,"itest=%d\n ftest=%2.3f\n",itest,ftest);

输出结果：

itest=12

ftest=65.432


跳转到选中位置

点击，可以直接跳转到引用位置


跳转行号

跳转到指定行号


运算符

常用的运算符，告诉用户，此处可以支持的运算符，用户可以根据“输入辅助”说明，填写宏代码


通讯参数设置

int SetComParam( 端口号,波特率,数据位,停止位,校验位,通讯模式):

端口号：通讯端口编号，unsigned int型。0-COM1,1-COM2,2-COM3...

波特率：通讯波特率，int型，例如9600,115200

数据位：通讯数据位，int型，7,8

停止位：通讯停止位，int型，1,2

校验位：通讯校验位，int型，'n'或值110--无校验，'o'或数值111--奇校验，'e'或数值101--偶校验

通讯模式：通讯模式设置，int型 0-232,1-485-4w,2-485-2w

返回值：返回值 0-失败，1-成功

使用示例：

int error=SetComParam(0,115200,8,1,'n',2);//COM1,485方式，115200,8,1,N


通讯数据输入

int Inport( 端口号,缓冲区指针,缓冲区长度,超时时间):

注意！使用前应该调用通讯参数设置: SetComParam初始化串口

端口号：通讯端口编号，unsigned int型。0-COM1,1-COM2,2-COM3...

缓冲区指针：读取缓冲区数组指针

缓冲区长度：读取缓冲区的长度 读取后返回，不一定等到缓冲区满.缓冲区最大值4096

超时时间n：单位毫秒，，如果n毫秒内没有收到任何数据，或者收到数据之后n毫秒内没有再收到数据，或缓冲区满，则接收函数返回

返回值：实际读取到的数据个数.如返回-1，表示出错

使用示例：

unsigned char recv_buff[];

int data_count=Inport(1,recv_buff,16,10);


通讯数据输出

int Outport( 端口号,缓冲区指针,数据个数):

注意！使用前应该调用通讯参数设置: SetComParam初始化串口

端口号：通讯端口编号，unsigned int型。0-COM1,1-COM2,2-COM3...

缓冲区指针：读取缓冲区数组指针

数据个数：unsigned int型，要发送的个数

返回值：返回输出的数据字节数

使用示例：

unsigned char send_buff[]="Hello world!";

int error=Outport(1,send_buff,12);


随机数函数

设定连续地址

rand（产生随机数）

相关函数

srand

表头文件

#include<stdlib.h>

定义函数

int rand(void)

函数说明

rand()会返回一随机数值，范围在0至RAND_MAX 间。在调用此函数产生随机数前，必须先利用srand()设好随机数种子，如果未设随机数种子，rand()在调用时会自动设随机数种子为1。关于随机数种子请参考srand()。

返回值

返回0至RAND_MAX之间的随机数值，RAND_MAX定义在stdlib.h，其值为2147483647。

范例

/* 产生介于1 到10 间的随机数值，此范例未设随机数种子，完整的随机数产生请参考

srand（）*/

#include<stdlib.h>

main()

{

int i,j;

for(i=0;i<10;i++)

{

j=1+(int)(10.0*rand()/(RAND_MAX+1.0));

printf("%d ",j);

}

}

执行

9 4 8 8 10 2 4 8 3 6

9 4 8 8 10 2 4 8 3 6

srand（设置随机数种子）

相关函数

rand

表头文件

#include<stdlib.h>

定义函数

void srand (unsigned int seed);

函数说明

srand()用来设置rand()产生随机数时的随机数种子。参数seed必须是个整数，通常可以利用geypid()或time(0)的返回值来当做seed。如果每次seed都设相同值，rand()所产生的随机数值每次就会一样。

返回值

范例

/* 产生介于1 到10 间的随机数值，此范例与执行结果可与rand（）参照*/

#include<time.h>

#include<stdlib.h>

main()

{

int i,j;

srand((int)time(0));

for(i=0;i<10;i++)

{

j=1+(int)(10.0*rand()/(RAND_MAX+1.0));

printf(" %d ",j);

}

}

执行

5 8 8 8 10 2 10 8 9 9

2 9 7 4 10 3 2 10 8 7


数据采样属性

请点击下图设置参数了解详细信息

属性设置/通道设置


PLC控制属性

请点击下图设置参数了解详细信息

切换基本窗口/报告当前窗口号/背光灯控制/执行宏指令


上传

允许上传及其密码，设置后，该工程下载到HMI上，其他用户如果知道密码，可以从HMI里上传到电脑上，得到的文件，还可以用FSTools工具下载到其他HMI上，正常使用

注意：上传的文件是个特殊的压缩包，必须通过反编译，才能用软件打开


下拉窗口

用户可以指定一个窗口作为下拉窗口，该下拉窗口里可以放报警事件显示等相关元件

注意：模拟或HMI上操作的时候，从窗口的上边沿，向下滑动，滑动到超过窗口一半的宽度，可以看见下拉窗口，逐渐出现；同样，从窗口的下边沿，向上滑动，滑动到超过窗口一半的宽度，下拉窗口可以缩回去


下载组态工程后默认显示的语种

下载组态工程后，默认显示的语种，如果设置简体中文，则组态画面以中文简体显示

注意：可通过SRW10050在运行中切换HMI当前显示的语种号


串口服务/网络服务

  • 通过串口连接的服务会显示在这里

  • 通过本窗口连接的网络服务也会显示在这里


主窗口

用户可以设置主窗口，在任何组态窗口上，都可以设置开关/窗口操作/返回主窗口


事件计数

报告当前发生的事件计数：字控制，勾选后，该寄存器统计当前发生的事件计数

报告累积法伤的事件数：字控制，勾选后，该寄存器统计累计发生的事件数

清除累计事件数：位控制，值为1，清除累计事件数，清除完自动复位


仅在指定窗口打开时有效

勾选后，仅在指定窗口打开时，执行该PLC控制


从常用字体模板导入

点击后，字体等相关信息可以从常用字体模板中导入，只要建立好了的字体模板，都可以导入，方便操作


任务计划描述

增加描述信息，方便编程识别


任务计划条目

开始时执行/结束时执行


任务计划的使能控制

使能位为ON的时候，禁止使用该任务计划


位设定

设为ON，表示让指定位为ON，设为OFF，表示让指定位为OFF


使用声音

勾选，报警事件触发后，播放声音文件


使用文本库

勾选后，如果有文本库条目，可以直接选择，如果没有，需要点击“文本库”按钮，进入文本库编辑，再选择条目


使用蜂鸣器

让蜂鸣器响，时间为设定时间，比如1秒


使用语种数

默认2，用户最多可以设置32


保存内容到文本库

点击后，可以保存当前的标签内容到文本库，如果有多条语种，则保存多条语种内容到文本库


公共窗口位置

显示在基本窗口之下，显示在基本窗口之上。默认选中“显示在基本窗口以下”

公共窗口显示在基本窗口之下
公共窗口显示在基本窗口之上


关闭背光

调低亮度后再过的时间，默认10，表示，调低亮度后再过10分钟，关闭背光

注意：关闭背光后，组态画面就看不见了


分组

全部、第1组~第32组，用户可以自定义组别，报警事件显示中可以按组显示


初始化宏

工程下载到HMI上或HMI上电后，显示组态窗口前，系统自动运行宏程序，实现一些初始化准备工作


初始化窗口

工程下载到HMI上或HMI上电后，显示的第一个组态窗口


动作

触发时 | 事件报警发生
确认时 | 用户在报警事件显示条目上点击， 表示已经确认过了，避免多人同时 操作
恢复时 | 报警事件条件不满足，恢复到正常 情况

触发宏 | 触发执行指定宏
通知位地址 | 让指定位为ON或OFF
通知字地址 | 设置指定字的值为常数或变量
弹出窗口 | 弹出设定的窗口
打印信息到打印机 | 可以打印报警事件信息


单字组成双字

单字组成双字时，高低字节排序：比如双字LW0=12345678(16进制），低位在（内存）前（小端），则字LW0=5678(16进制），字LW1=1234(16进制），高位在（内存）前（大端），则LW0=1234(16进制），字LW1=5678(16进制）


历史事件保存

为不保存、HMI、SD卡、USB1（如果设备支持2个USB存储方式，还可以有USB2）

最大条目数：用户可以自定义存储条数

子目录名：存储目录的名字，用户可以自定义名称，方便识别

最大存储限制：0表示无限制，其他值表示天数

存储区满： 有2个选项

当剩余空间小于： 可选项，比如，让LB0为ON，通知用户存储区满

举例，位LB1，为ON时，清空历史记录，清空成功后，自动复位


反编译

允许反编译及其密码，设置后，上传的文件，如果知道反编译密码，可以使用FSTools工具，反编译为工程


周期式采样方式

设置采样周期，单位为秒或0.1秒，每隔一个采样周期，系统进行一次数据采样，并处理相关数据


图形字体

图形字体：将整个字符串当做一个整体，然后截取成为一个位图，保存到工程中

图形字体的缺点：占用内存容量大。由于字符串使用位图来保存，因此会占用较大的空间

图形字体的优点：支持使用当前操作系统安装的所有字体，显示效果佳


地址变量

使用变量地址来对应指定星期或隔日


地址变量条目

任务计划

指定星期/隔日/地址变量


复制当前字体属性到所有语种

点击后，把当前字体属性拷贝到所有语种


复制当前文字到所有语种

当前文字，复制到所有语种，用户在各语种内容差不多，只需要修改部分内容下使用，方便操作


大纲

注意：按下Ctrl键，可以选中多个条目，选中后，点击基本窗口或键盘窗口的选项卡

改变成 [image] ，可以通过键盘的上下左右键微调元件位置


大纲的眼睛

点击，让元件在窗口上显示或隐藏，最上面那个总的，是全局控制，让所有元件在窗口上显示或隐藏


大纲的锁

点击，让元件在窗口上锁定或解锁，最上面那个总的，是全局控制，让所有元件在窗口上锁定或解锁


字体

支持当前操作系统安装的所有字体类型，比如微软雅黑


字体大小

设置字体的当前大小，可以选择8~72


字体模板条目

用户可以自己定义，常用的字体模板，给其他地方调用，比如语种设置就可以调用


字设定

让设定地址的值为常数，或者为变量的值


密码

密码都是默认为6个8，密码只能输入>=0的数字，最大值为99999999，密码必填，密码支持前导零的方式，例如0012和12不是一个密码


屏保结束返回原画面

勾选屏保结束返回原画面，如果不设置密码，点击HMI后，直接返回原画面，如果设置密码，点击HMI后，先弹出“请输入密码”的系统窗口，输入同级或高等级的密码后，再返回原画面

注意，不勾选屏保结束返回原画面，则停在屏保画面


屏幕保护

屏幕保护，时间到，切换到指定窗口，必须设置屏保的使用窗口，该窗口可以用来显示公司LOGO


弹出窗口

让指定窗口弹出


当前显示语种

选中后，下面的文本对应当前显示语种内容，若要设置其他语种内容，通过下拉选中其他语种

注意：文本库的内容，需要在文本库里面编辑


打开背光灯

勾选后，切换基本窗口的同时，如果背光灯处于关闭状态，打开背光灯


执行宏

选择执行的宏，点击宏代码或编辑，进入编辑宏界面


执行宏指令

切换基本窗口/报告当前窗口号/背光灯控制/执行宏指令


报告当前窗口号

切换基本窗口/报告当前窗口号/背光灯控制/执行宏指令


报警与事件之触发条件

可以设置多个条目，只有当所有条目都满足，触发条件才有效


报警与事件明细设置

设置报警与事件的触发条件及内容，可通过字、位设定条件

请点击下图设置参数了解详细信息


报警点亮背光

勾选报警/事件发生时自动点亮背光，表示HMI在运行中，关闭背光了，如果发生了报警或事件，自动点亮背光


指定星期

开始时间和结束时间在一个星期内


指定星期的星期

指定星期的开始时间，星期可以多选


换页后地址清零

勾选后，切换基本窗口，控制的字地址清零


控制类型

切换基本窗口、报告当前窗口号、背光灯控制、执行宏指令


描述

用户可以自定义字体模板的名称，方便编程


播放声音

播放指定的声音文件


数据记录

分为不保存、HMI、SD卡、USB1（如果设备支持2个USB存储方式，还可以有USB2）

最大条目数：用户可以自定义存储条数

自动停止：位控制，勾选则自动停止，不勾选则删除旧记录增加新记录

子目录名：存储目录的名字，用户可以自定义名称，方便识别

最大存储限制：0表示无限制，其他值表示天数

存储区满： 有2个选项

当剩余空间小于： 可选项，比如，让LB0为ON，通知用户存储区满

举例，位LB1，为ON时，清空历史记录，清空成功后，自动复位


文本内容

没有勾选文本库，显示的标签内容，可以编辑，如果勾选文本库，显示的文本库的内容，只能进入文本库编辑内容

注意：不同的语种，对应的内容同时刷新


新建任务计划

通过此按钮可以新建指定星期/隔日/地址变量这三种任务计划


时分秒

可以设置时、分、秒


时钟来源

时钟来源可以选择 HMI内部时钟 和 外部装置 两种。

选择HMI内部时钟时，下面的地址框用户不可见，以静态文本注释的方式显示:SRW0~7：年/月/日/时/分/秒/星期/毫秒。当选择外部装置时，默认地址也是SRW0，但可以通过后面的地址框设置一个地址作为时钟源


映射端口顺序

选择COM口，比如COM2，点击“上移”、“恢复”、“下移”，调整COM口的映射顺序，交换串口


暂停控制

位控制，值为0持续采样，为1暂停


每通道单次采集点数

设置每通道单次采集点数，范围是1~255


清除控制

位控制，值为1则清除内存中所有记录，清除完自动复位


滚动条

滚动条：元件的属性中没有设置滚动条宽度情况下，但是有滚动条，以这里的设置为准，比如，弹出窗口的滚动条宽度为20


点亮背光灯

触发条件满足，点亮背光灯


熄灭背光灯

触发条件满足，熄灭背光灯


用户等级数目

默认3，范围是1-16，最多支持16个密码等级


电源开启时执行

勾选了电源开启执行/结束执行，在范围内启动，就执行开始，在时间范围外启动执行结束

指定星期：可以没有结束时间（没有结束时间的时候，勾选了电源开启执行/结束执行无效）

隔日：必须设置结束时间


矢量字体

矢量字体：根据检查用户字体属性设置情况，将用户用到的文字从相应字体字库中拣出，并处理成 TrueType 字体文件（ttf 格式）来供 HMI 使用

矢量字体的缺点：仅支持当前操作系统安装的 TrueType 类型字体（ttf 格式），另外，还有边缘模糊问题，“禁用矢量字体边缘模糊处理”，在工程树/扩展属性下设置

矢量字体的优点：占用内存容量较小。通过在字体文件中截取字模的方法，可以充分减少字体文件的大小。同一文字的在同字体中不论大小、颜色、粗斜体只用截取一个字模信息，字号齐全且可自由设置不变形


禁用矢量字体边缘模糊处理

勾选“禁用矢量字体边缘模糊处理”，字体显示有毛刺，看起来不平滑，不太好看，但是，速度上要快些，在字体要求不高的情况下可以勾选，获得更快的速度

勾选“禁用矢量字体边缘模糊处理”
不勾选“禁用矢量字体边缘模糊处理”


等级描述

用户可以自定义等级描述，方便用户编程


粗体斜体

支持粗体/斜体

下图展示：正常 粗体 斜体 （效果）


紧急级别

可以设置高、中、低


组别

新建的时候可以设置，第1组~第32组，新建后，不能修改


结束时执行

开始时执行/结束时执行


背光灯控制

切换基本窗口/报告当前窗口号/背光灯控制/执行宏指令


背光灯调节为最低亮度

触发条件满足，背光灯调节为最低亮度


蜂鸣器

仅勾选使用蜂鸣器，触控HMI的有效控件时候，比如按钮，发出指定时间的蜂鸣音

如果还勾选了使能控制，比如LB0，当LB0为ON，才使用蜂鸣器，触控HMI的有效控件时候，才发出蜂鸣声，为OFF，触控HMI没有声音

蜂鸣时间：50、75、100、150、200、300、500、800，以上单位mS，直到1S


触发宏

执行指定宏


触发式采样方式

触发式：触发条件满足后，数据采样才触发

触发方式：位触发，字触发

位触发的触发条件：ON<->OFF、ON->OFF、OFF->ON，仅位触发式，可以选择自动复位，触发完，设置位自动复位

字触发的触发条件：>、<、<=、>=、==、!=， [image] 代表与或非运算，举例：LW0>1(AND)LW0<10


触发条件

位状态改变：ON<->OFF、ON->OFF、OFF->ON

自动复位：只有位触发方式，可以选择自动复位

字值改变：只要值改变了，就触发

条件判断：点增加，可以设置多个条件


触发蜂鸣器

勾选，报警事件触发后，蜂鸣器响，比如10秒，勾选持续蜂鸣直到恢复或确认，只要恢复或确认，蜂鸣器立即不响


触控音

勾选使用声音后，所有声音的播放可用，默认选中。

如果还勾选了使能控制，比如LB1，当LB1为ON，设置了声音的地方都可以使用声音，为OFF，设置了声音的地方均不会使用声音。

注意：比如，元件的控制设置中可以设置声音，声音文件通过声音库导入，当全局设置中，使用触控音不勾选，即使元件的控制设置中设置了声音，元件也无法使用声音。


语种条目

每个语种都要不一样，用户最多可以设置32个不同的语种，默认语种1是中文，语种2是英语


调低亮度

时间到，调低亮度，比如3，等待3分钟后，HMI自动调低亮度，至“最低、10%、20%、30%、50%、80%”


退出屏保

设置后，要退出屏保窗口，首先弹出“请输入密码”的系统窗口，如果设置密码等级是3级，需要输入3级或3级以上的密码才能退出屏保窗口

注意，输入密码，字符输入元件（SRW100~103，共4个字）


通道设置

属性设置/通道设置


通道设置之类型

支持16位无符号数、16位有符号数、32位无符号数、32位有符号数、16位BCD、32位BCD、单精度浮点数、字符串


隔日

开始时间与结束时间，可以跨星期执行

隔日，开始时间的星期只能单选，且必须设置结束时间


隔日条目

任务计划

指定星期/隔日/地址变量


打开工程

快捷图标：

快捷键： <Ctrl>+<O>

此命令打开一个已存在的工程，不可打开重复的工程

请点击下图设置参数了解详细信息

软件打开后，用户直接找到工程目录，打开后缀名为*.fsprj的工程文件，点击打开，即可打开工程

备注：在软件正常安装的情况下，用户还可以直接进入工程目录，双击后缀名为*.fsprj的工程文件，直接打开工程，不需要打开软件后，找到工程文件再打开工程


文件名

找到工程文件后，显示工程名称


文件格式

工程的主目录下，仅有一个后缀名为*.fsprj的工程文件，其他是文件夹


A按键

可以根据名称的首字母或者拼音首字母快速定位到相关文本库条目


引用

显示工程里使用该文本条目的引用的次数


折叠

- ：折叠该文本条目

+：展开该文本条目


拖拉

如果文本内容显示不全，用户可以拖拉该处，让文本内容显示全


按名称排序

点击后，列表的名称，根据常规算法进行排序


搜索

点击后，搜索，把符合搜索内容的条目过滤出来，显示在下面


搜索框

输入搜索的文本条目名称包含的内容


文本名称

文本库每个条目的名称


文本条目

分语种显示，可以设置不同语种下的文本内容


显示所有语种

不管语种显示里是否勾选，点击后，显示所有语种


状态数

支持1~255种状态


语种显示条目

勾选需要显示的语种，不勾选的条目，在文本库的窗口上，将不显示该语种的相关内容


预览框

文本内容预览框


HMI替换

选择好型号后，将关闭并保存所有窗口


HMI设备型号

用户可以选择对应HMI的设备型号，不同的型号，产品描述同步刷新


HMI设置

注意：COM1/COM2支持3种通讯类型，COM3/COM4只支持RS232

COM1/COM3或COM2/COM4 通讯端口 9 针 D 型公座管脚排列图。 这个端口从外观上看是一个端口， 实际上可以当 2 个端口来使用， COM1/COM2是通讯口，可以与 PLC 以 RS232/RS485-2/RS485-4通讯，COM3/COM4 主要是连接 PC的编程口和设置口， 还可以作为通讯口使用，但是只支持 RS232 方式

COM1/COM3 [image] COM2/COM4

管脚 | RS232 |  | RS485-2 COM1/COM2 | RS485-4 COM1/COM2
 | COM3/COM4 | COM1/COM2
1 |  |  | RX-（B） | RX-（B）
2 |  | RXD |  |
3 |  | TXD |  |
4 |  |  |  | TX-
5 | GND | GND |  |
6 |  |  | RX+（A） | RX+（A）
7 | RXD |  |  |
8 | TXD |  |  |
9 |  |  |  | TX+


IP地址

IP地址可以使用固定或变量两种方式

固定：直接输入，比如192.168.0.1

变量：选择首地址，仅本地RW地址（掉电保存的本地地址）可选，占用4个字地址，比如，RW0~3


从设备号

当前编程的HMI的站号，可以设置成常数或变量


位置

工程创建成功后，显示工程存放于电脑上的路径


制造商

连接的从设备的制造商，比如繁易


名称

工程的名称，工程创建成功后，会生成一个以这个名称命名的文件夹，文件夹作为一个整体统称工程文件夹，存放相应的文件，若单独操作其中某个文件可能会破坏掉工程的结构，从而导致工程无法打开

备注：工程文件夹简称工程


屏幕尺寸

用户可以选择对应HMI的尺寸，比如7（英寸）


广播站号

勾选后，启用广播站号，比如modbus，255是广播站号，只要255站号的modbus设备发出的数据帧，所有连接的modbus设备且支持广播站号都可以收到，只不过，不用回复

注意：广播站号，只对支持广播站号的有效，如果设备不支持，勾选了也是没有用的


恢复默认

用户修改了通讯设置，点击此按钮，可以恢复默认设置


所在COM口

选择连接远程HMI的COM口，可以访问连接在该COM口上的PLC设备


提供服务

COM1/COM2/COM3/COM4


服务的设备类型

HMI做从设备，比如，HMI支持Modbus RTU Server的服务

如果是网络服务，HMI做从设备，支持Modbus TCP Server的服务


未使用

默认即选中未使用，表示不使用COM口通讯


本地IP

HMI设置IP为静态IP时，本地IP显示静态IP设置的地址。选择动态IP时，显示“动态获得” 4个字


浏览

弹出“浏览文件夹”对话框，方便查看，明确存放工程的路径


端口号

可以设置为常数或变量，如果是变量，仅占一个字


网络PLC条目

请点击下图设置参数了解详细信息


网络服务

请点击下图设置参数了解详细信息


网络服务的端口号

此处，只能输入常数


自动获取IP地址（DHCP）

注意，用户可以使用系统位寄存器SRB10000切换自动或静态分配IP地址，IP地址等其他设置，可以用数值显示元件进行查看（仅显示），依次对应使用，SRW10010~13：IP地址，每个WORD表示一个网段，SRW10014~17： 子网掩码，SRW10018~21：网关，SRW10022~25：DNS1，SRW10026~29：DNS2，查看HMI自动获取的IP地址等相关信息


设备别名

用户可以设置一个设备别名，方便编程时识别


设备类型

连接的从设备，设备类型，比如Flexem FL2N


远程HMI

请点击下图设置参数了解详细信息


远程HMI的设备类型

远程HMI的设备类型，比如FS7


通讯设置

通讯类型：RS232、RS485-2、RS485-4，波特率：110、300、600、1200、2400、4800、9600、14400、19200、38400、56000、57600、115200、187500，数据位：7、8，停止位：1、2，校验位：无、奇、偶


静态分配IP地址

用户可以输入IP地址及其他参数，工程下载到HMI上，使用该以太网设置

注意，用户可以使用系统位寄存器SRB10000切换自动或静态分配IP地址，IP地址等其他设置，可以用数值输入元件，依次对应使用，SRW10010~13：IP地址，每个WORD表示一个网段，SRW10014~17： 子网掩码，SRW10018~21：网关，SRW10022~25：DNS1，SRW10026~29：DNS2


预设站号

常数，用户可以输入固定的站号，变量，站号根据变量的值跟着改变


屏幕分辨率

用户可以选择对应HMI的屏幕分辨率，比如800*480


高级设置

修改通讯超时等参数，用户不能随便修改，否则可能导致通讯失败或出现不可预期的异常现象


XY宽高

图片在窗口上的坐标位置及图片的宽高（窗口左上角为坐标原点，向右X坐标，向下Y坐标，水平方向为宽，垂直方向为高）


位设定

让设定位，值为ON或OFF


使用图片原始尺寸

点击后，让图片以原始尺寸显示


公共窗口

公共窗口的属性和元件作用于所有基本窗口

通过添加按钮可添加：动作与功能/定时器/定时数据传输

双击公共窗口后，即可通过下图设置相应的窗口属性：

请点击下图设置参数了解详细信息


写入前写入后

写入前：数据传输准备好了，先执行写入前的动作，执行完后，再执行数据传输

写入后：数据传输完成后，也就是说，最后一个位或字都传完了，再执行写入后动作


切换页面

切换到指定窗口


动作与功能

根据动作或条件，执行相应的设置

请点击下图设置参数了解详细信息


动作或条件

窗口初始化时、窗口退出时、向左滑动、向右滑动、向上滑动、向下滑动


取色

选择需要的颜色，还可以通过吸管吸取颜色


启动画面

设置屏幕开启时的第一个画面，用户可根据需要自行选定

请点击下图设置参数了解详细信息


图案填充

设置窗口背景为图案填充，同时，可以修改图样色、背景色


图片

用户可以使用图片作为窗口的背景，图片撑满整个窗口，需要选择合适的图片，否则图片会失真


图片居中

点击后，让图片处于窗口的中间


图片满屏

点击后，让图片撑满窗口


基本窗口

基本属性/背景与边框/动作与功能/定时器/定时数据传输

请点击下图设置参数了解详细信息


基本窗口的动作与功能

基本窗口

基本属性/背景与边框/动作与功能/定时器/定时数据传输


基本窗口的定时器

基本窗口

基本属性/背景与边框/动作与功能/定时器/定时数据传输


基本窗口的定时数据传输

基本窗口

基本属性/背景与边框/动作与功能/定时器/定时数据传输


基本窗口的背景与边框

基本窗口

基本属性/背景与边框/动作与功能/定时器/定时数据传输


外框宽度

用户可以修改窗口的外框宽度


外框颜色

用户可以修改窗口的外框颜色，可以用吸管拾取


字设定

让设定字，值为常数或变量


定时器

触发与停止/定时器功能


定时器功能

定时器

触发与停止/定时器功能


定时数据传输

触发与停止/数据传输/通知


宽度高度

用户可以修改窗口的宽度和高度，如果不勾选打印页，该型号，最大只能设置成800*480


导入图片

支持图片格式为BMP、JPG、GIF、PNG


延时

勾选，设置定时器初次执行的延时时间，延时设定时间后，再执行定时器功能


弹出窗口

可以设置弹出窗口显示于屏幕正中或自定义位置

显示标题栏：勾选后，用户可以设置标题栏

垄断：勾选后，弹出窗口下面的后台窗口将无法触控

关闭窗口：右上角有个关闭按钮，可以关闭弹出窗口

标题框（设置按钮）：可以设置标题内容


打印页

勾选后，可以修改画面的宽度及高度，最大可以达到2048*2048，如果打印机可以支持，可以打印更大的图片


执行周期

设置定时器的执行周期，触发条件满足且结束条件不满足，每次间隔设定的周期时间，执行一次，直到结束条件满足，停止


执行宏指令

执行指定的宏指令


数据传输

定时数据传输

触发与停止/数据传输/通知


数据类型

传输字数：数据类型选择字，可以设置常数或变量

传输位数：数据类型选择位，可以设置常数或变量


新建基本窗口

双击窗口里的 [image] 或者右键基本窗口新建窗口，并弹出如下图所示窗口，设置完毕，确定即可

基本属性/背景与边框/动作与功能/定时器/定时数据传输

请点击下图设置参数了解详细信息


新建基本窗口的动作与功能

动作与功能

基本属性/背景与边框/动作与功能/定时器/定时数据传输

在窗口初始化时，给窗口增加一些动作和功能

请点击下图设置参数了解详细信息


新建基本窗口的定时器

定时器

基本属性/背景与边框/动作与功能/定时器/定时数据传输

定时器元件附属于窗口，可以通过窗口增加定时器，也可以通过元件为窗口增加定时器功能

请点击下图设置参数了解详细信息


新建基本窗口的定时数据传输

定时数据传输

基本属性/背景与边框/动作与功能/定时器/定时数据传输

定时数据传输元件附属于窗口，可以通过窗口增加定时数据传输，也可以通过元件为窗口增加定时数据传输功能

请点击下图设置参数了解详细信息


新建基本窗口的背景与边框

背景与边框

基本属性/背景与边框/动作与功能/定时器/定时数据传输

设置基本窗口的背景色与边框

请点击下图设置参数了解详细信息


淡入淡出

淡入：窗口由暗转亮，最后完全清晰

淡出：窗口由亮转暗，以至完全隐没


添加等

通过此排按钮设置相应的公共窗口属性


渐变填充

设置窗口背景为渐变填充，同时，可以修改图样色、背景色，还可以修改渐变方向及变形效果


状态设置

设置位：设置指定位地址，置ON、置OFF、周期切换（取反）

设置字：设置指定字地址，加、减、设置常数，详见元件的开关部分


用户等级

设置窗口的用户等级


窗口关闭时切换到用户等级

用户可以设置，窗口关闭时切换回低的用户等级，下次进入时还需要输入密码


窗口属性

设置好的窗口属性将出现在这里


窗口描述

用户可以自定义窗口描述，方便编程识别


窗口编号

新建窗口，根据编号方式，自定义或插入窗口编号，可以修改编号，其他软件自动生成

修改窗口，用户可以修改编号，如果修改成其他存在的编号，会出现红色叹号，不能确定


窗口透明度

0%（不透明）、20%、50%、80%、100%（全透明）


纯色

设置背景为单一的颜色，可以用吸管拾取


结束条件

将在窗口关闭时停止：窗口关闭时，停止

到达指定次数停止：可以设置常数或变量，次数到了，停止

条件判断：可以设置多个条目，条件满足，停止

触发条件不满足：仅当触发条件选择条件判断才可以设置，当触发条件不满足，停止


编号方式

置于空缺位、置于最后、自定义、插入窗口编号


触发宏指令

让指定的宏指令运行


触发条件

位状态改变：ON<->OFF、ON->OFF、OFF->ON，自动复位：只要位触发式，可以选择自动复位

字值改变：只要值改变了，就触发

条件判断：点增加，可以设置多个条件

窗口打开时触发：窗口打开时，触发，如果是公共窗口，则一直处于触发状态

窗口关闭时触发：窗口关闭时，触发，如果是公共窗口，不会关闭，所以该选项不适合公共窗口，其他窗口可以设置


通知

定时数据传输

触发与停止/数据传输/通知


通知位地址

让指定位，值为ON或OFF


通知字地址

让指定字，值为常数或变量


重叠窗口

用户可以设置多个重叠窗口，底层、中层、顶层


位地址范围

数据项中，条目数跟数据类型确定后，位地址范围也确定了，一个字占16个位


使用外部地址作配方索引

用户可以自定义配方索引


名称

输入用户容易识别的名称，方便以后编程


地址偏移

根据数据类型和数组数据，软件自动计算


字地址范围

数据项中，条目数跟数据类型确定后，字地址范围也确定了


当前配方编号寄存器

当前配方索引寄存器，值改变，配方索引跟着改变


数据类型

可以选择，16位无符号数、16位有符号数、32位无符号数、32位有符号数、16位BCD、32位BCD、单精度浮点数、字符串


数据项

新建配方

一般属性/数据项


数组数据

长度范围1~65535


清除全部

位控制，值为ON，清除全部配方，清除完成后会复位


清除当前

位控制，值为ON，清除当前编号的配方，清除完成后会复位


清除配方

该用例，为了方便用户查看，在数值输入的左上角，放置一个文本，组成组合，多重复制后得到一组8*6（8行6列）数组，修改对应的文本，地址分别为4X1~4X48

功能键执行宏

下面详细介绍配方

在菜单栏，选择元件/开关/配方传输，此处，PLC源地址使用索引地址

当LW0=0，4X1~4X8的值1~8，RPI_a 0=0，点击配方传输，RPW_a 0~RPW_a 7的值为1~8

当LW0=8，4X9（1+8）~4X16（8+8）的值9~16，RPI_a 0=1，点击配方传输，RPW_a 0~RPW_a 7的值为9~16

当LW0=16，4X17（1+16）~4X24（8+16）的值17~24，RPI_a 0=2，点击配方传输，RPW_a 0~RPW_a 7的值为17~24

当LW0=24，4X25（1+24）~4X32（8+24）的值25~32，RPI_a 0=3，点击配方传输，RPW_a 0~RPW_a 7的值为25~32

当LW0=32，4X33（1+32）~4X40（8+32）的值33~40，RPI_a 0=4，点击配方传输，RPW_a 0~RPW_a 7的值为33~40

当LW0=40，4X41（1+40）~4X48（8+40）的值41~48，RPI_a 0=5，点击配方传输，RPW_a 0~RPW_a 7的值为41~48

注意，下面详细说明清除当前配方以及清除全部配方

比如，RPI_a 0=5，点击清除当前配方，可以看到，RPW_a 0~RPW_a 7的值立即都变成了0

如果点击清除全部配方，不管RPI_a 0的值是多少，RPW_a 0~RPW_a 7的值立即都变成了0


蛋糕配方

蛋糕配方（用户可以根据实际情况，把常用的数据保存到配方，再根据订单要求，获得配方数据，进行生产）

如果把配方看成是一个二维的参数表，参数表的行，表示配方的一个变量的数据，参数表的列，表示一组配方。

以上使用了等宽表格、静态文本、字设定/加、字设定/减、数值输入（数据格式：16位无符号数）

下面详细说明配方的设置，另外还使用了宏（窗口属性中增加定时器执行宏），方便模拟查看：

#include <macro.h>

int MacroMain()

{

// 这里添加代码

short index;

index=GetWord(@Index@,0);

switch(index)

{

case 0:

{

SetWord(@Recipe@,0,5);

SetWord(@Recipe@,1,5);

SetWord(@Recipe@,2,100);

SetWord(@Recipe@,3,75);

SetWord(@Recipe@,4,60);

SetWord(@Recipe@,5,0);

break;

}

case 1:

{

SetWord(@Recipe@,0,5);

SetWord(@Recipe@,1,5);

SetWord(@Recipe@,2,100);

SetWord(@Recipe@,3,50);

SetWord(@Recipe@,4,100);

SetWord(@Recipe@,5,0);

break;

}

case 2:

{

SetWord(@Recipe@,0,5);

SetWord(@Recipe@,1,5);

SetWord(@Recipe@,2,80);

SetWord(@Recipe@,3,75);

SetWord(@Recipe@,4,60);

SetWord(@Recipe@,5,1);

break;

}

case 3:

{

SetWord(@Recipe@,0,5);

SetWord(@Recipe@,1,5);

SetWord(@Recipe@,2,50);

SetWord(@Recipe@,3,60);

SetWord(@Recipe@,4,60);

SetWord(@Recipe@,5,1);

break;

}

case 4:

{

SetWord(@Recipe@,0,4);

SetWord(@Recipe@,1,4);

SetWord(@Recipe@,2,70);

SetWord(@Recipe@,3,40);

SetWord(@Recipe@,4,0);

SetWord(@Recipe@,5,200);

break;

}

default: break;

}

return 0;

}

名称 | 蛋黄（变量1） | 蛋白（变量2） | 面粉（变量3） | 白糖（变量4） | 牛奶（变量5） | 其他（变量6）
配方地址 | RPW_a 0 | RPW_a 1 | RPW_a 2 | RPW_a 3 | RPW_a 4 | RPW_a 5
数据类型 | 16位无符号数 | 16位无符号数 | 16位无符号数 | 16位无符号数 | 16位无符号数 | 16位无符号数
字数 | 1 | 1 | 1 | 1 | 1 | 1

当RPI_a 0的值为0，RPW_a 0的值为5，RPW_a 1的值为5，RPW_a 2的值为100，RPW_a 3的值为75，RPW_a 4的值为60，RPW_a 5的值为0。

当RPI_a 0的值为4，RPW_a 0的值为4，RPW_a 1的值为4，RPW_a 2的值为70，RPW_a 3的值为40，RPW_a 4的值为0，RPW_a 5的值为200。

其他依此类推。


配方条目的名称


配方模板

如果把配方看成是一个二维的参数表，参数表的行，表示配方的一个变量的数据，参数表的列，表示一组配方。

以上使用了等宽表格、静态文本、字设定/加、字设定/减、数值输入（数据格式：16位/32位无符号数、16位/32位有符号数、单精度浮点数）

下面详细说明配方的设置，另外还使用了宏（窗口属性中增加定时器执行宏），方便模拟查看：

#include <macro.h>

int MacroMain()

{

// 这里添加代码

short index;

index=GetWord(@Index@,0);

switch(index)

{

case 0:

{

SetWord(@Recipe@,0,7);

SetWord(@Recipe@,1,-16);

SetDWord(@Recipe@,2,99999);

SetDWord(@Recipe@,4,-99999);

SetFloat(@Recipe@,6,123.56);

break;

}

case 1:

{

SetWord(@Recipe@,0,96);

SetWord(@Recipe@,1,113);

SetDWord(@Recipe@,2,878);

SetDWord(@Recipe@,4,5600);

SetFloat(@Recipe@,6,-11.25);

break;

}

case 2:

{

SetWord(@Recipe@,0,60);

SetWord(@Recipe@,1,-60);

SetDWord(@Recipe@,2,600);

SetDWord(@Recipe@,4,-600);

SetFloat(@Recipe@,6,66.66);

break;

}

case 3:

{

SetWord(@Recipe@,0,32767);

SetWord(@Recipe@,1,-32768);

SetDWord(@Recipe@,2,100000);

SetDWord(@Recipe@,4,-100000);

SetFloat(@Recipe@,6,50.5);

break;

}

case 4:

{

SetWord(@Recipe@,0,40);

SetWord(@Recipe@,1,59);

SetDWord(@Recipe@,2,789);

SetDWord(@Recipe@,4,-16581);

SetFloat(@Recipe@,6,100);

break;

}

default: break;

}

return 0;

}

名称 | 变量1 | 变量2 | 变量3 | 变量4 | 变量5
配方地址 | RPW_a 0 | RPW_a 1 | RPW_a 2 RPW_a 3 | RPW_a 4 RPW_a 5 | RPW_a 6 RPW_a 7
数据类型 | 16位无符号数 | 16位有符号数 | 32位无符号数 | 32位有符号数 | 单精度浮点数
字数 | 1 | 1 | 2 | 2 | 2

当RPI_a 0的值为0，RPW_a 0的值为7，RPW_a 1的值为-16，RPW_a 2（2个字）的值为99999，RPW_a 4（2个字）的值为-99999，RPW_a 6（2个字）的值为123.56。

当RPI_a 0的值为4，RPW_a 0的值为40，RPW_a 1的值为59，RPW_a 2（2个字）的值为789，RPW_a 4（2个字）的值为-16581，RPW_a 6（2个字）的值为100.00。

其他依此类推。


配方长度

数据项中，条目数跟数据类型决定了这个配方长度


条件判断

见下图，可自由发挥，增加条件。如：当LB0为ON时执行触控触发功能


模拟单击

模拟单击的手势


模拟滑动

模拟滑动的手势，设置两个字地址，代表滑动的角度和滑动的速度


模拟缩放

模拟缩放的手势，设置一个字地址，表示缩放的比例


暂停

设定位地址，如LB0，则当 LB0 的状态为 ON 时，画面将暂停刷新，为 OFF 时，将继续刷新显示趋势图变化

PS：“暂停”功能仅暂停刷新曲线变化，并不会暂停取样动作


每屏显示点数

显示的采样点数

PS：可设2~799，每采样一个数据产生一个点数


游标

通过移动游标可以查看每个采样点的详细信息

PS：通过点击趋势图可以移动游标的位置


缩放

缩放可以控制当前显示的数据点数


X轴刻度

设置X轴的主刻度、次刻度、网格和标记的显示

PS：此图“使用的是点数刻度值”，用户也可“使用时间刻度值”


Y轴刻度

设置Y轴的主刻度、次刻度、网格和标记的显示


刻度

设置趋势图的刻度显示

请点击下图设置参数了解详细信息


刻度最大最小值

  • 使用通道的最大值和最小值：当多个通道并且每个通道的最大最小值不一样时，其他通道的值将与被选的通道的值，进行比例换算显示

例：2个通道，选择通道1的值作为刻度，通道1的最大值为100，最小值为0。通道2的最大值为10，最小值为0

结果：比例值为（100-0）/（10-0）=10，当通道2的值为3时，刻度将显示为3*10=30

  • 使用自定义的值为最大值和最小值：当通道的最小值小于自定义的最小值时，按照自定义的最小值显示。当通道的最大值大于自定义的最大值时，按照自定义的最大值显示


背景色

设置刻度区颜色、背景色


寄存器控制查询方式

 选择寄存器控制查询方式后，见下图


按顺序查询

选择按顺序查询后，见下图说明


查询

通过设置条件，过滤数据

请点击下图设置参数了解详细信息


数据来源

选择数据来源

详见“工程-数据采样-新建”，或可通过 [image] 点击进入设置


线设置

设置画点颜色、画点大小、画点类型

设置连接线的颜色、线条宽度、线条类型

按照线条的颜色，向X轴方向投影

最小值：可通过常量或者变量来设置。如通道地址值低于最小值，按最小值显示

最大值：可通过常量或者变量来设置。如通道地址值高于最大值，按最大值显示


通道

通道为趋势图的数据来源

请点击下图设置参数了解详细信息


通道设置

双击通道条目，可以进入通道设置


PLC地址

选择本地，或者已经连接的PLC地址


下载配方到PLC

从配方源地址下载到PLC地址


从PLC上传配方

从PLC源地址上传到配方地址。设置与下载配方到PLC一样


字数

根据已建好配方的大小自动生成


打开配方设置

通过此按钮可以查看并修改配方


通知位地址

选择一个位地址，当配方下载或者上传过程中，“配方位地址”会一直处于ON状态，传输完毕，会置为OFF


配方源地址

选择已经建好的配方，即可有配方地址，请参考：新建配方